All of lore.kernel.org
 help / color / mirror / Atom feed
From: Kalle Valo <kvalo@qca.qualcomm.com>
To: ath9k-devel@lists.ath9k.org
Subject: [ath9k-devel] [PATCH v2 1/3] ath10k: implement device recovery
Date: Fri, 5 Jul 2013 10:47:36 +0300	[thread overview]
Message-ID: <87bo6hh2hz.fsf@kamboji.qca.qualcomm.com> (raw)
In-Reply-To: <1372148011-28234-2-git-send-email-michal.kazior@tieto.com> (Michal Kazior's message of "Tue, 25 Jun 2013 10:13:29 +0200")

Michal Kazior <michal.kazior@tieto.com> writes:

> Restart the hardware if FW crashes.
>
> If FW crashes during recovery we leave the
> hardware in a "wedged" state to avoid recursive
> recoveries.
>
> When in "wedged" state userspace may bring
> interfaces down (to issue stop()) and then bring
> one interface (to issue start()) to reload
> hardware manually.
>
> Signed-off-by: Michal Kazior <michal.kazior@tieto.com>

[...]

> --- a/drivers/net/wireless/ath/ath10k/core.h
> +++ b/drivers/net/wireless/ath/ath10k/core.h
> @@ -250,6 +250,20 @@ struct ath10k_debug {
>  enum ath10k_state {
>  	ATH10K_STATE_OFF = 0,
>  	ATH10K_STATE_ON,
> +
> +	/* When doing firmware recovery the device is first powered down.
> +	 * mac80211 is supposed to call in to start() hook later on. It is
> +	 * however possible that driver unloading and firmware crash overlap.
> +	 * mac80211 can wait on conf_mutex in stop() while the device is
> +	 * stopped in ath10k_core_restart() work holding conf_mutex. */
> +	ATH10K_STATE_RESTARTING_OFF,
> +	ATH10K_STATE_RESTARTING_ON,

I feel that RESTARTING_OFF and RESTARTING_ON are a bit confusing names,
especially when we have OFF and ON states. Wouldn't RESTARTING and
RESTARTED be simpler?

-- 
Kalle Valo

  reply	other threads:[~2013-07-05  7:47 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <8c0a4f68cc3454b77a21ab949075fb0632549bb9>
2013-06-25  8:13 ` [ath9k-devel] [PATCH v2 0/3] ath10k: hardware recovery Michal Kazior
2013-06-25  8:13   ` [ath9k-devel] [PATCH v2 1/3] ath10k: implement device recovery Michal Kazior
2013-07-05  7:47     ` Kalle Valo [this message]
2013-07-05  8:05       ` Michal Kazior
2013-07-15  7:19         ` Kalle Valo
2013-07-15  7:19           ` Kalle Valo
2013-06-25  8:13   ` [ath9k-devel] [PATCH v2 2/3] ath10k: implement fw crash simulation command Michal Kazior
2013-06-25  8:13   ` [ath9k-devel] [PATCH v2 3/3] ath10k: create debugfs interface to trigger fw crash Michal Kazior
2013-07-16  7:54   ` [PATCH v3 0/3] ath10k: hardware recovery Michal Kazior
2013-07-16  7:54     ` Michal Kazior
2013-07-16  7:54     ` [PATCH v3 1/3] ath10k: implement device recovery Michal Kazior
2013-07-16  7:54       ` Michal Kazior
2013-07-16  7:54     ` [PATCH v3 2/3] ath10k: implement fw crash simulation command Michal Kazior
2013-07-16  7:54       ` Michal Kazior
2013-07-16  7:54     ` [PATCH v3 3/3] ath10k: create debugfs interface to trigger fw crash Michal Kazior
2013-07-16  7:54       ` Michal Kazior
2013-07-19 10:29       ` Kalle Valo
2013-07-19 10:29         ` Kalle Valo
2013-07-20  6:01         ` Kalle Valo
2013-07-20  6:01           ` Kalle Valo
2013-07-22 12:08           ` [PATCH v4] " Michal Kazior
2013-07-22 12:08             ` Michal Kazior
2013-07-23  8:02             ` Kalle Valo
2013-07-23  8:02               ` Kalle Valo
2013-07-19 10:32     ` [PATCH v3 0/3] ath10k: hardware recovery Kalle Valo
2013-07-19 10:32       ` Kalle Valo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87bo6hh2hz.fsf@kamboji.qca.qualcomm.com \
    --to=kvalo@qca.qualcomm.com \
    --cc=ath9k-devel@lists.ath9k.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.