From: Kalle Valo <kvalo@qca.qualcomm.com>
To: Michal Kazior <michal.kazior@tieto.com>
Cc: "ath9k-devel@lists.ath9k.org" <ath9k-devel@lists.ath9k.org>,
ath10k@lists.infradead.org
Subject: Re: [ath9k-devel] [PATCH v2 1/3] ath10k: implement device recovery
Date: Mon, 15 Jul 2013 10:19:16 +0300 [thread overview]
Message-ID: <87r4f0p9xn.fsf@kamboji.qca.qualcomm.com> (raw)
In-Reply-To: <CA+BoTQkJLTLRrO41bNJ+x1fAKb39AQ2J4QfinFbE4=BqwPu0VQ@mail.gmail.com> (Michal Kazior's message of "Fri, 5 Jul 2013 10:05:36 +0200")
Hi Michal,
sorry, I forgot to answer this one.
Michal Kazior <michal.kazior@tieto.com> writes:
> On 5 July 2013 09:47, Kalle Valo <kvalo@qca.qualcomm.com> wrote:
>
>> I feel that RESTARTING_OFF and RESTARTING_ON are a bit confusing names,
>> especially when we have OFF and ON states. Wouldn't RESTARTING and
>> RESTARTED be simpler?
>
> RESTARTING/RESTARTED seems confusing to me too. The whole thing
> shouldn't be considered restarted until mac80211 calls in
> restart_complete() - but then again, at that point we should consider
> the state as STATE_ON (and we do). Having RESTARTING_OFF / _ON gives
> off more info about the state hw is in.
>
> Ideally we should have only one state - RESTARTING and guarantee that
> the hw is in a workable state before we call in for
> ieee80211_restart_hw(). We'd need to skip hw startup in ath10k_start()
> in that case and make some code from ath10k_start() reusable and
> callable from ath10k_core_start().
>
> I can't really remember the reason I went with this particular design
> now. Perhaps this can be addressed in follow up patches later?
I would prefer that you still rename the states to what I suggested.
--
Kalle Valo
_______________________________________________
ath10k mailing list
ath10k@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/ath10k
WARNING: multiple messages have this Message-ID (diff)
From: Kalle Valo <kvalo@qca.qualcomm.com>
To: ath9k-devel@lists.ath9k.org
Subject: [ath9k-devel] [PATCH v2 1/3] ath10k: implement device recovery
Date: Mon, 15 Jul 2013 10:19:16 +0300 [thread overview]
Message-ID: <87r4f0p9xn.fsf@kamboji.qca.qualcomm.com> (raw)
In-Reply-To: <CA+BoTQkJLTLRrO41bNJ+x1fAKb39AQ2J4QfinFbE4=BqwPu0VQ@mail.gmail.com> (Michal Kazior's message of "Fri, 5 Jul 2013 10:05:36 +0200")
Hi Michal,
sorry, I forgot to answer this one.
Michal Kazior <michal.kazior@tieto.com> writes:
> On 5 July 2013 09:47, Kalle Valo <kvalo@qca.qualcomm.com> wrote:
>
>> I feel that RESTARTING_OFF and RESTARTING_ON are a bit confusing names,
>> especially when we have OFF and ON states. Wouldn't RESTARTING and
>> RESTARTED be simpler?
>
> RESTARTING/RESTARTED seems confusing to me too. The whole thing
> shouldn't be considered restarted until mac80211 calls in
> restart_complete() - but then again, at that point we should consider
> the state as STATE_ON (and we do). Having RESTARTING_OFF / _ON gives
> off more info about the state hw is in.
>
> Ideally we should have only one state - RESTARTING and guarantee that
> the hw is in a workable state before we call in for
> ieee80211_restart_hw(). We'd need to skip hw startup in ath10k_start()
> in that case and make some code from ath10k_start() reusable and
> callable from ath10k_core_start().
>
> I can't really remember the reason I went with this particular design
> now. Perhaps this can be addressed in follow up patches later?
I would prefer that you still rename the states to what I suggested.
--
Kalle Valo
next prev parent reply other threads:[~2013-07-15 7:19 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <8c0a4f68cc3454b77a21ab949075fb0632549bb9>
2013-06-25 8:13 ` [ath9k-devel] [PATCH v2 0/3] ath10k: hardware recovery Michal Kazior
2013-06-25 8:13 ` [ath9k-devel] [PATCH v2 1/3] ath10k: implement device recovery Michal Kazior
2013-07-05 7:47 ` Kalle Valo
2013-07-05 8:05 ` Michal Kazior
2013-07-15 7:19 ` Kalle Valo [this message]
2013-07-15 7:19 ` Kalle Valo
2013-06-25 8:13 ` [ath9k-devel] [PATCH v2 2/3] ath10k: implement fw crash simulation command Michal Kazior
2013-06-25 8:13 ` [ath9k-devel] [PATCH v2 3/3] ath10k: create debugfs interface to trigger fw crash Michal Kazior
2013-07-16 7:54 ` [PATCH v3 0/3] ath10k: hardware recovery Michal Kazior
2013-07-16 7:54 ` Michal Kazior
2013-07-16 7:54 ` [PATCH v3 1/3] ath10k: implement device recovery Michal Kazior
2013-07-16 7:54 ` Michal Kazior
2013-07-16 7:54 ` [PATCH v3 2/3] ath10k: implement fw crash simulation command Michal Kazior
2013-07-16 7:54 ` Michal Kazior
2013-07-16 7:54 ` [PATCH v3 3/3] ath10k: create debugfs interface to trigger fw crash Michal Kazior
2013-07-16 7:54 ` Michal Kazior
2013-07-19 10:29 ` Kalle Valo
2013-07-19 10:29 ` Kalle Valo
2013-07-20 6:01 ` Kalle Valo
2013-07-20 6:01 ` Kalle Valo
2013-07-22 12:08 ` [PATCH v4] " Michal Kazior
2013-07-22 12:08 ` Michal Kazior
2013-07-23 8:02 ` Kalle Valo
2013-07-23 8:02 ` Kalle Valo
2013-07-19 10:32 ` [PATCH v3 0/3] ath10k: hardware recovery Kalle Valo
2013-07-19 10:32 ` Kalle Valo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87r4f0p9xn.fsf@kamboji.qca.qualcomm.com \
--to=kvalo@qca.qualcomm.com \
--cc=ath10k@lists.infradead.org \
--cc=ath9k-devel@lists.ath9k.org \
--cc=michal.kazior@tieto.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.