All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] drm/i915/gvt: use ARRAY_SIZE
@ 2017-10-16  2:32 ` Jérémy Lefaure
  0 siblings, 0 replies; 8+ messages in thread
From: Jérémy Lefaure @ 2017-10-16  2:32 UTC (permalink / raw)
  To: Zhenyu Wang, Zhi Wang, Jani Nikula, Joonas Lahtinen, Rodrigo Vivi,
	David Airlie
  Cc: Jérémy Lefaure, intel-gfx, intel-gvt-dev, linux-kernel,
	dri-devel

Using the ARRAY_SIZE macro improves the readability of the code. Also,
it's useless to use a variable to store this constant calculated at
compile time.

Found with Coccinelle with the following semantic patch:
@r depends on (org || report)@
type T;
T[] E;
position p;
@@
(
 (sizeof(E)@p /sizeof(*E))
|
 (sizeof(E)@p /sizeof(E[...]))
|
 (sizeof(E)@p /sizeof(T))
)

Signed-off-by: Jérémy Lefaure <jeremy.lefaure@lse.epita.fr>
---
This patch was part of a bigger patch [1].

[1]: https://patchwork.kernel.org/patch/9979843/

 drivers/gpu/drm/i915/gvt/vgpu.c | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/drivers/gpu/drm/i915/gvt/vgpu.c b/drivers/gpu/drm/i915/gvt/vgpu.c
index 02c61a1ad56a..b32c1c889ea8 100644
--- a/drivers/gpu/drm/i915/gvt/vgpu.c
+++ b/drivers/gpu/drm/i915/gvt/vgpu.c
@@ -31,6 +31,7 @@
  *
  */
 
+#include <linux/kernel.h>
 #include "i915_drv.h"
 #include "gvt.h"
 #include "i915_pvinfo.h"
@@ -98,7 +99,6 @@ static struct {
  */
 int intel_gvt_init_vgpu_types(struct intel_gvt *gvt)
 {
-	unsigned int num_types;
 	unsigned int i, low_avail, high_avail;
 	unsigned int min_low;
 
@@ -116,15 +116,14 @@ int intel_gvt_init_vgpu_types(struct intel_gvt *gvt)
 	 */
 	low_avail = gvt_aperture_sz(gvt) - HOST_LOW_GM_SIZE;
 	high_avail = gvt_hidden_sz(gvt) - HOST_HIGH_GM_SIZE;
-	num_types = sizeof(vgpu_types) / sizeof(vgpu_types[0]);
 
-	gvt->types = kzalloc(num_types * sizeof(struct intel_vgpu_type),
-			     GFP_KERNEL);
+	gvt->types = kzalloc(ARRAY_SIZE(vgpu_types) *
+			     sizeof(struct intel_vgpu_type), GFP_KERNEL);
 	if (!gvt->types)
 		return -ENOMEM;
 
 	min_low = MB_TO_BYTES(32);
-	for (i = 0; i < num_types; ++i) {
+	for (i = 0; i < ARRAY_SIZE(vgpu_types); ++i) {
 		if (low_avail / vgpu_types[i].low_mm == 0)
 			break;
 
-- 
2.14.2

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply related	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2017-10-23 16:38 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2017-10-16  2:32 [PATCH] drm/i915/gvt: use ARRAY_SIZE Jérémy Lefaure
2017-10-16  2:32 ` Jérémy Lefaure
2017-10-16  2:55 ` ✓ Fi.CI.BAT: success for " Patchwork
2017-10-16  4:01 ` ✓ Fi.CI.IGT: " Patchwork
2017-10-16  9:34 ` [PATCH] " Jani Nikula
2017-10-16  9:37   ` Wang, Zhi A
2017-10-23 16:38 ` Zhi Wang
2017-10-23 16:38   ` Zhi Wang

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.