From: Cristian Ciocaltea <cristian.ciocaltea@collabora.com>
To: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
Cc: Vinod Koul <vkoul@kernel.org>,
Kishon Vijay Abraham I <kishon@kernel.org>,
Heiko Stuebner <heiko@sntech.de>,
Algea Cao <algea.cao@rock-chips.com>,
Sandor Yu <Sandor.yu@nxp.com>, Maxime Ripard <mripard@kernel.org>,
kernel@collabora.com, linux-kernel@vger.kernel.org,
linux-phy@lists.infradead.org,
linux-arm-kernel@lists.infradead.org,
linux-rockchip@lists.infradead.org
Subject: Re: [PATCH v5 11/12] phy: rockchip: samsung-hdptx: Optimize internal rate handling
Date: Sun, 9 Mar 2025 12:32:41 +0200 [thread overview]
Message-ID: <884acd6e-4936-4b00-88ed-cbccc10efc9c@collabora.com> (raw)
In-Reply-To: <CAA8EJpqzZaRoQ5mDeKUHpNhYsegC=V6c2SQpKaQn4FYhozQn1A@mail.gmail.com>
On 3/9/25 12:17 PM, Dmitry Baryshkov wrote:
> On Sat, 8 Mar 2025 at 14:21, Cristian Ciocaltea
> <cristian.ciocaltea@collabora.com> wrote:
>>
>> Drop the rate parameter from a bunch of internal helpers and, instead,
>> make better use of the newly introduced ->hdmi_cfg.tmds_char_rate driver
>> data.
>>
>> Additionally, rename the rather ambiguous ->rate member of struct
>> rk_hdptx_phy to ->hw_rate and ensure rk_hdptx_ropll_tmds_cmn_config()
>
> Would it be better to name it tmds_char_rate?
This is only used in rk_hdptx_phy_clk_recalc_rate() to provide the
actual rate programmed in hardware, hence the "hw_rate" naming.
Renaming it to tmds_char_rate might add some confusion with the similar
one in ->hdmi_cfg, but I don't really have any strong preference here.
>> updates it only after all the other operations have been successful.
>
> Please don't mix refactoring / renames and the actual code changes.
Right, I should have moved that to a dedicated patch. Will handle in
the next revision.
Thanks,
Cristian
WARNING: multiple messages have this Message-ID (diff)
From: Cristian Ciocaltea <cristian.ciocaltea@collabora.com>
To: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
Cc: Vinod Koul <vkoul@kernel.org>,
Kishon Vijay Abraham I <kishon@kernel.org>,
Heiko Stuebner <heiko@sntech.de>,
Algea Cao <algea.cao@rock-chips.com>,
Sandor Yu <Sandor.yu@nxp.com>, Maxime Ripard <mripard@kernel.org>,
kernel@collabora.com, linux-kernel@vger.kernel.org,
linux-phy@lists.infradead.org,
linux-arm-kernel@lists.infradead.org,
linux-rockchip@lists.infradead.org
Subject: Re: [PATCH v5 11/12] phy: rockchip: samsung-hdptx: Optimize internal rate handling
Date: Sun, 9 Mar 2025 12:32:41 +0200 [thread overview]
Message-ID: <884acd6e-4936-4b00-88ed-cbccc10efc9c@collabora.com> (raw)
In-Reply-To: <CAA8EJpqzZaRoQ5mDeKUHpNhYsegC=V6c2SQpKaQn4FYhozQn1A@mail.gmail.com>
On 3/9/25 12:17 PM, Dmitry Baryshkov wrote:
> On Sat, 8 Mar 2025 at 14:21, Cristian Ciocaltea
> <cristian.ciocaltea@collabora.com> wrote:
>>
>> Drop the rate parameter from a bunch of internal helpers and, instead,
>> make better use of the newly introduced ->hdmi_cfg.tmds_char_rate driver
>> data.
>>
>> Additionally, rename the rather ambiguous ->rate member of struct
>> rk_hdptx_phy to ->hw_rate and ensure rk_hdptx_ropll_tmds_cmn_config()
>
> Would it be better to name it tmds_char_rate?
This is only used in rk_hdptx_phy_clk_recalc_rate() to provide the
actual rate programmed in hardware, hence the "hw_rate" naming.
Renaming it to tmds_char_rate might add some confusion with the similar
one in ->hdmi_cfg, but I don't really have any strong preference here.
>> updates it only after all the other operations have been successful.
>
> Please don't mix refactoring / renames and the actual code changes.
Right, I should have moved that to a dedicated patch. Will handle in
the next revision.
Thanks,
Cristian
--
linux-phy mailing list
linux-phy@lists.infradead.org
https://lists.infradead.org/mailman/listinfo/linux-phy
WARNING: multiple messages have this Message-ID (diff)
From: Cristian Ciocaltea <cristian.ciocaltea@collabora.com>
To: Dmitry Baryshkov <dmitry.baryshkov@linaro.org>
Cc: Vinod Koul <vkoul@kernel.org>,
Kishon Vijay Abraham I <kishon@kernel.org>,
Heiko Stuebner <heiko@sntech.de>,
Algea Cao <algea.cao@rock-chips.com>,
Sandor Yu <Sandor.yu@nxp.com>, Maxime Ripard <mripard@kernel.org>,
kernel@collabora.com, linux-kernel@vger.kernel.org,
linux-phy@lists.infradead.org,
linux-arm-kernel@lists.infradead.org,
linux-rockchip@lists.infradead.org
Subject: Re: [PATCH v5 11/12] phy: rockchip: samsung-hdptx: Optimize internal rate handling
Date: Sun, 9 Mar 2025 12:32:41 +0200 [thread overview]
Message-ID: <884acd6e-4936-4b00-88ed-cbccc10efc9c@collabora.com> (raw)
In-Reply-To: <CAA8EJpqzZaRoQ5mDeKUHpNhYsegC=V6c2SQpKaQn4FYhozQn1A@mail.gmail.com>
On 3/9/25 12:17 PM, Dmitry Baryshkov wrote:
> On Sat, 8 Mar 2025 at 14:21, Cristian Ciocaltea
> <cristian.ciocaltea@collabora.com> wrote:
>>
>> Drop the rate parameter from a bunch of internal helpers and, instead,
>> make better use of the newly introduced ->hdmi_cfg.tmds_char_rate driver
>> data.
>>
>> Additionally, rename the rather ambiguous ->rate member of struct
>> rk_hdptx_phy to ->hw_rate and ensure rk_hdptx_ropll_tmds_cmn_config()
>
> Would it be better to name it tmds_char_rate?
This is only used in rk_hdptx_phy_clk_recalc_rate() to provide the
actual rate programmed in hardware, hence the "hw_rate" naming.
Renaming it to tmds_char_rate might add some confusion with the similar
one in ->hdmi_cfg, but I don't really have any strong preference here.
>> updates it only after all the other operations have been successful.
>
> Please don't mix refactoring / renames and the actual code changes.
Right, I should have moved that to a dedicated patch. Will handle in
the next revision.
Thanks,
Cristian
_______________________________________________
Linux-rockchip mailing list
Linux-rockchip@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-rockchip
next prev parent reply other threads:[~2025-03-09 10:34 UTC|newest]
Thread overview: 108+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-08 12:21 [PATCH v5 00/12] phy: rockchip: samsung-hdptx: Support high color depth management Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` [PATCH v5 01/12] phy: Add HDMI configuration options Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` [PATCH v5 02/12] phy: hdmi: Add color depth configuration Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-09 9:16 ` Dmitry Baryshkov
2025-03-09 9:16 ` Dmitry Baryshkov
2025-03-09 9:16 ` Dmitry Baryshkov
2025-03-09 10:10 ` Cristian Ciocaltea
2025-03-09 10:10 ` Cristian Ciocaltea
2025-03-09 10:10 ` Cristian Ciocaltea
2025-03-09 10:10 ` Dmitry Baryshkov
2025-03-09 10:10 ` Dmitry Baryshkov
2025-03-09 10:10 ` Dmitry Baryshkov
2025-03-08 12:21 ` [PATCH v5 03/12] phy: rockchip: samsung-hdptx: Fix clock ratio setup Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-09 9:17 ` Dmitry Baryshkov
2025-03-09 9:17 ` Dmitry Baryshkov
2025-03-09 9:17 ` Dmitry Baryshkov
2025-03-09 10:11 ` Cristian Ciocaltea
2025-03-09 10:11 ` Cristian Ciocaltea
2025-03-09 10:11 ` Cristian Ciocaltea
2025-03-09 10:12 ` Dmitry Baryshkov
2025-03-09 10:12 ` Dmitry Baryshkov
2025-03-09 10:12 ` Dmitry Baryshkov
2025-03-09 10:17 ` Cristian Ciocaltea
2025-03-09 10:17 ` Cristian Ciocaltea
2025-03-09 10:17 ` Cristian Ciocaltea
2025-03-08 12:21 ` [PATCH v5 04/12] phy: rockchip: samsung-hdptx: Drop unused struct lcpll_config Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-09 9:18 ` Dmitry Baryshkov
2025-03-09 9:18 ` Dmitry Baryshkov
2025-03-09 9:18 ` Dmitry Baryshkov
2025-03-08 12:21 ` [PATCH v5 05/12] phy: rockchip: samsung-hdptx: Drop unused phy_cfg driver data Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-09 9:18 ` Dmitry Baryshkov
2025-03-09 9:18 ` Dmitry Baryshkov
2025-03-09 9:18 ` Dmitry Baryshkov
2025-03-08 12:21 ` [PATCH v5 06/12] phy: rockchip: samsung-hdptx: Drop superfluous cfgs " Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-09 9:19 ` Dmitry Baryshkov
2025-03-09 9:19 ` Dmitry Baryshkov
2025-03-09 9:19 ` Dmitry Baryshkov
2025-03-08 12:21 ` [PATCH v5 07/12] phy: rockchip: samsung-hdptx: Avoid Hz<->hHz unit conversion overhead Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-09 9:22 ` Dmitry Baryshkov
2025-03-09 9:22 ` Dmitry Baryshkov
2025-03-09 9:22 ` Dmitry Baryshkov
2025-03-09 10:13 ` Cristian Ciocaltea
2025-03-09 10:13 ` Cristian Ciocaltea
2025-03-09 10:13 ` Cristian Ciocaltea
2025-03-09 14:47 ` David Laight
2025-03-09 14:47 ` David Laight
2025-03-09 14:47 ` David Laight
2025-03-09 22:00 ` Cristian Ciocaltea
2025-03-09 22:00 ` Cristian Ciocaltea
2025-03-09 22:00 ` Cristian Ciocaltea
2025-03-08 12:21 ` [PATCH v5 08/12] phy: rockchip: samsung-hdptx: Setup TMDS char rate via phy_configure_opts_hdmi Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-09 9:26 ` Dmitry Baryshkov
2025-03-09 9:26 ` Dmitry Baryshkov
2025-03-09 9:26 ` Dmitry Baryshkov
2025-03-09 10:15 ` Cristian Ciocaltea
2025-03-09 10:15 ` Cristian Ciocaltea
2025-03-09 10:15 ` Cristian Ciocaltea
2025-03-18 12:48 ` Cristian Ciocaltea
2025-03-18 12:48 ` Cristian Ciocaltea
2025-03-18 12:48 ` Cristian Ciocaltea
2025-03-08 12:21 ` [PATCH v5 09/12] phy: rockchip: samsung-hdptx: Provide config params validation support Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-09 9:27 ` Dmitry Baryshkov
2025-03-09 9:27 ` Dmitry Baryshkov
2025-03-09 9:27 ` Dmitry Baryshkov
2025-03-08 12:21 ` [PATCH v5 10/12] phy: rockchip: samsung-hdptx: Restrict altering TMDS char rate via CCF Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` [PATCH v5 11/12] phy: rockchip: samsung-hdptx: Optimize internal rate handling Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-09 10:17 ` Dmitry Baryshkov
2025-03-09 10:17 ` Dmitry Baryshkov
2025-03-09 10:17 ` Dmitry Baryshkov
2025-03-09 10:32 ` Cristian Ciocaltea [this message]
2025-03-09 10:32 ` Cristian Ciocaltea
2025-03-09 10:32 ` Cristian Ciocaltea
2025-03-09 10:33 ` Dmitry Baryshkov
2025-03-09 10:33 ` Dmitry Baryshkov
2025-03-09 10:33 ` Dmitry Baryshkov
2025-03-08 12:21 ` [PATCH v5 12/12] phy: rockchip: samsung-hdptx: Add high color depth management Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-08 12:21 ` Cristian Ciocaltea
2025-03-09 10:18 ` Dmitry Baryshkov
2025-03-09 10:18 ` Dmitry Baryshkov
2025-03-09 10:18 ` Dmitry Baryshkov
2025-03-18 12:56 ` Cristian Ciocaltea
2025-03-18 12:56 ` Cristian Ciocaltea
2025-03-18 12:56 ` Cristian Ciocaltea
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=884acd6e-4936-4b00-88ed-cbccc10efc9c@collabora.com \
--to=cristian.ciocaltea@collabora.com \
--cc=Sandor.yu@nxp.com \
--cc=algea.cao@rock-chips.com \
--cc=dmitry.baryshkov@linaro.org \
--cc=heiko@sntech.de \
--cc=kernel@collabora.com \
--cc=kishon@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-phy@lists.infradead.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=mripard@kernel.org \
--cc=vkoul@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.