All of lore.kernel.org
 help / color / mirror / Atom feed
From: Binbin Wu <binbin.wu@linux.intel.com>
To: Peter Fang <peter.fang@intel.com>
Cc: Dave Hansen <dave.hansen@linux.intel.com>,
	Kiryl Shutsemau <kas@kernel.org>,
	Rick Edgecombe <rick.p.edgecombe@intel.com>,
	Kuppuswamy Sathyanarayanan
	<sathyanarayanan.kuppuswamy@linux.intel.com>,
	Thomas Gleixner <tglx@kernel.org>, Ingo Molnar <mingo@redhat.com>,
	Borislav Petkov <bp@alien8.de>,
	x86@kernel.org, "H. Peter Anvin" <hpa@zytor.com>,
	linux-kernel@vger.kernel.org, linux-coco@lists.linux.dev,
	kvm@vger.kernel.org, Xiaoyao Li <xiaoyao.li@intel.com>
Subject: Re: [PATCH v3 3/4] virt: tdx-guest: Use a variable to store the Quote buffer size
Date: Mon, 7 Sep 2026 15:55:22 +0800	[thread overview]
Message-ID: <8d20d04a-3503-42d5-8aa0-90b96aca2fe4@linux.intel.com> (raw)
In-Reply-To: <appp3yiDbYsekIzP@intel.com>

On 9/4/2026 2:49 PM, Peter Fang wrote:
> On Thu, Sep 03, 2026 at 05:17:02PM +0800, Binbin Wu wrote:
>> On 7/29/2026 8:29 PM, Peter Fang wrote:
>>> In preparation for dynamic Quote buffer sizes, replace the fixed size
>>> constant with a variable.
>>>
>>> The size is currently a constant sprinkled across several places. Store
>>> it in a variable and have all the users read it from there.
>>>
>>> Signed-off-by: Peter Fang <peter.fang@intel.com>
>>
>> Reviewed-by: Binbin Wu <binbin.wu@linux.intel.com>
> 
> Thanks Binbin!
> 
>>
>>> @@ -191,8 +191,9 @@ struct tdx_quote_buf {
>>>  	u8 data[];
>>>  };
>>>  
>>> -/* Quote data buffer */
>>> +/* Quote data buffer and length */
>>>  static void *quote_data;
>>> +static size_t quote_data_len;
>>
>> Nit:
>> The existing code is using "quote_data", it's natural to follow the style.
>> I personally feel the var names are a bit ambiguous on whether it's the full
>> quote buffer or just the data part.
> 
> Yeah I agree... How about I change it to:
> 
>   static struct tdx_quote_buf *quote_buf;
> 
> This way it's explicitly typed, and should work better with functions
> like alloc_quote_buf() and free_quote_buf()?

tdx_report_new_locked() already uses the name 'quote_buf' as a local var. :(
Maybe the local var can be dropped, but tdx_hcall_get_quote() takes a "u8 *"
pointer, which will require a type cast.

Anyway, this is a nit and it could be addressed in a separately if needed.


  reply	other threads:[~2026-09-07  7:55 UTC|newest]

Thread overview: 53+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-29 12:29 [PATCH v3 0/4] tdx-guest: Make Quote buffer size dynamic Peter Fang
2026-07-29 12:29 ` [PATCH v3 1/4] x86/tdx: Add helper to query maximum TD Quote size Peter Fang
2026-09-03  6:04   ` Tony Lindgren
2026-09-03 22:45     ` Peter Fang
2026-07-29 12:29 ` [PATCH v3 2/4] virt: tdx-guest: Calculate the Quote buffer size safely Peter Fang
2026-07-29 18:29   ` Kuppuswamy Sathyanarayanan
2026-09-03  5:33   ` Xiaoyao Li
2026-09-03  6:05   ` Tony Lindgren
2026-09-03  9:18   ` Binbin Wu
2026-07-29 12:29 ` [PATCH v3 3/4] virt: tdx-guest: Use a variable to store the Quote buffer size Peter Fang
2026-07-29 12:58   ` sashiko-bot
2026-09-03  5:25     ` Peter Fang
2026-07-29 18:47   ` Kuppuswamy Sathyanarayanan
2026-09-02 23:15     ` Peter Fang
2026-09-03  5:59       ` Xiaoyao Li
2026-09-04  1:28         ` Peter Fang
2026-09-03  6:31   ` Tony Lindgren
2026-09-04  4:51     ` Peter Fang
2026-09-03  9:17   ` Binbin Wu
2026-09-04  6:49     ` Peter Fang
2026-09-07  7:55       ` Binbin Wu [this message]
2026-07-29 12:29 ` [PATCH v3 4/4] virt: tdx-guest: Allocate Quote buffer dynamically Peter Fang
2026-07-29 12:55   ` sashiko-bot
2026-09-03  7:04     ` Peter Fang
2026-09-03  6:21   ` Xiaoyao Li
2026-09-03  6:33     ` Tony Lindgren
2026-09-04 20:59       ` Peter Fang
2026-09-08  4:23         ` Tony Lindgren
2026-07-29 21:21 ` [PATCH v3 0/4] tdx-guest: Make Quote buffer size dynamic Edgecombe, Rick P
2026-08-11 22:40   ` Edgecombe, Rick P
2026-08-12 14:08     ` Sean Christopherson
2026-08-12 16:02       ` Edgecombe, Rick P
2026-08-12 16:43         ` Sean Christopherson
2026-08-12 17:22           ` Edgecombe, Rick P
2026-08-12 22:37             ` Peter Fang
2026-08-12 22:47               ` Edgecombe, Rick P
2026-08-12 23:10                 ` Sean Christopherson
2026-08-12 23:30                   ` Edgecombe, Rick P
2026-08-13 19:32                     ` Artem Bityutskiy
2026-08-13 20:14                       ` Edgecombe, Rick P
2026-08-14  5:45                         ` Artem Bityutskiy
2026-08-14  7:37                           ` Peter Fang
2026-08-14 15:55                           ` Edgecombe, Rick P
2026-08-15 11:39                             ` Artem Bityutskiy
2026-08-17 17:26                               ` Edgecombe, Rick P
2026-08-18 11:09                                 ` Artem Bityutskiy
2026-08-18 20:37                       ` Sean Christopherson
2026-08-18 23:46                         ` Edgecombe, Rick P
2026-08-19 14:57                         ` Artem Bityutskiy
2026-08-12 23:27                 ` Peter Fang
2026-08-12 21:02         ` Peter Fang
2026-08-27 22:22   ` Peter Fang
2026-08-27 22:41     ` Edgecombe, Rick P

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8d20d04a-3503-42d5-8aa0-90b96aca2fe4@linux.intel.com \
    --to=binbin.wu@linux.intel.com \
    --cc=bp@alien8.de \
    --cc=dave.hansen@linux.intel.com \
    --cc=hpa@zytor.com \
    --cc=kas@kernel.org \
    --cc=kvm@vger.kernel.org \
    --cc=linux-coco@lists.linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=peter.fang@intel.com \
    --cc=rick.p.edgecombe@intel.com \
    --cc=sathyanarayanan.kuppuswamy@linux.intel.com \
    --cc=tglx@kernel.org \
    --cc=x86@kernel.org \
    --cc=xiaoyao.li@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.