From: Matthieu Baerts <matttbe@kernel.org>
To: Geliang Tang <geliang@kernel.org>, mptcp@lists.linux.dev
Subject: Re: [PATCH mptcp-next v2 00/14] mptcp: pm: code reorganisation
Date: Sat, 1 Mar 2025 12:10:49 +0100 [thread overview]
Message-ID: <8e6a57b2-8d45-4c7d-a0d1-ca120eb0114a@kernel.org> (raw)
In-Reply-To: <6dd5447d53d519a848f8b21104d90478802a0372.camel@kernel.org>
Hi Geliang,
On 01/03/2025 01:21, Geliang Tang wrote:
> Hi Matt,
>
> On Fri, 2025-02-28 at 14:31 +0100, Matthieu Baerts (NGI0) wrote:
>> I have been thinking about that during the past couple of months, but
>> now, with the recent modifications done by Geliang, and the
>> associated
>> reviews, I really think it is time to reorganise the code around the
>> path-managers to avoid confusions, and a mix of code used in
>> different
>> conditions.
>>
>> I hope this will not cause too many issues with the in-progress
>> patches.
>> I tried only to move the code around, and minimise the functions
>> renaming. Then, to switch to the new code, it might be easier to
>> simply
>> copy your modified code from the old place to the new one. In other
>> words, duplicate the net/mptcp directory, then do a rebase, resolve
>> the
>> conflicts with 'git restore --ours', then reapply the modifications
>> by
>> copying your old code to the new place. If it is too difficult,
>> please
>> let me know.
>>
>> Before this series, the PM code was dispersed in different places:
>>
>> - pm.c had common code for all PMs
>>
>> - pm_netlink.c was supposed to be about the in-kernel PM, but also
>> had
>> exported common helpers, callbacks used by the different PMs, NL
>> events for PM userspace daemon, etc. quite confusing.
>>
>> - pm_userspace.c had userspace PM only code, but using specific
>> in-kernel PM helpers
>>
>> To clarify the code, a reorganisation is suggested here, only by
>> moving
>> code around, and small helper renaming to avoid confusions:
>>
>> - pm_netlink.c now only contains common PM Netlink code:
>> - PM events: this code was already there
>> - shared helpers around Netlink code that were already there as
>> well
>> - shared Netlink commands code from pm.c
>>
>> - pm_kernel.c now contains only code that is specific to the in-
>> kernel
>> PM. Now all functions are either called from:
>> - pm.c: events coming from the core, when this PM is being used
>> - pm_netlink.c: for shared Netlink commands
>> - mptcp_pm_gen.c: for Netlink commands specific to the in-kernel PM
>> - sockopt.c: for the exported counters per netns
>>
>> - pm.c got many code from pm_netlink.c:
>> - helpers used from both PMs and not linked to Netlink
>> - callbacks used by different PMs, e.g. ADD_ADDR management
>> - some helpers have been renamed to remove the '_nl' prefix, and
>> they
>> have been marked as 'static'.
>>
>> - protocol.h has been updated accordingly:
>> - some helpers no longer need to be exported
>> - new ones needed to be exported: they have been prefixed if
>> needed.
>>
>> The code around the PM is now less confusing, which should help for
>> the
>> maintenance in the long term.
>>
>> This will certainly impact future backports, but because other
>> cleanups
>> have already done recently, and more are coming to ease the addition
>> of
>> a new path-manager controlled with BPF (struct_ops), doing that now
>> seems to be a good time. Also, many issues around the PM have been
>> fixed
>> a few months ago while increasing the code coverage in the selftests,
>> so
>> such big reorganisation can be done with more confidence now.
>>
>> Signed-off-by: Matthieu Baerts (NGI0) <matttbe@kernel.org>
>> ---
>> Changes in v2:
>> - Addressing Geliang's comments
>> - The renaming of common helpers have been done in dedicated patches
>> - Some helpers have been kept where they were in pm.c, except one now
>> in
>> a dedicated patch.
>> - The last patch has been split in smaller chunks, only moving code
>> from
>> one file to another to help with the reviews.
>
> Thanks for this v2, I have some comments for it:
Thank you for having looked at the v2.
> Patches 1, 2, 5 can be merged into one.
> Patch 3 can be merged into patch 9.
We could, but how can this help? If these patches are OK for the moment
and reviewable, maybe no need to spend more time on that and merging
stuff that might make it harder to follow, and might cause new conflicts?
> Patch 4, change mptcp_pm_rm_addr_recv() as non-static here, instead of
> changing it in patch 9. How about renaming it as
> __mptcp_pm_nl_rm_addr_received?
Would it not be confusing with the previous functions? Especially in
case of backports.
> Patch 7, how about renaming mptcp_pm_nl_set_flags_all as
> __mptcp_pm_nl_set_flags too?
No, the '__' prefix is usually used to mark that this function is going
to be used in a "critical" section, e.g. when a lock is held.
> Patch 11, how about dropping this patch, keep
> mptcp_pm_addr_families_match() unmoved, but add a new section like "/*
> generic PM helpers */" to import the helpers there?
I did that at the beginning, but:
- that's strange not to put the generic helpers at the beginning
- also strange to have to go down to see how a helper is implemented
> Patch 12
> - in mptcp_remove_anno_list_by_saddr() behavioural is changed, a
> separate patch is needed.
It is not, it is just a fix for a checkpatch warning mentioned in the
commit message. The netdev FAQ seems to suggest avoiding such fixes,
except if it is part of other changes. I don't think it is worth
splitting, the behaviour is not really modified.
> - mptcp_lookup_subflow_by_saddr should be after mptcp_remote_address
Why? I moved mptcp_pm_is_init_remote_addr() there because it was in the
middle of pm_netlink.c and it is very closed to remote_address.
> - mptcp_pm_sport_in_anno_list should be after
> mptcp_lookup_anno_list_by_saddr and befor mptcp_pm_add_timer.
Why?
> - split "move all struct mptcp_pm_add_entry related code into pm.c"
> from patch 12 as a separate one.
Why?
> - split "move all send_ack related code into pm.c" from patch 12 as a
> separate one.
Why?
> - make mptcp_pm_is_init_remote_addr() static shoud be merged into
> patch 6.
We cannot do that: it is called from pm.c, and we need remote_address(),
at that time only declared in pm_netlink.c.
> Split "move all pm_nl_pernet related code into pm_kernel.c" from patch
> 13 as a separate one.
Why?
> Can the action of deleting three headers in patch 14 be advanced to the
> previous patch?
For the two first ones, maybe but is it important? For mptcp_pm_gen.h, no.
Thank you for the suggestions, but I don't think it is worth spending
more time on that, except if you think it would help for the maintenance
and the backports. Merging patches probably will not help, and splitting
code being moved around is still too big for the backports. But maybe I
missed something.
I think it would be better to apply these patches ASAP, not to block
further developments, or having to rebase this kind of series. WDYT?
Cheers,
Matt
--
Sponsored by the NGI0 Core fund.
next prev parent reply other threads:[~2025-03-01 11:10 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-28 13:31 [PATCH mptcp-next v2 00/14] mptcp: pm: code reorganisation Matthieu Baerts (NGI0)
2025-02-28 13:31 ` [PATCH mptcp-next v2 01/14] mptcp: pm: remove '_nl' from mptcp_pm_nl_addr_send_ack Matthieu Baerts (NGI0)
2025-02-28 13:31 ` [PATCH mptcp-next v2 02/14] mptcp: pm: remove '_nl' from mptcp_pm_nl_mp_prio_send_ack Matthieu Baerts (NGI0)
2025-02-28 13:31 ` [PATCH mptcp-next v2 03/14] mptcp: pm: remove '_nl' from mptcp_pm_nl_work Matthieu Baerts (NGI0)
2025-02-28 13:31 ` [PATCH mptcp-next v2 04/14] mptcp: pm: remove '_nl' from mptcp_pm_nl_rm_addr_received Matthieu Baerts (NGI0)
2025-02-28 13:31 ` [PATCH mptcp-next v2 05/14] mptcp: pm: remove '_nl' from mptcp_pm_nl_subflow_chk_stale() Matthieu Baerts (NGI0)
2025-02-28 13:31 ` [PATCH mptcp-next v2 06/14] mptcp: pm: remove '_nl' from mptcp_pm_nl_is_init_remote_addr Matthieu Baerts (NGI0)
2025-02-28 13:31 ` [PATCH mptcp-next v2 07/14] mptcp: pm: kernel: add '_pm' to mptcp_nl_set_flags Matthieu Baerts (NGI0)
2025-02-28 13:31 ` [PATCH mptcp-next v2 08/14] mptcp: pm: avoid calling PM specific code from core Matthieu Baerts (NGI0)
2025-02-28 13:31 ` [PATCH mptcp-next v2 09/14] mptcp: pm: worker: split in-kernel and common tasks Matthieu Baerts (NGI0)
2025-02-28 13:31 ` [PATCH mptcp-next v2 10/14] mptcp: pm: export mptcp_remote_address Matthieu Baerts (NGI0)
2025-02-28 13:31 ` [PATCH mptcp-next v2 11/14] mptcp: pm: move generic helper at the top Matthieu Baerts (NGI0)
2025-02-28 13:31 ` [PATCH mptcp-next v2 12/14] mptcp: pm: move generic PM helpers to pm.c Matthieu Baerts (NGI0)
2025-02-28 13:31 ` [PATCH mptcp-next v2 13/14] mptcp: pm: split in-kernel PM specific code Matthieu Baerts (NGI0)
2025-03-03 10:51 ` Matthieu Baerts
2025-02-28 13:31 ` [PATCH mptcp-next v2 14/14] mptcp: pm: move Netlink PM helpers to pm_netlink.c Matthieu Baerts (NGI0)
2025-02-28 14:44 ` [PATCH mptcp-next v2 00/14] mptcp: pm: code reorganisation MPTCP CI
2025-03-01 0:19 ` Geliang Tang
2025-03-01 0:20 ` Geliang Tang
2025-03-01 0:21 ` Geliang Tang
2025-03-01 11:10 ` Matthieu Baerts [this message]
2025-03-03 10:55 ` Geliang Tang
2025-03-03 11:07 ` Matthieu Baerts
2025-03-03 14:14 ` Matthieu Baerts
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=8e6a57b2-8d45-4c7d-a0d1-ca120eb0114a@kernel.org \
--to=matttbe@kernel.org \
--cc=geliang@kernel.org \
--cc=mptcp@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.