From: Jan Beulich <jbeulich@suse.com>
To: Oleksii Kurochko <oleksii.kurochko@gmail.com>,
Luca Fancellu <luca.fancellu@arm.com>
Cc: "Penny Zheng" <Penny.Zheng@arm.com>,
"Stefano Stabellini" <sstabellini@kernel.org>,
"Julien Grall" <julien@xen.org>,
"Bertrand Marquis" <bertrand.marquis@arm.com>,
"Michal Orzel" <michal.orzel@amd.com>,
"Volodymyr Babchuk" <Volodymyr_Babchuk@epam.com>,
"Andrew Cooper" <andrew.cooper3@citrix.com>,
"Anthony PERARD" <anthony.perard@vates.tech>,
"Roger Pau Monné" <roger.pau@citrix.com>,
"Alistair Francis" <alistair.francis@wdc.com>,
"Bob Eshleman" <bobbyeshleman@gmail.com>,
"Connor Davis" <connojdavis@gmail.com>,
"Wei Chen" <wei.chen@arm.com>,
xen-devel@lists.xenproject.org
Subject: Re: [PATCH v3 6/7] xen: introduce Kconfig ARCH_PAGING_MEMPOOL
Date: Thu, 20 Mar 2025 08:32:35 +0100 [thread overview]
Message-ID: <94865aea-043b-4f52-adb8-d2d78dba293b@suse.com> (raw)
In-Reply-To: <136cf1c5-d1e5-471d-b560-51632b444e41@gmail.com>
On 19.03.2025 17:31, Oleksii Kurochko wrote:
>
> On 3/19/25 12:35 PM, Jan Beulich wrote:
>> On 18.03.2025 14:05, Oleksii Kurochko wrote:
>>> On 3/17/25 9:07 PM, Luca Fancellu wrote:
>>>> From: Penny Zheng<Penny.Zheng@arm.com>
>>>>
>>>> ARM MPU system doesn't need to use paging memory pool, as MPU memory
>>>> mapping table at most takes only one 4KB page, which is enough to
>>>> manage the maximum 255 MPU memory regions, for all EL2 stage 1
>>>> translation and EL1 stage 2 translation.
>>>>
>>>> Introduce ARCH_PAGING_MEMPOOL Kconfig common symbol, selected for Arm
>>>> MMU systems, x86 and RISC-V.
>>>>
>>>> Wrap the code inside 'construct_domU' that deal with p2m paging
>>>> allocation in a new function 'domain_p2m_set_allocation', protected
>>>> by ARCH_PAGING_MEMPOOL, this is done in this way to prevent polluting
>>>> the former function with #ifdefs and improve readability
>>>>
>>>> Introduce arch_{get,set}_paging_mempool_size stubs for architecture
>>>> with !ARCH_PAGING_MEMPOOL.
>>>>
>>>> Remove 'struct paging_domain' from Arm 'struct arch_domain' when the
>>>> field is not required.
>>>>
>>>> Signed-off-by: Penny Zheng<penny.zheng@arm.com>
>>>> Signed-off-by: Wei Chen<wei.chen@arm.com>
>>>> Signed-off-by: Luca Fancellu<luca.fancellu@arm.com>
>>>> ---
>>>> v3 changes:
>>>> - Introduced ARCH_PAGING_MEMPOOL instead of HAS_PAGING_MEMPOOL
>>>> v2 changes:
>>>> - make Kconfig HAS_PAGING_MEMPOOL common
>>>> - protect also "xen,domain-p2m-mem-mb" reading with HAS_PAGING_MEMPOOL
>>>> - do not define p2m_teardown{_allocation} in this patch
>>>> - change commit message
>>>> ---
>>>> xen/arch/arm/Kconfig | 1 +
>>>> xen/arch/arm/dom0less-build.c | 74 ++++++++++++++++++++-----------
>>>> xen/arch/arm/include/asm/domain.h | 2 +
>>>> xen/arch/riscv/Kconfig | 1 +
>>>> xen/arch/x86/Kconfig | 1 +
>>>> xen/common/Kconfig | 3 ++
>>>> xen/include/xen/domain.h | 17 +++++++
>>>> 7 files changed, 73 insertions(+), 26 deletions(-)
>>> For RISC-V:
>>> Reviewed-by: Oleksii Kurochko<oleksii.kurochko@gmail.com>
>> Mind me asking then why RISC-V needs this at this point? The stubs surely
>> were added to address some build issue, not because they are actively
>> meaningful?
>
> Only because we have stubs and not to have redefinition compilation
> error. And, yes, they are not actively meaningful now, at least. I am
> okay with not enabling of this config for RISC-V but then seems to me we
> have to drop stubs in riscv/stubs.c. ~ Oleksii
Well, I don't think it's "have to", but I agree that dropping them would
make sense then (and be desirable).
Jan
next prev parent reply other threads:[~2025-03-20 7:32 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-17 20:07 [PATCH v3 0/7] MPU mm subsystem skeleton Luca Fancellu
2025-03-17 20:07 ` [PATCH v3 1/7] arm/mpu: Add HYPERVISOR_VIRT_START and avoid a check in xen.lds.S Luca Fancellu
2025-03-17 20:07 ` [PATCH v3 2/7] xen/arm: Implement virt/maddr conversion in MPU system Luca Fancellu
2025-03-17 20:07 ` [PATCH v3 3/7] xen/arm: Introduce frame_table and virt_to_page Luca Fancellu
2025-03-17 20:07 ` [PATCH v3 4/7] arm/mpu: Kconfig symbols for MPU build Luca Fancellu
2025-03-17 20:07 ` [PATCH v3 5/7] arm/mpu: Implement stubs for ioremap_attr on MPU Luca Fancellu
2025-03-17 20:07 ` [PATCH v3 6/7] xen: introduce Kconfig ARCH_PAGING_MEMPOOL Luca Fancellu
2025-03-18 9:11 ` Orzel, Michal
2025-03-18 13:05 ` Oleksii Kurochko
2025-03-19 11:35 ` Jan Beulich
2025-03-19 12:18 ` Luca Fancellu
2025-03-19 12:24 ` Luca Fancellu
2025-03-19 12:26 ` Luca Fancellu
2025-03-19 16:31 ` Oleksii Kurochko
2025-03-20 7:32 ` Jan Beulich [this message]
2025-03-26 9:39 ` Orzel, Michal
2025-03-26 9:46 ` Oleksii Kurochko
2025-03-26 9:53 ` Orzel, Michal
2025-03-26 9:54 ` Jan Beulich
2025-03-26 9:59 ` Orzel, Michal
2025-03-26 10:04 ` Jan Beulich
2025-03-17 20:07 ` [PATCH v3 7/7] arm/mpu: Create the skeleton for MPU compilation Luca Fancellu
2025-03-18 9:27 ` Orzel, Michal
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=94865aea-043b-4f52-adb8-d2d78dba293b@suse.com \
--to=jbeulich@suse.com \
--cc=Penny.Zheng@arm.com \
--cc=Volodymyr_Babchuk@epam.com \
--cc=alistair.francis@wdc.com \
--cc=andrew.cooper3@citrix.com \
--cc=anthony.perard@vates.tech \
--cc=bertrand.marquis@arm.com \
--cc=bobbyeshleman@gmail.com \
--cc=connojdavis@gmail.com \
--cc=julien@xen.org \
--cc=luca.fancellu@arm.com \
--cc=michal.orzel@amd.com \
--cc=oleksii.kurochko@gmail.com \
--cc=roger.pau@citrix.com \
--cc=sstabellini@kernel.org \
--cc=wei.chen@arm.com \
--cc=xen-devel@lists.xenproject.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.