All of lore.kernel.org
 help / color / mirror / Atom feed
From: Ben Boeckel <me@benboeckel.net>
To: Greg Joyce <gjoyce@linux.vnet.ibm.com>
Cc: Hannes Reinecke <hare@suse.de>,
	linux-block@vger.kernel.org, linuxppc-dev@lists.ozlabs.org,
	jonathan.derrick@linux.dev, brking@linux.vnet.ibm.com,
	msuchanek@suse.de, mpe@ellerman.id.au, nayna@linux.ibm.com,
	axboe@kernel.dk, akpm@linux-foundation.org,
	keyrings@vger.kernel.org
Subject: Re: [PATCH v3 3/3] block: sed-opal: keyring support for SED keys
Date: Thu, 1 Dec 2022 11:12:59 -0500	[thread overview]
Message-ID: <Y4jSi+pd8D069w4D@megas.dev.benboeckel.internal> (raw)
In-Reply-To: <044c90dc7feb3959b5740154addc230ba9a57216.camel@linux.vnet.ibm.com>

On Thu, Dec 01, 2022 at 09:29:36 -0600, Greg Joyce wrote:
> On Wed, 2022-11-30 at 22:46 -0500, Ben Boeckel wrote:
> > Perhaps naming it `OPAL_MAX_KEY_LEN` would help clarify this?
> 
> I'm not averse to changing it because it would be clearer. My concern
> is that it's been OPAL_KEY_MAX for 5+ years (the original SED Opal
> commit). Unless there is strong consensus to change it, I'm going to
> leave it as the original name.

I don't care about the name (very much in the peanut gallery), just it
not being a magic number :) .

--Ben

WARNING: multiple messages have this Message-ID (diff)
From: Ben Boeckel <me@benboeckel.net>
To: Greg Joyce <gjoyce@linux.vnet.ibm.com>
Cc: axboe@kernel.dk, nayna@linux.ibm.com,
	linux-block@vger.kernel.org, keyrings@vger.kernel.org,
	Hannes Reinecke <hare@suse.de>,
	jonathan.derrick@linux.dev, brking@linux.vnet.ibm.com,
	akpm@linux-foundation.org, msuchanek@suse.de,
	linuxppc-dev@lists.ozlabs.org
Subject: Re: [PATCH v3 3/3] block: sed-opal: keyring support for SED keys
Date: Thu, 1 Dec 2022 11:12:59 -0500	[thread overview]
Message-ID: <Y4jSi+pd8D069w4D@megas.dev.benboeckel.internal> (raw)
In-Reply-To: <044c90dc7feb3959b5740154addc230ba9a57216.camel@linux.vnet.ibm.com>

On Thu, Dec 01, 2022 at 09:29:36 -0600, Greg Joyce wrote:
> On Wed, 2022-11-30 at 22:46 -0500, Ben Boeckel wrote:
> > Perhaps naming it `OPAL_MAX_KEY_LEN` would help clarify this?
> 
> I'm not averse to changing it because it would be clearer. My concern
> is that it's been OPAL_KEY_MAX for 5+ years (the original SED Opal
> commit). Unless there is strong consensus to change it, I'm going to
> leave it as the original name.

I don't care about the name (very much in the peanut gallery), just it
not being a magic number :) .

--Ben

  reply	other threads:[~2022-12-01 16:13 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-11-29 23:25 [PATCH v3 0/3] sed-opal: keyrings, discovery, revert, key store gjoyce
2022-11-29 23:25 ` gjoyce
2022-11-29 23:25 ` [PATCH v3 1/3] block: sed-opal: Implement IOC_OPAL_DISCOVERY gjoyce
2022-11-29 23:25   ` gjoyce
2022-11-30  6:52   ` Hannes Reinecke
2022-11-30  6:52     ` Hannes Reinecke
2022-11-29 23:25 ` [PATCH v3 2/3] block: sed-opal: Implement IOC_OPAL_REVERT_LSP gjoyce
2022-11-29 23:25   ` gjoyce
2022-11-30  6:53   ` Hannes Reinecke
2022-11-30  6:53     ` Hannes Reinecke
2022-11-29 23:25 ` [PATCH v3 3/3] block: sed-opal: keyring support for SED keys gjoyce
2022-11-29 23:25   ` gjoyce
2022-11-30  7:00   ` Hannes Reinecke
2022-11-30  7:00     ` Hannes Reinecke
2022-11-30 15:19     ` Greg Joyce
2022-11-30 15:19       ` Greg Joyce
2022-12-01  3:46       ` Ben Boeckel
2022-12-01  3:46         ` Ben Boeckel
2022-12-01 15:29         ` Greg Joyce
2022-12-01 15:29           ` Greg Joyce
2022-12-01 16:12           ` Ben Boeckel [this message]
2022-12-01 16:12             ` Ben Boeckel
2022-12-01 16:58             ` Greg Joyce
2022-12-01 16:58               ` Greg Joyce
2022-12-01 17:00               ` Greg Joyce
2022-12-01 17:00                 ` Greg Joyce
2022-12-01 18:03     ` Greg Joyce
2022-12-01 18:03       ` Greg Joyce
2022-12-02  6:56       ` Hannes Reinecke
2022-12-02  6:56         ` Hannes Reinecke
2022-12-02 15:18         ` Greg Joyce
2022-12-02 15:18           ` Greg Joyce
  -- strict thread matches above, loose matches on Subject: below --
2022-12-04  0:05 kernel test robot

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Y4jSi+pd8D069w4D@megas.dev.benboeckel.internal \
    --to=me@benboeckel.net \
    --cc=akpm@linux-foundation.org \
    --cc=axboe@kernel.dk \
    --cc=brking@linux.vnet.ibm.com \
    --cc=gjoyce@linux.vnet.ibm.com \
    --cc=hare@suse.de \
    --cc=jonathan.derrick@linux.dev \
    --cc=keyrings@vger.kernel.org \
    --cc=linux-block@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mpe@ellerman.id.au \
    --cc=msuchanek@suse.de \
    --cc=nayna@linux.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.