All of lore.kernel.org
 help / color / mirror / Atom feed
From: Deepak R Varma <drv@mailo.com>
To: Jiri Slaby <jirislaby@kernel.org>
Cc: "Maciej W. Rozycki" <macro@orcam.me.uk>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-serial@vger.kernel.org, linux-kernel@vger.kernel.org,
	Saurabh Singh Sengar <ssengar@microsoft.com>,
	Praveen Kumar <kumarpraveen@linux.microsoft.com>,
	Deepak R Varma <drv@mailo.com>
Subject: Re: [PATCH v4 2/2] tty: serial: dz: convert atomic_* to refcount_* APIs for irq_guard
Date: Tue, 3 Jan 2023 15:39:17 +0530	[thread overview]
Message-ID: <Y7P+zZEF09YWs5yW@qemulion> (raw)
In-Reply-To: <3c4e744f-c313-e195-af93-a22382c81bb6@kernel.org>

On Tue, Jan 03, 2023 at 10:00:48AM +0100, Jiri Slaby wrote:
> On 26. 12. 22, 7:21, Deepak R Varma wrote:
> > The refcount_* APIs are designed to address known issues with the
> > atomic_t APIs for reference counting. They provide following distinct
> > advantages:
> >     - protect the reference counters from overflow/underflow
> >     - avoid use-after-free errors
> >     - provide improved memory ordering guarantee schemes
> >     - neater and safer.
> > Hence, replace the atomic_* APIs by their equivalent refcount_t
> > API functions.
> >
> > This patch proposal address the following warnings generated by
> > the atomic_as_refcounter.cocci coccinelle script
> > atomic_add_return(-1, ...)
> ...
> > --- a/drivers/tty/serial/dz.c
> > +++ b/drivers/tty/serial/dz.c
> ...
> > @@ -400,18 +399,16 @@ static int dz_startup(struct uart_port *uport)
> >   	struct dz_port *dport = to_dport(uport);
> >   	struct dz_mux *mux = dport->mux;
> >   	unsigned long flags;
> > -	int irq_guard;
> >   	int ret;
> >   	u16 tmp;
> >
> > -	irq_guard = atomic_add_return(1, &mux->irq_guard);
> > -	if (irq_guard != 1)
> > +	refcount_inc(&mux->irq_guard);
> > +	if (refcount_read(&mux->irq_guard) != 1)
> >   		return 0;
> >
> > -	ret = request_irq(dport->port.irq, dz_interrupt,
> > -			  IRQF_SHARED, "dz", mux);
> > +	ret = request_irq(dport->port.irq, dz_interrupt, IRQF_SHARED, "dz", mux);
>
> How is this related to the above described change?

No, it is not. My apologies. I must have joined the lines for improved readability
and forgot to revert. I will restore this in next revision based on the feedback
on the other patch of this series. OR I can include this change in the current
change log as a "while at it..." statement. Would you advise me?

Thank you,
./drv

>
> --
> js
> suse labs
>



  reply	other threads:[~2023-01-03 10:09 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-12-24 16:32 [PATCH v3 0/2] tty: serial: dz: convert atomic_* to refcount_* Deepak R Varma
2022-12-26  6:20 ` [PATCH v4 " Deepak R Varma
2022-12-24 16:33 ` [PATCH v3 1/2] tty: serial: dz: convert atomic_* to refcount_* APIs for map_guard Deepak R Varma
2022-12-26  6:21   ` [PATCH v4 " Deepak R Varma
2023-01-03  8:59   ` Jiri Slaby
2023-01-03 10:05     ` Deepak R Varma
2023-01-04  8:28       ` Greg Kroah-Hartman
2023-01-04  8:59         ` Deepak R Varma
2023-01-10  6:19     ` Deepak R Varma
2023-01-10  7:27       ` Reshetova, Elena
2023-01-10  7:47         ` Deepak R Varma
2023-01-10  7:57           ` Greg Kroah-Hartman
2022-12-24 16:34 ` [PATCH 2/2] tty: serial: dz: convert atomic_* to refcount_* APIs for irq_guard Deepak R Varma
2022-12-26  6:21   ` [PATCH v4 " Deepak R Varma
2023-01-03  9:00   ` Jiri Slaby
2023-01-03 10:09     ` Deepak R Varma [this message]
2023-01-04  8:28       ` Greg Kroah-Hartman
2023-01-04  9:00         ` Deepak R Varma

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Y7P+zZEF09YWs5yW@qemulion \
    --to=drv@mailo.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=jirislaby@kernel.org \
    --cc=kumarpraveen@linux.microsoft.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-serial@vger.kernel.org \
    --cc=macro@orcam.me.uk \
    --cc=ssengar@microsoft.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.