All of lore.kernel.org
 help / color / mirror / Atom feed
From: Leon Romanovsky <leon@kernel.org>
To: Leo Yan <leo.yan@linaro.org>
Cc: codalist@telemann.coda.cs.cmu.edu,
	Jan Harkes <jaharkes@cs.cmu.edu>,
	Mathieu Poirier <mathieu.poirier@linaro.org>,
	Suzuki K Poulose <suzuki.poulose@arm.com>,
	Alexander Shishkin <alexander.shishkin@linux.intel.com>,
	netdev@vger.kernel.org, Balbir Singh <bsingharora@gmail.com>,
	linux-kernel@vger.kernel.org, Eric Paris <eparis@redhat.com>,
	coda@cs.cmu.edu, linux-audit@redhat.com,
	coresight@lists.linaro.org, Jakub Kicinski <kuba@kernel.org>,
	"David S. Miller" <davem@davemloft.net>,
	linux-arm-kernel@lists.infradead.org,
	Mike Leach <mike.leach@linaro.org>
Subject: Re: [PATCH v1 1/7] pid: Introduce helper task_is_in_root_ns()
Date: Mon, 6 Dec 2021 08:49:01 +0200	[thread overview]
Message-ID: <Ya2yXZAn+36yhfdU@unreal> (raw)
In-Reply-To: <20211205145105.57824-2-leo.yan@linaro.org>

On Sun, Dec 05, 2021 at 10:50:59PM +0800, Leo Yan wrote:
> Currently the kernel uses open code in multiple places to check if a
> task is in the root PID namespace with the kind of format:
> 
>   if (task_active_pid_ns(current) == &init_pid_ns)
>       do_something();
> 
> This patch creates a new helper function, task_is_in_root_ns(), it
> returns true if a passed task is in the root PID namespace, otherwise
> returns false.  So it will be used to replace open codes.
> 
> Suggested-by: Suzuki K Poulose <suzuki.poulose@arm.com>
> Signed-off-by: Leo Yan <leo.yan@linaro.org>
> ---
>  include/linux/pid_namespace.h | 5 +++++
>  1 file changed, 5 insertions(+)
> 
> diff --git a/include/linux/pid_namespace.h b/include/linux/pid_namespace.h
> index 7c7e627503d2..bf82b373f022 100644
> --- a/include/linux/pid_namespace.h
> +++ b/include/linux/pid_namespace.h
> @@ -86,4 +86,9 @@ extern struct pid_namespace *task_active_pid_ns(struct task_struct *tsk);
>  void pidhash_init(void);
>  void pid_idr_init(void);
>  
> +static inline bool task_is_in_root_ns(struct task_struct *tsk)

It is bad that this name doesn't reflect PID nature of this namespace.
Won't it better to name it task_is_in_init_pid_ns()?

Thanks

> +{
> +	return task_active_pid_ns(tsk) == &init_pid_ns;
> +}
> +
>  #endif /* _LINUX_PID_NS_H */
> -- 
> 2.25.1
> 

--
Linux-audit mailing list
Linux-audit@redhat.com
https://listman.redhat.com/mailman/listinfo/linux-audit


WARNING: multiple messages have this Message-ID (diff)
From: Leon Romanovsky <leon@kernel.org>
To: Leo Yan <leo.yan@linaro.org>
Cc: "David S. Miller" <davem@davemloft.net>,
	Jakub Kicinski <kuba@kernel.org>,
	Mathieu Poirier <mathieu.poirier@linaro.org>,
	Suzuki K Poulose <suzuki.poulose@arm.com>,
	Mike Leach <mike.leach@linaro.org>,
	Alexander Shishkin <alexander.shishkin@linux.intel.com>,
	Jan Harkes <jaharkes@cs.cmu.edu>,
	coda@cs.cmu.edu, Paul Moore <paul@paul-moore.com>,
	Eric Paris <eparis@redhat.com>,
	Balbir Singh <bsingharora@gmail.com>,
	netdev@vger.kernel.org, linux-kernel@vger.kernel.org,
	coresight@lists.linaro.org, linux-arm-kernel@lists.infradead.org,
	codalist@coda.cs.cmu.edu, linux-audit@redhat.com
Subject: Re: [PATCH v1 1/7] pid: Introduce helper task_is_in_root_ns()
Date: Mon, 6 Dec 2021 08:49:01 +0200	[thread overview]
Message-ID: <Ya2yXZAn+36yhfdU@unreal> (raw)
In-Reply-To: <20211205145105.57824-2-leo.yan@linaro.org>

On Sun, Dec 05, 2021 at 10:50:59PM +0800, Leo Yan wrote:
> Currently the kernel uses open code in multiple places to check if a
> task is in the root PID namespace with the kind of format:
> 
>   if (task_active_pid_ns(current) == &init_pid_ns)
>       do_something();
> 
> This patch creates a new helper function, task_is_in_root_ns(), it
> returns true if a passed task is in the root PID namespace, otherwise
> returns false.  So it will be used to replace open codes.
> 
> Suggested-by: Suzuki K Poulose <suzuki.poulose@arm.com>
> Signed-off-by: Leo Yan <leo.yan@linaro.org>
> ---
>  include/linux/pid_namespace.h | 5 +++++
>  1 file changed, 5 insertions(+)
> 
> diff --git a/include/linux/pid_namespace.h b/include/linux/pid_namespace.h
> index 7c7e627503d2..bf82b373f022 100644
> --- a/include/linux/pid_namespace.h
> +++ b/include/linux/pid_namespace.h
> @@ -86,4 +86,9 @@ extern struct pid_namespace *task_active_pid_ns(struct task_struct *tsk);
>  void pidhash_init(void);
>  void pid_idr_init(void);
>  
> +static inline bool task_is_in_root_ns(struct task_struct *tsk)

It is bad that this name doesn't reflect PID nature of this namespace.
Won't it better to name it task_is_in_init_pid_ns()?

Thanks

> +{
> +	return task_active_pid_ns(tsk) == &init_pid_ns;
> +}
> +
>  #endif /* _LINUX_PID_NS_H */
> -- 
> 2.25.1
> 

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

WARNING: multiple messages have this Message-ID (diff)
From: Leon Romanovsky <leon@kernel.org>
To: Leo Yan <leo.yan@linaro.org>
Cc: "David S. Miller" <davem@davemloft.net>,
	Jakub Kicinski <kuba@kernel.org>,
	Mathieu Poirier <mathieu.poirier@linaro.org>,
	Suzuki K Poulose <suzuki.poulose@arm.com>,
	Mike Leach <mike.leach@linaro.org>,
	Alexander Shishkin <alexander.shishkin@linux.intel.com>,
	Jan Harkes <jaharkes@cs.cmu.edu>,
	coda@cs.cmu.edu, Paul Moore <paul@paul-moore.com>,
	Eric Paris <eparis@redhat.com>,
	Balbir Singh <bsingharora@gmail.com>,
	netdev@vger.kernel.org, linux-kernel@vger.kernel.org,
	coresight@lists.linaro.org, linux-arm-kernel@lists.infradead.org,
	codalist@coda.cs.cmu.edu, linux-audit@redhat.com
Subject: Re: [PATCH v1 1/7] pid: Introduce helper task_is_in_root_ns()
Date: Mon, 6 Dec 2021 08:49:01 +0200	[thread overview]
Message-ID: <Ya2yXZAn+36yhfdU@unreal> (raw)
In-Reply-To: <20211205145105.57824-2-leo.yan@linaro.org>

On Sun, Dec 05, 2021 at 10:50:59PM +0800, Leo Yan wrote:
> Currently the kernel uses open code in multiple places to check if a
> task is in the root PID namespace with the kind of format:
> 
>   if (task_active_pid_ns(current) == &init_pid_ns)
>       do_something();
> 
> This patch creates a new helper function, task_is_in_root_ns(), it
> returns true if a passed task is in the root PID namespace, otherwise
> returns false.  So it will be used to replace open codes.
> 
> Suggested-by: Suzuki K Poulose <suzuki.poulose@arm.com>
> Signed-off-by: Leo Yan <leo.yan@linaro.org>
> ---
>  include/linux/pid_namespace.h | 5 +++++
>  1 file changed, 5 insertions(+)
> 
> diff --git a/include/linux/pid_namespace.h b/include/linux/pid_namespace.h
> index 7c7e627503d2..bf82b373f022 100644
> --- a/include/linux/pid_namespace.h
> +++ b/include/linux/pid_namespace.h
> @@ -86,4 +86,9 @@ extern struct pid_namespace *task_active_pid_ns(struct task_struct *tsk);
>  void pidhash_init(void);
>  void pid_idr_init(void);
>  
> +static inline bool task_is_in_root_ns(struct task_struct *tsk)

It is bad that this name doesn't reflect PID nature of this namespace.
Won't it better to name it task_is_in_init_pid_ns()?

Thanks

> +{
> +	return task_active_pid_ns(tsk) == &init_pid_ns;
> +}
> +
>  #endif /* _LINUX_PID_NS_H */
> -- 
> 2.25.1
> 

  reply	other threads:[~2021-12-06 22:15 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-12-05 14:50 [PATCH v1 0/7] pid: Introduce helper task_is_in_root_ns() Leo Yan
2021-12-05 14:50 ` Leo Yan
2021-12-05 14:50 ` Leo Yan
2021-12-05 14:50 ` [PATCH v1 1/7] " Leo Yan
2021-12-05 14:50   ` Leo Yan
2021-12-05 14:50   ` Leo Yan
2021-12-06  6:49   ` Leon Romanovsky [this message]
2021-12-06  6:49     ` Leon Romanovsky
2021-12-06  6:49     ` Leon Romanovsky
2021-12-06  7:03     ` Leo Yan
2021-12-06  7:03       ` Leo Yan
2021-12-06  7:03       ` Leo Yan
2021-12-06  7:13       ` Leon Romanovsky
2021-12-06  7:13         ` Leon Romanovsky
2021-12-06  7:13         ` Leon Romanovsky
2021-12-05 14:51 ` [PATCH v1 2/7] coresight: etm3x: Use task_is_in_root_ns() to check PID namespace Leo Yan
2021-12-05 14:51   ` Leo Yan
2021-12-05 14:51   ` Leo Yan
2021-12-05 14:51 ` [PATCH v1 3/7] coresight: etm4x: " Leo Yan
2021-12-05 14:51   ` Leo Yan
2021-12-05 14:51   ` Leo Yan
2021-12-05 14:51 ` [PATCH v1 4/7] connector/cn_proc: " Leo Yan
2021-12-05 14:51   ` Leo Yan
2021-12-05 14:51   ` Leo Yan
2021-12-05 14:51 ` [PATCH v1 5/7] coda: Use task_is_in_root_ns() Leo Yan
2021-12-05 14:51   ` Leo Yan
2021-12-05 14:51   ` Leo Yan
2021-12-05 14:51 ` [PATCH v1 6/7] audit: " Leo Yan
2021-12-05 14:51   ` Leo Yan
2021-12-05 14:51   ` Leo Yan
2021-12-05 14:51 ` [PATCH v1 7/7] taskstats: " Leo Yan
2021-12-05 14:51   ` Leo Yan
2021-12-05 14:51   ` Leo Yan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Ya2yXZAn+36yhfdU@unreal \
    --to=leon@kernel.org \
    --cc=alexander.shishkin@linux.intel.com \
    --cc=bsingharora@gmail.com \
    --cc=coda@cs.cmu.edu \
    --cc=codalist@telemann.coda.cs.cmu.edu \
    --cc=coresight@lists.linaro.org \
    --cc=davem@davemloft.net \
    --cc=eparis@redhat.com \
    --cc=jaharkes@cs.cmu.edu \
    --cc=kuba@kernel.org \
    --cc=leo.yan@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-audit@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mathieu.poirier@linaro.org \
    --cc=mike.leach@linaro.org \
    --cc=netdev@vger.kernel.org \
    --cc=suzuki.poulose@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.