* [RFC] Add a 'tag' field to MAINTAINERS
@ 2021-12-16 21:43 Matthew Wilcox
2021-12-17 2:39 ` Joe Perches
0 siblings, 1 reply; 3+ messages in thread
From: Matthew Wilcox @ 2021-12-16 21:43 UTC (permalink / raw)
To: Linus Torvalds; +Cc: linux-kernel
People find it hard to use the right tag when sending patches which
affect a maintainer that they don't interact with often. If we add
a field to MAINTAINERS, perhaps a tool will be written some day that
automatically adds it to patches.
Signed-off-by: Matthew Wilcox (Oracle) <willy@infradead.org>
diff --git a/MAINTAINERS b/MAINTAINERS
index 0a1410d5a621..c6358fa58fed 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -81,6 +81,7 @@ Descriptions of section entries:
R: Designated reviewer: FullName <address@domain>
These reviewers should be CCed on patches.
L: Mailing list that is relevant to this area
+ J: Prefix to use when sending a patch
W: Web-page with status/info
B: URI for where to file bugs. A web-page with detailed bug
filing info, a direct bug tracker link, or a mailto: URI.
@@ -2667,6 +2668,7 @@ F: drivers/leds/leds-blinkm.c
BLOCK LAYER
M: Jens Axboe <axboe@kernel.dk>
L: linux-block@vger.kernel.org
+J: block
T: git git://git.kernel.org/pub/scm/linux/kernel/git/axboe/linux-block.git
S: Maintained
F: block/
@@ -14927,6 +14929,7 @@ M: Pawel Osciak <pawel@osciak.com>
M: Marek Szyprowski <m.szyprowski@samsung.com>
M: Kyungmin Park <kyungmin.park@samsung.com>
L: linux-media@vger.kernel.org
+J: videobuf
S: Maintained
F: drivers/media/v4l2-core/videobuf2-*
F: include/media/videobuf2-*
^ permalink raw reply related [flat|nested] 3+ messages in thread
* Re: [RFC] Add a 'tag' field to MAINTAINERS
2021-12-16 21:43 [RFC] Add a 'tag' field to MAINTAINERS Matthew Wilcox
@ 2021-12-17 2:39 ` Joe Perches
2021-12-17 2:45 ` Joe Perches
0 siblings, 1 reply; 3+ messages in thread
From: Joe Perches @ 2021-12-17 2:39 UTC (permalink / raw)
To: Matthew Wilcox, Linus Torvalds; +Cc: linux-kernel
On Thu, 2021-12-16 at 21:43 +0000, Matthew Wilcox wrote:
> People find it hard to use the right tag when sending patches which
> affect a maintainer that they don't interact with often. If we add
> a field to MAINTAINERS, perhaps a tool will be written some day that
> automatically adds it to patches.
>
> Signed-off-by: Matthew Wilcox (Oracle) <willy@infradead.org>
>
> diff --git a/MAINTAINERS b/MAINTAINERS
> index 0a1410d5a621..c6358fa58fed 100644
> --- a/MAINTAINERS
> +++ b/MAINTAINERS
> @@ -81,6 +81,7 @@ Descriptions of section entries:
> R: Designated reviewer: FullName <address@domain>
> These reviewers should be CCed on patches.
> L: Mailing list that is relevant to this area
> + J: Prefix to use when sending a patch
> W: Web-page with status/info
> B: URI for where to file bugs. A web-page with detailed bug
> filing info, a direct bug tracker link, or a mailto: URI.
> @@ -2667,6 +2668,7 @@ F: drivers/leds/leds-blinkm.c
> BLOCK LAYER
> M: Jens Axboe <axboe@kernel.dk>
> L: linux-block@vger.kernel.org
> +J: block
> T: git git://git.kernel.org/pub/scm/linux/kernel/git/axboe/linux-block.git
> S: Maintained
> F: block/
> @@ -14927,6 +14929,7 @@ M: Pawel Osciak <pawel@osciak.com>
> M: Marek Szyprowski <m.szyprowski@samsung.com>
> M: Kyungmin Park <kyungmin.park@samsung.com>
> L: linux-media@vger.kernel.org
> +J: videobuf
> S: Maintained
> F: drivers/media/v4l2-core/videobuf2-*
> F: include/media/videobuf2-*
>
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [RFC] Add a 'tag' field to MAINTAINERS
2021-12-17 2:39 ` Joe Perches
@ 2021-12-17 2:45 ` Joe Perches
0 siblings, 0 replies; 3+ messages in thread
From: Joe Perches @ 2021-12-17 2:45 UTC (permalink / raw)
To: Matthew Wilcox, Linus Torvalds; +Cc: linux-kernel
(apologies for the blank reply, evolution email client isn't great)
On Thu, 2021-12-16 at 21:43 +0000, Matthew Wilcox wrote:
> People find it hard to use the right tag when sending patches which
> affect a maintainer that they don't interact with often. If we add
> a field to MAINTAINERS, perhaps a tool will be written some day that
> automatically adds it to patches.
I am not against the concept, but at least the initial entries
should mirror what is currently used.
> diff --git a/MAINTAINERS b/MAINTAINERS
[]
> @@ -14927,6 +14929,7 @@ M: Pawel Osciak <pawel@osciak.com>
> M: Marek Szyprowski <m.szyprowski@samsung.com>
> M: Kyungmin Park <kyungmin.park@samsung.com>
> L: linux-media@vger.kernel.org
> +J: videobuf
> S: Maintained
> F: drivers/media/v4l2-core/videobuf2-*
> F: include/media/videobuf2-*
This isn't useful.
Almost every patch to this pattern is prefixed with something else.
$ git log --pretty=oneline --no-merges -- 'drivers/media/v4l2-core/videobuf2-*'
03fbdb2fc2b8bb27b0ee0534fd3e9c57cdc3854a media: move videobuf2 to drivers/media/common
c0cb76589c77b9a05f6271691be8707104ff0241 media: vb2: unify calling of set_page_dirty_lock
327553ae8eb87a66b2c9e041e890ea66f21009b2 media: vb2: clear V4L2_BUF_FLAG_LAST when filling vb2_buffer
d28b2cf969b1e887450700191c22df8085574e9b media: v4l2-core: Fix kernel-doc markups
2a87af6ba1b9df4dda91d7e1a7d750f295ce1e57 media: videobuf2: don't use kernel-doc "/**" markups
c4860ad60564838994b74e7ee7dd12ceeda0f520 lib/scatterlist: Fix offset type in sg_alloc_table_from_pages
5b6f9abe5a49df81737fbbfba890ee5b093f8168 media: vb2: add bidirectional flag in vb2_queue
07ca2d4c0f44086eb38bbe0b3f86a379a701e2dc media: vb2: core: Lower the log level of debug outputs
efaf515f0d5124193393e37adbef423866a99273 media: vb2 dma-sg: Constify dma_buf_ops structures
59310b7a06c1f9c7d8fd2d981dbc85226214dc32 media: vb2 vmalloc: Constify dma_buf_ops structures
6e03db38631f5607e81856418ffe779c29e53c56 media: vb2 dma-contig: Constify dma_buf_ops structures
758d90e161382c134b7cbd5f724df4de02f3c67e [media] v4l2-core: Use kvmalloc() for potentially big allocations
72b7876c2e3b6087c72ce030d8145ec4a7328121 [media] vb2: Fix error handling in '__vb2_buf_mem_alloc'
a136f59c0a1f1b09eb203951975e3fc5e8d3e722 [media] vb2: Move buffer cache synchronisation to prepare from queue
6aca5b8fb86681954e6715494e74106db505701c [media] vb2: Rename confusingly named internal buffer preparation functions
ef6ff8f47263b1a98b7c3a8d7ee30c1d5b0afdfa [media] vb2: Fix an off by one error in 'vb2_plane_vaddr'
f9b67f0014cba18f1aabb6fa9272335a043eb6fd dma-buf: Rename dma-ops to prevent conflict with kunmap_atomic macro
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2021-12-17 2:45 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2021-12-16 21:43 [RFC] Add a 'tag' field to MAINTAINERS Matthew Wilcox
2021-12-17 2:39 ` Joe Perches
2021-12-17 2:45 ` Joe Perches
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.