All of lore.kernel.org
 help / color / mirror / Atom feed
From: Thierry Reding <thierry.reding@gmail.com>
To: "Uwe Kleine-König" <u.kleine-koenig@pengutronix.de>
Cc: Wan Jiabing <wanjiabing@vivo.com>,
	kernel@pengutronix.de, linux-pwm@vger.kernel.org,
	linux-riscv@lists.infradead.org,
	Palmer Dabbelt <palmer@dabbelt.com>,
	Paul Walmsley <paul.walmsley@sifive.com>,
	Yash Shah <yash.shah@sifive.com>,
	Atish Patra <atishp@atishpatra.org>,
	"Wesley W. Terpstra" <wesley@sifive.com>
Subject: Re: [PATCH 1/7] pwm: sifive: Simplify offset calculation for PWMCMP registers
Date: Thu, 28 Jul 2022 19:12:44 +0200	[thread overview]
Message-ID: <YuLDjCnlvJLSGX8r@orome> (raw)
In-Reply-To: <20220721103129.304697-1-u.kleine-koenig@pengutronix.de>

[-- Attachment #1: Type: text/plain, Size: 738 bytes --]

On Thu, Jul 21, 2022 at 12:31:23PM +0200, Uwe Kleine-König wrote:
> Instead of explicitly using PWM_SIFIVE_PWMCMP0 + pwm->hwpwm *
> PWM_SIFIVE_SIZE_PWMCMP for each access to one of the PWMCMP registers,
> introduce a macro that takes the hwpwm id as parameter.
> 
> For the register definition using a plain 4 instead of the cpp constant
> PWM_SIFIVE_SIZE_PWMCMP is easier to read, so define the offset macro
> without the constant. The latter can then be dropped as there are no
> users left.
> 
> Signed-off-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
> ---
>  drivers/pwm/pwm-sifive.c | 10 +++-------
>  1 file changed, 3 insertions(+), 7 deletions(-)

I've applied the whole series now, thanks.

Thierry

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

WARNING: multiple messages have this Message-ID (diff)
From: Thierry Reding <thierry.reding@gmail.com>
To: "Uwe Kleine-König" <u.kleine-koenig@pengutronix.de>
Cc: Wan Jiabing <wanjiabing@vivo.com>,
	kernel@pengutronix.de, linux-pwm@vger.kernel.org,
	linux-riscv@lists.infradead.org,
	Palmer Dabbelt <palmer@dabbelt.com>,
	Paul Walmsley <paul.walmsley@sifive.com>,
	Yash Shah <yash.shah@sifive.com>,
	Atish Patra <atishp@atishpatra.org>,
	"Wesley W. Terpstra" <wesley@sifive.com>
Subject: Re: [PATCH 1/7] pwm: sifive: Simplify offset calculation for PWMCMP registers
Date: Thu, 28 Jul 2022 19:12:44 +0200	[thread overview]
Message-ID: <YuLDjCnlvJLSGX8r@orome> (raw)
In-Reply-To: <20220721103129.304697-1-u.kleine-koenig@pengutronix.de>


[-- Attachment #1.1: Type: text/plain, Size: 738 bytes --]

On Thu, Jul 21, 2022 at 12:31:23PM +0200, Uwe Kleine-König wrote:
> Instead of explicitly using PWM_SIFIVE_PWMCMP0 + pwm->hwpwm *
> PWM_SIFIVE_SIZE_PWMCMP for each access to one of the PWMCMP registers,
> introduce a macro that takes the hwpwm id as parameter.
> 
> For the register definition using a plain 4 instead of the cpp constant
> PWM_SIFIVE_SIZE_PWMCMP is easier to read, so define the offset macro
> without the constant. The latter can then be dropped as there are no
> users left.
> 
> Signed-off-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
> ---
>  drivers/pwm/pwm-sifive.c | 10 +++-------
>  1 file changed, 3 insertions(+), 7 deletions(-)

I've applied the whole series now, thanks.

Thierry

[-- Attachment #1.2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

[-- Attachment #2: Type: text/plain, Size: 161 bytes --]

_______________________________________________
linux-riscv mailing list
linux-riscv@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-riscv

  parent reply	other threads:[~2022-07-28 17:12 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-07-21 10:31 [PATCH 1/7] pwm: sifive: Simplify offset calculation for PWMCMP registers Uwe Kleine-König
2022-07-21 10:31 ` Uwe Kleine-König
2022-07-21 10:31 ` [PATCH 2/7] pwm: sifive: Fold pwm_sifive_enable() into its only caller Uwe Kleine-König
2022-07-21 10:31   ` Uwe Kleine-König
2022-07-21 10:31 ` [PATCH 3/7] pwm: sifive: Reduce time the controller lock is held Uwe Kleine-König
2022-07-21 10:31   ` Uwe Kleine-König
2022-07-21 10:31 ` [PATCH 4/7] pwm: sifive: Enable clk only after period check in .apply() Uwe Kleine-König
2022-07-21 10:31   ` Uwe Kleine-König
2022-07-21 10:31 ` [PATCH 5/7] pwm: sifive: Simplify clk handling Uwe Kleine-König
2022-07-21 10:31   ` Uwe Kleine-König
2022-07-21 10:31 ` [PATCH 6/7] pwm: sifive: Ensure the clk is enabled exactly one per running PWM Uwe Kleine-König
2022-07-21 10:31   ` Uwe Kleine-König
2022-07-21 20:45   ` Uwe Kleine-König
2022-07-21 20:45     ` Uwe Kleine-König
2022-07-28 17:10     ` Thierry Reding
2022-07-28 17:10       ` Thierry Reding
2022-07-21 10:31 ` [PATCH 7/7] pwm: sifive: Shut down hardware only after pwmchip_remove() completed Uwe Kleine-König
2022-07-21 10:31   ` Uwe Kleine-König
2022-07-22 17:45   ` Emil Renner Berthing
2022-07-22 17:45     ` Emil Renner Berthing
2022-07-28 17:12     ` Thierry Reding
2022-07-28 17:12       ` Thierry Reding
2022-07-28 17:45       ` Conor.Dooley
2022-07-28 17:45         ` Conor.Dooley
2022-07-28 17:12 ` Thierry Reding [this message]
2022-07-28 17:12   ` [PATCH 1/7] pwm: sifive: Simplify offset calculation for PWMCMP registers Thierry Reding

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YuLDjCnlvJLSGX8r@orome \
    --to=thierry.reding@gmail.com \
    --cc=atishp@atishpatra.org \
    --cc=kernel@pengutronix.de \
    --cc=linux-pwm@vger.kernel.org \
    --cc=linux-riscv@lists.infradead.org \
    --cc=palmer@dabbelt.com \
    --cc=paul.walmsley@sifive.com \
    --cc=u.kleine-koenig@pengutronix.de \
    --cc=wanjiabing@vivo.com \
    --cc=wesley@sifive.com \
    --cc=yash.shah@sifive.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.