All of lore.kernel.org
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Arnd Bergmann <arnd@arndb.de>
Cc: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>,
	linux-i2c@vger.kernel.org, linux-kernel@vger.kernel.org,
	Bartosz Golaszewski <brgl@bgdev.pl>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Subject: Re: [PATCH v1 1/1] at24: Drop of_match_ptr() and ACPI_PTR() protections
Date: Tue, 25 Feb 2025 12:37:51 +0200	[thread overview]
Message-ID: <Z72dfxKzLLORkLl1@smile.fi.intel.com> (raw)
In-Reply-To: <b8a1315a-8d86-4904-92d1-179699f54e03@app.fastmail.com>

On Tue, Feb 25, 2025 at 11:29:05AM +0100, Arnd Bergmann wrote:
> On Tue, Feb 25, 2025, at 11:08, Andy Shevchenko wrote:
> > These result in a very small reduction in driver size, but at the cost
> > of more complex build and slightly harder to read code. In the case of
> > of_match_ptr() it also prevents use of PRP0001 ACPI based identification.
> > In this particular case we have a valid ACPI/PNP ID that should be used
> > in preference to PRP0001 but doesn't mean we should prevent that route.
> >
> > With this done, drop unneeded of*.h inclusions and __maybe_unused markers.
> >
> > Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> 
> Acked-by: Arnd Bergmann <arnd@arndb.de>

Thank you!

> For reference, see below for a couple of patches in this area that
> I have sent in the past. Ideally I think we should try to fix these
> all up and enable -Wunused-const-variable, which is useful in its
> own right.

Agree.

> Your patch does not address a warning, but it's still a step
> in that direction.

Yeah, because the original code uses __maybe_unused markers.

...

> Subject: [PATCH] [SUBMITTED 20240403] spi: remove incorrect of_match_ptr
>  annotations

Was it applied (and the rest you provided here)?

To me sounds like a good cleanup that should be applier sooner than later to
move forward of getting rid of of_match_ptr()/ACPI_PTR() completely.

-- 
With Best Regards,
Andy Shevchenko



  reply	other threads:[~2025-02-25 10:37 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-25 10:08 [PATCH v1 1/1] at24: Drop of_match_ptr() and ACPI_PTR() protections Andy Shevchenko
2025-02-25 10:29 ` Arnd Bergmann
2025-02-25 10:37   ` Andy Shevchenko [this message]
2025-02-25 10:42     ` Arnd Bergmann
2025-02-25 10:48       ` Andy Shevchenko
2025-02-25 18:09         ` Arnd Bergmann
2025-02-25 17:21   ` Krzysztof Kozlowski
2025-02-26 14:18     ` Andy Shevchenko
2025-02-27  8:18       ` Arnd Bergmann
2025-03-03 11:07 ` Bartosz Golaszewski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Z72dfxKzLLORkLl1@smile.fi.intel.com \
    --to=andriy.shevchenko@linux.intel.com \
    --cc=arnd@arndb.de \
    --cc=bartosz.golaszewski@linaro.org \
    --cc=brgl@bgdev.pl \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-i2c@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.