From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Krzysztof Kozlowski <krzk@kernel.org>
Cc: Arnd Bergmann <arnd@arndb.de>,
Bartosz Golaszewski <bartosz.golaszewski@linaro.org>,
linux-i2c@vger.kernel.org, linux-kernel@vger.kernel.org,
Bartosz Golaszewski <brgl@bgdev.pl>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Subject: Re: [PATCH v1 1/1] at24: Drop of_match_ptr() and ACPI_PTR() protections
Date: Wed, 26 Feb 2025 16:18:28 +0200 [thread overview]
Message-ID: <Z78itKfsojtMpr_o@smile.fi.intel.com> (raw)
In-Reply-To: <88ad89bc-9261-4af0-a7ab-28dd760af567@kernel.org>
On Tue, Feb 25, 2025 at 06:21:29PM +0100, Krzysztof Kozlowski wrote:
> On 25/02/2025 11:29, Arnd Bergmann wrote:
> > On Tue, Feb 25, 2025, at 11:08, Andy Shevchenko wrote:
> >> These result in a very small reduction in driver size, but at the cost
> >> of more complex build and slightly harder to read code. In the case of
> >> of_match_ptr() it also prevents use of PRP0001 ACPI based identification.
> >> In this particular case we have a valid ACPI/PNP ID that should be used
> >> in preference to PRP0001 but doesn't mean we should prevent that route.
> >>
> >> With this done, drop unneeded of*.h inclusions and __maybe_unused markers.
> >>
> >> Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> >
> > Acked-by: Arnd Bergmann <arnd@arndb.de>
> >
> > For reference, see below for a couple of patches in this area that
> > I have sent in the past. Ideally I think we should try to fix these
> > all up and enable -Wunused-const-variable, which is useful in its
> > own right.
>
> I tried to fix this in SPI, regulator and ASoC 2 years ago and Mark
> rejected such approach of dropping ACPI/of_match_ptr. AFAIU, Mark wants
> this to be fixed in more generic way, on the OF and ACPI common code,
> not per driver.
>
> SPI:
> https://lore.kernel.org/all/7a65d775-cf07-4393-8b10-2cef4d5266ab@sirena.org.uk/
>
> regulator:
> https://lore.kernel.org/all/20230310214553.275450-1-krzysztof.kozlowski@linaro.org/
>
> ASoC:
> https://lore.kernel.org/all/20230310214333.274903-1-krzysztof.kozlowski@linaro.org/
It was almost two years ago. Things may be changed :-)
At least I have no impediments so far with converting drivers I'm supporting in
the SPI. For ASoC there might be a new attempt by Cezary Rojewski in the future
(he does some cleanups in that area, and we discussed cleaning up ACPI_PTR() at
minimum).
Also note
$ git grep -lw ACPI_PTR | wc -l
238
$ git grep -lw of_match_ptr | wc -l
841
So, at least dropping ACPI_PTR() seems on the track to getting rid of.
And I checked, they are spread all over the kernel with top subsystems as
...
10 drivers/hwtracing/coresight
11 drivers/input/touchscreen
15 drivers/media/i2c
53 sound/soc/codecs
--
With Best Regards,
Andy Shevchenko
next prev parent reply other threads:[~2025-02-26 14:18 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-25 10:08 [PATCH v1 1/1] at24: Drop of_match_ptr() and ACPI_PTR() protections Andy Shevchenko
2025-02-25 10:29 ` Arnd Bergmann
2025-02-25 10:37 ` Andy Shevchenko
2025-02-25 10:42 ` Arnd Bergmann
2025-02-25 10:48 ` Andy Shevchenko
2025-02-25 18:09 ` Arnd Bergmann
2025-02-25 17:21 ` Krzysztof Kozlowski
2025-02-26 14:18 ` Andy Shevchenko [this message]
2025-02-27 8:18 ` Arnd Bergmann
2025-03-03 11:07 ` Bartosz Golaszewski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Z78itKfsojtMpr_o@smile.fi.intel.com \
--to=andriy.shevchenko@linux.intel.com \
--cc=arnd@arndb.de \
--cc=bartosz.golaszewski@linaro.org \
--cc=brgl@bgdev.pl \
--cc=gregkh@linuxfoundation.org \
--cc=krzk@kernel.org \
--cc=linux-i2c@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.