All of lore.kernel.org
 help / color / mirror / Atom feed
From: Oleksii Kurochko <oleksii.kurochko@gmail.com>
To: Jan Beulich <jbeulich@suse.com>
Cc: "Stefano Stabellini" <sstabellini@kernel.org>,
	"Julien Grall" <julien@xen.org>,
	"Bertrand Marquis" <bertrand.marquis@arm.com>,
	"Michal Orzel" <michal.orzel@amd.com>,
	"Volodymyr Babchuk" <Volodymyr_Babchuk@epam.com>,
	"Andrew Cooper" <andrew.cooper3@citrix.com>,
	"Anthony PERARD" <anthony.perard@vates.tech>,
	"Roger Pau Monné" <roger.pau@citrix.com>,
	xen-devel@lists.xenproject.org
Subject: Re: [PATCH v1 2/9] asm-generic: move parts of Arm's asm/kernel.h to asm-generic
Date: Mon, 3 Feb 2025 16:34:04 +0100	[thread overview]
Message-ID: <a2e07db1-ce5b-4999-9dbd-e7e097061d2a@gmail.com> (raw)
In-Reply-To: <2f14762e-d302-483c-8adb-3223e6290de0@suse.com>

[-- Attachment #1: Type: text/plain, Size: 2216 bytes --]


On 1/27/25 12:15 PM, Jan Beulich wrote:
> On 08.01.2025 12:13, Oleksii Kurochko wrote:
>> Move the following parts to asm-generic with the following changes:
>> - struct kernel_info:
>>    - Create arch_kernel_info for arch specific kernel information.
>>      At the moment, it contains domain_type for Arm.
>>    - Rename vpl011 to vuart to have more generic name suitable for other archs.
>>    - s/phandle_gic/phandle_intc to have more generic name suitable for other
>>      archs.
>>    - Make text_offset of zimage structure available for RISCV_64.
>> - Wrap by `#ifdef KERNEL_INFO_SHM_MEM_INIT` definition of KERNEL_SHM_MEM_INIT
>>    and wrap by `#ifndef KERNEL_INFO_INIT` definition of KERNEL_INFO_INIT to have
>>    ability to override KERNEL_INFO_SHM_MEM_INIT for arch in case it doesn't
>>    want to use generic one.
>> - All other parts are left as is from Arm's asm/kernel.h
>>
>> Because of the changes in struct kernel_info the correspondent parts of Arm's
>> code are updated.
>>
>> As part of this patch the following clean up happens:
>> - Drop asm/setup.h from asm/kernel.h as nothing depends from it.
>>    Add inclusion of asm/setup.h for a code which uses device_tree_get_reg() to
>>    avoid compilation issues for CONFIG_STATIC_MEMORY and CONFIG_STATIC_SHM.
>>
>> Signed-off-by: Oleksii Kurochko<oleksii.kurochko@gmail.com>
> I question that what is being moved qualifies for asm-generic, an in particular
> for a header named kernel.h. Some of what you move may make sense to move to
> dom0less-build.h instead. But everything that doesn't fit there needs to find
> a different home, imo.

It doesn't clear what then should be in kernel.h, I did in this way to not have a problem with header inclusion
during the build of Arm.

Definitions DOM0LESSS_* could be moved to dom0less-build.h, all other doesn't really connected only to dom0less feature
and could be re-used for dom0 so it seems like it should leave in a separate header ( if kernel.h isn't good for it ).

Probably kernel.h shouldn't leave in asm-generic as nothing architecture specific is in it, but on the other hand, will it
be okay to have something in xen/include if it isn't supported by all architectures?

~ Oleksii

[-- Attachment #2: Type: text/html, Size: 2745 bytes --]

  reply	other threads:[~2025-02-03 15:34 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-01-08 11:13 [PATCH for 4.21 v1 0/9] Move parts of Arm's Dom0less to common code Oleksii Kurochko
2025-01-08 11:13 ` [PATCH v1 1/9] xen/common: dom0less: make some parts of Arm's CONFIG_DOM0LESS common Oleksii Kurochko
2025-01-27 11:12   ` Jan Beulich
2025-02-03 15:18     ` Oleksii Kurochko
2025-01-08 11:13 ` [PATCH v1 2/9] asm-generic: move parts of Arm's asm/kernel.h to asm-generic Oleksii Kurochko
2025-01-27 11:15   ` Jan Beulich
2025-02-03 15:34     ` Oleksii Kurochko [this message]
2025-02-03 16:33       ` Jan Beulich
2025-01-08 11:13 ` [PATCH v1 3/9] arm/static-shmem.h: drop inclusion of asm/setup.h Oleksii Kurochko
2025-01-08 11:13 ` [PATCH v1 4/9] asm-generic: move Arm's static-memory.h to asm-generic Oleksii Kurochko
2025-01-27 11:19   ` Jan Beulich
2025-02-03 15:45     ` Oleksii Kurochko
2025-01-08 11:13 ` [PATCH v1 5/9] asm-generic: move Arm's static-shmem.h " Oleksii Kurochko
2025-01-08 11:13 ` [PATCH v1 6/9] asm-generic: move some parts of Arm's domain_build.h to asm-generic header Oleksii Kurochko
2025-01-27 11:23   ` Jan Beulich
2025-02-03 15:50     ` Oleksii Kurochko
2025-02-03 16:38       ` Jan Beulich
2025-01-08 11:13 ` [PATCH v1 7/9] xen/common: dom0less: introduce common kernel.c Oleksii Kurochko
2025-01-08 11:13 ` [PATCH v1 8/9] xen/common: dom0less: introduce common domain-build.c Oleksii Kurochko
2025-01-08 11:13 ` [PATCH v1 9/9] xen/common: dom0less: introduce common dom0less-build.c Oleksii Kurochko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=a2e07db1-ce5b-4999-9dbd-e7e097061d2a@gmail.com \
    --to=oleksii.kurochko@gmail.com \
    --cc=Volodymyr_Babchuk@epam.com \
    --cc=andrew.cooper3@citrix.com \
    --cc=anthony.perard@vates.tech \
    --cc=bertrand.marquis@arm.com \
    --cc=jbeulich@suse.com \
    --cc=julien@xen.org \
    --cc=michal.orzel@amd.com \
    --cc=roger.pau@citrix.com \
    --cc=sstabellini@kernel.org \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.