All of lore.kernel.org
 help / color / mirror / Atom feed
From: dmkhn@proton.me
To: Jan Beulich <jbeulich@suse.com>
Cc: xen-devel@lists.xenproject.org, andrew.cooper3@citrix.com,
	anthony.perard@vates.tech, julien@xen.org, michal.orzel@amd.com,
	roger.pau@citrix.com, dmukhin@ford.com,
	Stefano Stabellini <sstabellini@kernel.org>
Subject: Re: [PATCH v1 1/3] xen/console: cleanup conring management
Date: Mon, 28 Apr 2025 20:10:02 +0000	[thread overview]
Message-ID: <aA/glq9zB1phFcAf@kraken> (raw)
In-Reply-To: <fe9a99b2-e208-4171-ada0-c244bfab6559@suse.com>

On Mon, Apr 28, 2025 at 08:47:01AM +0200, Jan Beulich wrote:
> On 26.04.2025 00:18, Stefano Stabellini wrote:
> > On Thu, 3 Apr 2025, dmkhn@proton.me wrote:
> >> From: Denis Mukhin <dmukhin@ford.com>
> >>
> >> Move console_locks_busted handling inside conring_puts() to remove
> >> tasklet code duplication.
> >>
> >> Signed-off-by: Denis Mukhin <dmukhin@ford.com>
> >
> > This patch is a good cleanup but makes one functional change: previously
> > guest_console_write would always call tasklet_schedule. Now, it only
> > calls tasklet_schedule if !console_locks_busted.
> >
> > On ARM, we don't call console_force_unlock and never set
> > console_locks_busted. It makes no difference.
> >
> > On x86, there are a few callers of console_force_unlock, so it would
> > make a difference. However, looking at the callers, it seems to me that
> > the change is for the better and better aligns the code with the
> > intention behind console_force_unlock.
> 
> Denis, I see you submitted v2 without any adjustment to the description.
> With Stefano having pointed out the aspect, it should have been pretty
> clear that such a (kind of hidden) functional change wants justifying.
> 
> Furthermore, you added Stefano's R-b without any hint towards the extra
> request he had put up above wrt x86.

Sorry for that, I will update the descriptions in the next iteration.
I am preparing the update, which reverts the locking part completely. 

> 
> Jan



  reply	other threads:[~2025-04-28 20:10 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-04-03  0:06 [PATCH v1 0/3] xen/console: few cleanups in console driver dmkhn
2025-04-03  0:06 ` [PATCH v1 1/3] xen/console: cleanup conring management dmkhn
2025-04-08 15:10   ` Jan Beulich
2025-04-25 22:18   ` Stefano Stabellini
2025-04-28  6:47     ` Jan Beulich
2025-04-28 20:10       ` dmkhn [this message]
2025-04-03  0:06 ` [PATCH v1 2/3] xen/console: introduce console_puts() dmkhn
2025-04-25 22:35   ` Stefano Stabellini
2025-04-25 22:47   ` Stefano Stabellini
2025-04-28  1:47     ` dmkhn
2025-04-03  0:06 ` [PATCH v1 3/3] xen/console: introduce conring_flush() dmkhn
2025-04-25 22:53   ` Stefano Stabellini

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aA/glq9zB1phFcAf@kraken \
    --to=dmkhn@proton.me \
    --cc=andrew.cooper3@citrix.com \
    --cc=anthony.perard@vates.tech \
    --cc=dmukhin@ford.com \
    --cc=jbeulich@suse.com \
    --cc=julien@xen.org \
    --cc=michal.orzel@amd.com \
    --cc=roger.pau@citrix.com \
    --cc=sstabellini@kernel.org \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.