All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jani Nikula <jani.nikula@linux.intel.com>
To: Ankit Nautiyal <ankit.k.nautiyal@intel.com>,
	intel-gfx@lists.freedesktop.org,
	intel-gvt-dev@lists.freedesktop.org,
	intel-xe@lists.freedesktop.org
Cc: Ankit Nautiyal <ankit.k.nautiyal@intel.com>
Subject: Re: [PATCH 0/7] Prepare GVT for display modularization
Date: Thu, 18 Dec 2025 12:57:08 +0200	[thread overview]
Message-ID: <aec7910187fc14d556af6fb84c4b9e6a43575f37@intel.com> (raw)
In-Reply-To: <20251218082302.2327243-1-ankit.k.nautiyal@intel.com>

On Thu, 18 Dec 2025, Ankit Nautiyal <ankit.k.nautiyal@intel.com> wrote:
> GVT currently relies on display internals through register macros and
> helpers like for_each_pipe(). This tight coupling makes modularization
> difficult because GVT should not access struct intel_display directly.
> Add an API for GVT code to expose DISPLAY_RUNTIME_INFO()->pipe_mask.
> This series introduces changes to make GVT independent of display internals
> while keeping existing macros usable:
>
> - Abstract offset calculations in display using
>   INTEL_DISPLAY_DEVICE_*_OFFSET() macros.
> - Add APIs for GVT to compute offsets and pipe mask via functions.
> - Update GVT to use these APIs by overriding helper macros and
>   for_each_pipe().

Oh, this doesn't handle intel_gvt_mmio_table.c, which is part of i915.

That can be a follow-up, I guess, but still needs to be addressed.

BR,
Jani.

>
> Rev2:
> - Remove conflicting headers and get rid of #ifdefs/#undefs in last
>   patch.
> - Wrap macro arguments in paranthesis.
> - Rename for_each_pipe to gvt_for_each_pipe.
>
> PS: I have not yet addressed the question about whether we need to start
>     using _MMIO_TRANS2() instead of_MMIO_PIPE2() in TRANSCONF() macro.
>     That likely needs a separate patch and discussion.
>     For now, I have kept the patch#4 to deal with the
>     -Werror=enum-conversion:
>      - drm/i915/gvt/display_helpers: Cast argument to enum pipe for
>        pipe-offset macro
>
> Ankit Nautiyal (7):
>   drm/i915/display: Abstract pipe/trans/cursor offset calculation
>   drm/i915/display: Add APIs to be used by gvt to get the register
>     offsets
>   drm/i915/gvt: Add header to use display offset functions in macros
>   drm/i915/gvt/display_helpers: Cast argument to enum pipe for
>     pipe-offset macro
>   drm/i915/gvt: Change for_each_pipe to use pipe_valid API
>   drm/i915/gvt: Use the appropriate header for the DPLL macro
>   drm/i915/gvt/display_helper: Get rid of #ifdef/#undefs
>
>  drivers/gpu/drm/i915/Makefile                 |  1 +
>  .../drm/i915/display/intel_display_device.h   | 17 +++++++
>  .../drm/i915/display/intel_display_limits.c   |  0
>  .../drm/i915/display/intel_display_reg_defs.h | 15 ++-----
>  drivers/gpu/drm/i915/display/intel_gvt_api.c  | 45 +++++++++++++++++++
>  drivers/gpu/drm/i915/display/intel_gvt_api.h  | 21 +++++++++
>  drivers/gpu/drm/i915/gvt/cmd_parser.c         |  2 +-
>  drivers/gpu/drm/i915/gvt/display.c            |  9 ++--
>  drivers/gpu/drm/i915/gvt/display_helpers.h    | 27 +++++++++++
>  drivers/gpu/drm/i915/gvt/fb_decoder.c         |  2 +-
>  drivers/gpu/drm/i915/gvt/handlers.c           |  2 +-
>  11 files changed, 123 insertions(+), 18 deletions(-)
>  create mode 100644 drivers/gpu/drm/i915/display/intel_display_limits.c
>  create mode 100644 drivers/gpu/drm/i915/display/intel_gvt_api.c
>  create mode 100644 drivers/gpu/drm/i915/display/intel_gvt_api.h
>  create mode 100644 drivers/gpu/drm/i915/gvt/display_helpers.h

-- 
Jani Nikula, Intel

  parent reply	other threads:[~2025-12-18 10:57 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-12-18  8:22 [PATCH 0/7] Prepare GVT for display modularization Ankit Nautiyal
2025-12-18  8:22 ` [PATCH 1/7] drm/i915/display: Abstract pipe/trans/cursor offset calculation Ankit Nautiyal
2025-12-18  8:22 ` [PATCH 2/7] drm/i915/display: Add APIs to be used by gvt to get the register offsets Ankit Nautiyal
2025-12-18 10:32   ` Jani Nikula
2025-12-18 12:09     ` Nautiyal, Ankit K
2025-12-18  8:22 ` [PATCH 3/7] drm/i915/gvt: Add header to use display offset functions in macros Ankit Nautiyal
2025-12-18 10:26   ` Jani Nikula
2025-12-18  8:22 ` [PATCH 4/7] drm/i915/gvt/display_helpers: Cast argument to enum pipe for pipe-offset macro Ankit Nautiyal
2025-12-18 10:25   ` Jani Nikula
2025-12-18 12:06     ` Nautiyal, Ankit K
2025-12-18  8:22 ` [PATCH 5/7] drm/i915/gvt: Change for_each_pipe to use pipe_valid API Ankit Nautiyal
2025-12-18 10:36   ` Jani Nikula
2025-12-18 11:57     ` Nautiyal, Ankit K
2025-12-18  8:22 ` [PATCH 6/7] drm/i915/gvt: Use the appropriate header for the DPLL macro Ankit Nautiyal
2025-12-18 10:36   ` Jani Nikula
2025-12-18  8:23 ` [PATCH 7/7] drm/i915/gvt/display_helper: Get rid of #ifdef/#undefs Ankit Nautiyal
2025-12-18 10:37   ` Jani Nikula
2025-12-18  8:43 ` ✗ CI.checkpatch: warning for Prepare GVT for display modularization (rev2) Patchwork
2025-12-18  8:44 ` ✓ CI.KUnit: success " Patchwork
2025-12-18  9:00 ` ✗ CI.checksparse: warning " Patchwork
2025-12-18  9:38 ` ✓ Xe.CI.BAT: success " Patchwork
2025-12-18 10:36 ` ✓ i915.CI.BAT: " Patchwork
2025-12-18 10:57 ` Jani Nikula [this message]
2025-12-18 12:05   ` [PATCH 0/7] Prepare GVT for display modularization Nautiyal, Ankit K
2025-12-18 13:51 ` ✓ i915.CI.Full: success for Prepare GVT for display modularization (rev2) Patchwork
2025-12-19  4:17 ` ✗ Xe.CI.Full: failure " Patchwork
2025-12-29 12:47 ` [PATCH 0/7] Prepare GVT for display modularization Nautiyal, Ankit K
2025-12-31 10:35   ` Jani Nikula
2026-01-02  6:15     ` Nautiyal, Ankit K
2026-01-02 11:24       ` Jani Nikula

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=aec7910187fc14d556af6fb84c4b9e6a43575f37@intel.com \
    --to=jani.nikula@linux.intel.com \
    --cc=ankit.k.nautiyal@intel.com \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=intel-gvt-dev@lists.freedesktop.org \
    --cc=intel-xe@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.