From: Julia Lawall <julia.lawall@inria.fr>
To: Joe Perches <joe@perches.com>
Cc: Kees Cook <keescook@chromium.org>,
"Gustavo A . R . Silva" <gustavoars@kernel.org>,
cocci@systeme.lip6.fr, linux-kernel@vger.kernel.org
Subject: Re: [Cocci] [RFC PATCH] coccinelle: misc: add uninitialized_var.cocci script
Date: Sat, 29 Aug 2020 21:48:11 +0200 (CEST) [thread overview]
Message-ID: <alpine.DEB.2.22.394.2008292146170.3629@hadrien> (raw)
In-Reply-To: <489164b541e344f254b70429e4f6d467e1602931.camel@perches.com>
On Sat, 29 Aug 2020, Joe Perches wrote:
> On Sat, 2020-08-29 at 21:36 +0200, Julia Lawall wrote:
> >
> > On Wed, 12 Aug 2020, Denis Efremov wrote:
> >
> > > Commit 63a0895d960a ("compiler: Remove uninitialized_var() macro") and
> > > commit 4b19bec97c88 ("docs: deprecated.rst: Add uninitialized_var()")
> > > removed uninitialized_var() and deprecated it.
> > >
> > > The purpose of this script is to prevent new occurrences of open-coded
> > > variants of uninitialized_var().
>
> > > Cc: Kees Cook <keescook@chromium.org>
> > > Cc: Gustavo A. R. Silva <gustavoars@kernel.org>
> > > Signed-off-by: Denis Efremov <efremov@linux.com>
> >
> > Applied, without the commented out part.
> >
> > I only got three warnings, though. Perhaps the others have been fixed?
>
> uninitialized_var does not exist in -next
OK, if it seems better, I can remove it. Out of the threee reported, one
was a completely unnecessary initialization.
julia
_______________________________________________
Cocci mailing list
Cocci@systeme.lip6.fr
https://systeme.lip6.fr/mailman/listinfo/cocci
WARNING: multiple messages have this Message-ID (diff)
From: Julia Lawall <julia.lawall@inria.fr>
To: Joe Perches <joe@perches.com>
Cc: Denis Efremov <efremov@linux.com>,
cocci@systeme.lip6.fr, linux-kernel@vger.kernel.org,
Kees Cook <keescook@chromium.org>,
"Gustavo A . R . Silva" <gustavoars@kernel.org>
Subject: Re: [RFC PATCH] coccinelle: misc: add uninitialized_var.cocci script
Date: Sat, 29 Aug 2020 21:48:11 +0200 (CEST) [thread overview]
Message-ID: <alpine.DEB.2.22.394.2008292146170.3629@hadrien> (raw)
In-Reply-To: <489164b541e344f254b70429e4f6d467e1602931.camel@perches.com>
On Sat, 29 Aug 2020, Joe Perches wrote:
> On Sat, 2020-08-29 at 21:36 +0200, Julia Lawall wrote:
> >
> > On Wed, 12 Aug 2020, Denis Efremov wrote:
> >
> > > Commit 63a0895d960a ("compiler: Remove uninitialized_var() macro") and
> > > commit 4b19bec97c88 ("docs: deprecated.rst: Add uninitialized_var()")
> > > removed uninitialized_var() and deprecated it.
> > >
> > > The purpose of this script is to prevent new occurrences of open-coded
> > > variants of uninitialized_var().
>
> > > Cc: Kees Cook <keescook@chromium.org>
> > > Cc: Gustavo A. R. Silva <gustavoars@kernel.org>
> > > Signed-off-by: Denis Efremov <efremov@linux.com>
> >
> > Applied, without the commented out part.
> >
> > I only got three warnings, though. Perhaps the others have been fixed?
>
> uninitialized_var does not exist in -next
OK, if it seems better, I can remove it. Out of the threee reported, one
was a completely unnecessary initialization.
julia
next prev parent reply other threads:[~2020-08-29 19:48 UTC|newest]
Thread overview: 33+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-08-11 21:01 [Cocci] [RFC PATCH] coccinelle: misc: add uninitialized_var.cocci script Denis Efremov
2020-08-11 21:01 ` Denis Efremov
2020-08-29 19:36 ` [Cocci] " Julia Lawall
2020-08-29 19:36 ` Julia Lawall
2020-08-29 19:38 ` [Cocci] " Joe Perches
2020-08-29 19:38 ` Joe Perches
2020-08-29 19:48 ` Julia Lawall [this message]
2020-08-29 19:48 ` Julia Lawall
2020-08-29 20:13 ` [Cocci] " Denis Efremov
2020-08-29 20:13 ` Denis Efremov
2020-08-29 20:26 ` [Cocci] " Julia Lawall
2020-08-29 20:26 ` Julia Lawall
2020-09-01 7:15 ` [Cocci] [PATCH v2] " Denis Efremov
2020-09-01 7:15 ` Denis Efremov
2020-09-01 9:06 ` [Cocci] " Julia Lawall
2020-09-01 9:06 ` Julia Lawall
2020-09-01 9:48 ` [Cocci] [PATCH v3] " Denis Efremov
2020-09-01 9:48 ` Denis Efremov
2020-09-01 10:08 ` [Cocci] " Julia Lawall
2020-09-01 10:08 ` Julia Lawall
2020-09-01 14:37 ` [Cocci] checkpatch? (was: Re: [PATCH v3] coccinelle: misc: add uninitialized_var.cocci script) Joe Perches
2020-09-01 14:37 ` Joe Perches
2020-09-02 5:17 ` [Cocci] " Denis Efremov
2020-09-02 5:17 ` Denis Efremov
2020-09-05 17:18 ` [Cocci] [PATCH v3] coccinelle: misc: add uninitialized_var.cocci script Julia Lawall
2020-09-05 17:18 ` Julia Lawall
2020-09-05 17:58 ` [Cocci] [PATCH] checkpatch: Warn on self-assignments Joe Perches
2020-09-05 17:58 ` Joe Perches
2020-09-10 19:51 ` [Cocci] " Kees Cook
2020-09-10 19:51 ` Kees Cook
2020-09-10 21:35 ` [Cocci] " Joe Perches
2020-09-10 21:35 ` Joe Perches
[not found] <1b8537dd-8bf3-d3b6-4c10-af2fa623f1fe@web.de>
2020-08-12 9:27 ` [Cocci] [RFC PATCH] coccinelle: misc: add uninitialized_var.cocci script Julia Lawall
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.2.22.394.2008292146170.3629@hadrien \
--to=julia.lawall@inria.fr \
--cc=cocci@systeme.lip6.fr \
--cc=gustavoars@kernel.org \
--cc=joe@perches.com \
--cc=keescook@chromium.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.