All of lore.kernel.org
 help / color / mirror / Atom feed
From: Thomas Gleixner <tglx@linutronix.de>
To: Geert Uytterhoeven <geert@linux-m68k.org>
Cc: Linux/m68k <linux-m68k@lists.linux-m68k.org>,
	Linux Kernel Development <linux-kernel@vger.kernel.org>
Subject: Re: m68k: Convert to genirq (WIP)
Date: Tue, 31 May 2011 11:50:31 +0200 (CEST)	[thread overview]
Message-ID: <alpine.LFD.2.02.1105311146360.3078@ionos> (raw)
In-Reply-To: <alpine.DEB.2.00.1105282010370.16617@ayla.of.borg>

Geert,

On Sat, 28 May 2011, Geert Uytterhoeven wrote:

> 	Hi all,
> 
> Now sparc32 has beaten me, I pushed out my work in progress of converting m68k
> to use the generic hardirq framework:

That leaves only s390 in the rain, but I don't expect that they
replace their magic interrupt opcode ever :)

> git://git.kernel.org:/pub/scm/linux/kernel/git/geert/linux-m68k.git m68k-genirq
> http://git.kernel.org/?p=linux/kernel/git/geert/linux-m68k.git;a=shortlog;h=refs/heads/m68k-genirq
> 
> It contains the following commits:
> 
>   [1] ide-{cd,floppy,tape}, keyboard: Do not include <linux/irq.>
>   [2] m68k/irq: Rename irq_controller to irq_chip
>   [3] m68k/irq: Kill irq_node_t typedef, always use struct irq_node
>   [4] m68k/irq: Rename irq_node to irq_data
>   [5] m68k/irq: Switch irq_chip methods to "struct irq_data *data"
>   [6] m68k/irq: Rename setup_irq() to m68k_setup_irq() and make it static
>   [7] m68k/irq: Extract irq_set_chip()
>   [8] m68k/irq: Add genirq support
>   [9] m68k/atari: Convert Atari to genirq
> 
>   [1] is a temporary(?) fix to avoid redefinitions during the remainder of
>       the series,
>   [2-7] refactor the current m68k irq framework to match the generic hardirq
>         framework more closely w.r.t. to its (platform) users,
>   [8] adds generic hardirq support to the core, which can be enabled through
>       a config option, so both legacy and generic hardirq can coexist at the
>       source level during the migration,
>   [9] converts Atari to use generic hardirqs.

Very sensible approach! Patches are looking good so far! Feel free to
add Acked-by-me!

Thanks,

	tglx

WARNING: multiple messages have this Message-ID (diff)
From: Thomas Gleixner <tglx@linutronix.de>
To: Geert Uytterhoeven <geert@linux-m68k.org>
Cc: Linux/m68k <linux-m68k@vger.kernel.org>,
	Linux Kernel Development <linux-kernel@vger.kernel.org>
Subject: Re: m68k: Convert to genirq (WIP)
Date: Tue, 31 May 2011 11:50:31 +0200 (CEST)	[thread overview]
Message-ID: <alpine.LFD.2.02.1105311146360.3078@ionos> (raw)
In-Reply-To: <alpine.DEB.2.00.1105282010370.16617@ayla.of.borg>

Geert,

On Sat, 28 May 2011, Geert Uytterhoeven wrote:

> 	Hi all,
> 
> Now sparc32 has beaten me, I pushed out my work in progress of converting m68k
> to use the generic hardirq framework:

That leaves only s390 in the rain, but I don't expect that they
replace their magic interrupt opcode ever :)

> git://git.kernel.org:/pub/scm/linux/kernel/git/geert/linux-m68k.git m68k-genirq
> http://git.kernel.org/?p=linux/kernel/git/geert/linux-m68k.git;a=shortlog;h=refs/heads/m68k-genirq
> 
> It contains the following commits:
> 
>   [1] ide-{cd,floppy,tape}, keyboard: Do not include <linux/irq.>
>   [2] m68k/irq: Rename irq_controller to irq_chip
>   [3] m68k/irq: Kill irq_node_t typedef, always use struct irq_node
>   [4] m68k/irq: Rename irq_node to irq_data
>   [5] m68k/irq: Switch irq_chip methods to "struct irq_data *data"
>   [6] m68k/irq: Rename setup_irq() to m68k_setup_irq() and make it static
>   [7] m68k/irq: Extract irq_set_chip()
>   [8] m68k/irq: Add genirq support
>   [9] m68k/atari: Convert Atari to genirq
> 
>   [1] is a temporary(?) fix to avoid redefinitions during the remainder of
>       the series,
>   [2-7] refactor the current m68k irq framework to match the generic hardirq
>         framework more closely w.r.t. to its (platform) users,
>   [8] adds generic hardirq support to the core, which can be enabled through
>       a config option, so both legacy and generic hardirq can coexist at the
>       source level during the migration,
>   [9] converts Atari to use generic hardirqs.

Very sensible approach! Patches are looking good so far! Feel free to
add Acked-by-me!

Thanks,

	tglx

  parent reply	other threads:[~2011-05-31  9:50 UTC|newest]

Thread overview: 64+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-05-28 18:32 m68k: Convert to genirq (WIP) Geert Uytterhoeven
2011-05-28 18:32 ` Geert Uytterhoeven
2011-05-31  8:35 ` Geert Uytterhoeven
2011-05-31  8:35 ` Geert Uytterhoeven
2011-05-31  9:50 ` Thomas Gleixner [this message]
2011-05-31  9:50   ` Thomas Gleixner
2011-05-31 19:54 ` Geert Uytterhoeven
2011-05-31 19:54   ` Geert Uytterhoeven
2011-05-31 20:10   ` Thomas Gleixner
2011-05-31 20:10     ` Thomas Gleixner
2011-06-03 11:20 ` Finn Thain
2011-06-03 11:20   ` Finn Thain
2011-06-03 11:33   ` Geert Uytterhoeven
2011-06-03 11:33     ` Geert Uytterhoeven
2011-06-05  6:27   ` Brad Boyer
2011-06-05  6:27     ` Brad Boyer
2011-06-05  7:45     ` Geert Uytterhoeven
2011-06-05  7:45     ` Geert Uytterhoeven
2011-08-10  9:59     ` Geert Uytterhoeven
2011-08-10  9:59     ` Geert Uytterhoeven
2011-08-10 10:53       ` Finn Thain
2011-08-10 10:53         ` Finn Thain
2011-08-10 16:19         ` Brad Boyer
2011-08-10 16:19           ` Brad Boyer
2011-08-26  9:52         ` Geert Uytterhoeven
2011-08-26  9:52           ` Geert Uytterhoeven
2011-08-26 11:21           ` Finn Thain
2011-08-26 11:21             ` Finn Thain
2011-08-26 11:32             ` Geert Uytterhoeven
2011-08-26 11:32               ` Geert Uytterhoeven
2011-08-26 16:09             ` Brad Boyer
2011-08-26 16:09               ` Brad Boyer
2011-06-04 17:56 ` Geert Uytterhoeven
2011-06-15 19:44   ` Geert Uytterhoeven
2011-06-16 19:30     ` Geert Uytterhoeven
2011-06-16 19:30       ` Geert Uytterhoeven
2011-06-16 20:03       ` Thomas Gleixner
2011-06-16 20:03         ` Thomas Gleixner
2011-06-17  3:45       ` Finn Thain
2011-06-17  3:45       ` Finn Thain
2011-06-17  5:01         ` Geert Uytterhoeven
2011-06-17  5:01           ` Geert Uytterhoeven
2011-08-08 13:08         ` Geert Uytterhoeven
2011-08-08 13:08         ` Geert Uytterhoeven
2011-08-10 10:48           ` Finn Thain
2011-08-10 10:48             ` Finn Thain
2011-06-15 19:44   ` Geert Uytterhoeven
2011-06-04 17:56 ` Geert Uytterhoeven
2011-06-16 19:45 ` Geert Uytterhoeven
2011-06-16 19:45   ` Geert Uytterhoeven
2011-06-16 21:10   ` Michael Schmitz
2011-06-17 17:25     ` Andreas Schwab
2011-06-17 17:25       ` Andreas Schwab
2011-06-16 21:10   ` Michael Schmitz
2011-06-17 17:22   ` Andreas Schwab
2011-06-19 10:17     ` Geert Uytterhoeven
2011-06-19 10:17     ` Geert Uytterhoeven
2011-06-19 11:19       ` Andreas Schwab
2011-06-19 13:36         ` Geert Uytterhoeven
2011-06-19 13:58           ` Andreas Schwab
2011-06-19 13:58             ` Andreas Schwab
2011-06-19 13:36         ` Geert Uytterhoeven
2011-06-19 11:19       ` Andreas Schwab
2011-06-17 17:22   ` Andreas Schwab

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.LFD.2.02.1105311146360.3078@ionos \
    --to=tglx@linutronix.de \
    --cc=geert@linux-m68k.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-m68k@lists.linux-m68k.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.