* [PATCH] staging: rtl8723bs: rename camelcase variable psurveyPara
@ 2026-07-27 13:52 Max Raulea
2026-07-27 14:49 ` Greg KH
0 siblings, 1 reply; 2+ messages in thread
From: Max Raulea @ 2026-07-27 13:52 UTC (permalink / raw)
To: linux-staging; +Cc: gregkh, linux-kernel
Reported style issue by checkpatch in the rtl8723bs driver.
changed the variable name to psurvey_para to adhere to Linux Kernel
coding style.
Signed-off-by: Max Raulea <max.raulea@gmail.com>
---
drivers/staging/rtl8723bs/core/rtw_cmd.c | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_cmd.c b/drivers/staging/rtl8723bs/core/rtw_cmd.c
index d8ad1c75195b..6304b218bc2d 100644
--- a/drivers/staging/rtl8723bs/core/rtw_cmd.c
+++ b/drivers/staging/rtl8723bs/core/rtw_cmd.c
@@ -525,7 +525,7 @@ u8 rtw_sitesurvey_cmd(struct adapter *padapter, struct ndis_802_11_ssid *ssid,
{
u8 res = _FAIL;
struct cmd_obj *ph2c;
- struct sitesurvey_parm *psurveyPara;
+ struct sitesurvey_parm *psurvey_para;
struct cmd_priv *pcmdpriv = &padapter->cmdpriv;
struct mlme_priv *pmlmepriv = &padapter->mlmepriv;
@@ -536,18 +536,18 @@ u8 rtw_sitesurvey_cmd(struct adapter *padapter, struct ndis_802_11_ssid *ssid,
if (!ph2c)
return _FAIL;
- psurveyPara = kzalloc_obj(*psurveyPara, GFP_ATOMIC);
- if (!psurveyPara) {
+ psurvey_para = kzalloc_obj(*psurvey_para, GFP_ATOMIC);
+ if (!psurvey_para) {
kfree(ph2c);
return _FAIL;
}
rtw_free_network_queue(padapter, false);
- init_h2fwcmd_w_parm_no_rsp(ph2c, psurveyPara, SITE_SURVEY_CMD);
+ init_h2fwcmd_w_parm_no_rsp(ph2c, psurvey_para, SITE_SURVEY_CMD);
/* psurveyPara->bsslimit = 48; */
- psurveyPara->scan_mode = pmlmepriv->scan_mode;
+ psurvey_para->scan_mode = pmlmepriv->scan_mode;
/* prepare ssid list */
if (ssid) {
@@ -555,8 +555,8 @@ u8 rtw_sitesurvey_cmd(struct adapter *padapter, struct ndis_802_11_ssid *ssid,
for (i = 0; i < ssid_num && i < RTW_SSID_SCAN_AMOUNT; i++) {
if (ssid[i].ssid_length) {
- memcpy(&psurveyPara->ssid[i], &ssid[i], sizeof(struct ndis_802_11_ssid));
- psurveyPara->ssid_num++;
+ memcpy(&psurvey_para->ssid[i], &ssid[i], sizeof(struct ndis_802_11_ssid));
+ psurvey_para->ssid_num++;
}
}
}
@@ -567,8 +567,8 @@ u8 rtw_sitesurvey_cmd(struct adapter *padapter, struct ndis_802_11_ssid *ssid,
for (i = 0; i < ch_num && i < RTW_CHANNEL_SCAN_AMOUNT; i++) {
if (ch[i].hw_value && !(ch[i].flags & RTW_IEEE80211_CHAN_DISABLED)) {
- memcpy(&psurveyPara->ch[i], &ch[i], sizeof(struct rtw_ieee80211_channel));
- psurveyPara->ch_num++;
+ memcpy(&psurvey_para->ch[i], &ch[i], sizeof(struct rtw_ieee80211_channel));
+ psurvey_para->ch_num++;
}
}
}
--
2.55.0
^ permalink raw reply related [flat|nested] 2+ messages in thread
* Re: [PATCH] staging: rtl8723bs: rename camelcase variable psurveyPara
2026-07-27 13:52 [PATCH] staging: rtl8723bs: rename camelcase variable psurveyPara Max Raulea
@ 2026-07-27 14:49 ` Greg KH
0 siblings, 0 replies; 2+ messages in thread
From: Greg KH @ 2026-07-27 14:49 UTC (permalink / raw)
To: Max Raulea; +Cc: linux-staging, linux-kernel
On Mon, Jul 27, 2026 at 03:52:33PM +0200, Max Raulea wrote:
> Reported style issue by checkpatch in the rtl8723bs driver.
>
> changed the variable name to psurvey_para to adhere to Linux Kernel
> coding style.
>
> Signed-off-by: Max Raulea <max.raulea@gmail.com>
> ---
> drivers/staging/rtl8723bs/core/rtw_cmd.c | 18 +++++++++---------
> 1 file changed, 9 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/staging/rtl8723bs/core/rtw_cmd.c b/drivers/staging/rtl8723bs/core/rtw_cmd.c
> index d8ad1c75195b..6304b218bc2d 100644
> --- a/drivers/staging/rtl8723bs/core/rtw_cmd.c
> +++ b/drivers/staging/rtl8723bs/core/rtw_cmd.c
> @@ -525,7 +525,7 @@ u8 rtw_sitesurvey_cmd(struct adapter *padapter, struct ndis_802_11_ssid *ssid,
> {
> u8 res = _FAIL;
> struct cmd_obj *ph2c;
> - struct sitesurvey_parm *psurveyPara;
> + struct sitesurvey_parm *psurvey_para;
Wait, sorry, no, this isn't right.
The leading "p" here is from the windows-style Hungarian notation,
trying to say this is a pointer. When really, we know this as the
compiler knows and enforces it, so there's no need to add it to the
name.
So this really should just be survey_para, right?
thanks,
greg k-h
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2026-07-27 14:49 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-27 13:52 [PATCH] staging: rtl8723bs: rename camelcase variable psurveyPara Max Raulea
2026-07-27 14:49 ` Greg KH
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.