All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/2] acpi: add kernel option to skip binding drivers to certain devices
@ 2026-08-13  2:41 dmukhin
  2026-08-13  2:41 ` [PATCH 1/2] acpi: Use METHOD_NAME__UID instead of open-coded _UID dmukhin
  2026-08-13  2:41 ` [PATCH 2/2] acpi: bus: Introduce acpi.skip_ids= boot parameter dmukhin
  0 siblings, 2 replies; 5+ messages in thread
From: dmukhin @ 2026-08-13  2:41 UTC (permalink / raw)
  To: Rafael J . Wysocki, Len Brown, linux-acpi, linux-kernel; +Cc: Denis Mukhin

Mini series to allow fine-grained platform device ownership in
virtualized environment.

Patch 1: cleanup - replace an open-coded string with an existing symbol.
Patch 2: introduce the acpi.skip_ids= boot parameter.

Tested on: Linux 6.12.

Denis Mukhin (2):
  acpi: Use METHOD_NAME__UID instead of open-coded _UID
  acpi: bus: Introduce acpi.skip_ids= boot parameter

 .../admin-guide/kernel-parameters.txt         |  5 ++
 drivers/acpi/acpi_processor.c                 |  2 +-
 drivers/acpi/bus.c                            | 60 +++++++++++++++++--
 3 files changed, 62 insertions(+), 5 deletions(-)

-- 
2.54.0


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2026-08-13 22:43 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-08-13  2:41 [PATCH 0/2] acpi: add kernel option to skip binding drivers to certain devices dmukhin
2026-08-13  2:41 ` [PATCH 1/2] acpi: Use METHOD_NAME__UID instead of open-coded _UID dmukhin
2026-08-13  2:41 ` [PATCH 2/2] acpi: bus: Introduce acpi.skip_ids= boot parameter dmukhin
2026-08-13 10:09   ` Rafael J. Wysocki (Intel)
2026-08-13 22:43     ` dmukhin

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.