* [PATCH v13 0/1] Add USB2.0 VBUS mux driver for RZ/G3E
@ 2026-08-10 7:51 Tommaso Merciai
2026-08-10 7:51 ` [PATCH v13 1/1] mux: Add driver for Renesas RZ/V2H VBENCTL VBUS_SEL mux Tommaso Merciai
2026-08-13 10:38 ` [PATCH v13 0/1] Add USB2.0 VBUS mux driver for RZ/G3E Peter Rosin
0 siblings, 2 replies; 4+ messages in thread
From: Tommaso Merciai @ 2026-08-10 7:51 UTC (permalink / raw)
To: tomm.merciai, peda, prabhakar.mahadev-lad.rj, peda, p.zabel,
ulf.hansson
Cc: linux-renesas-soc, biju.das.jz, Tommaso Merciai, Ulf Hansson,
Alvin Šipraga, Josua Mayer, linux-kernel
Dear All,
This patch adds a new mux driver for RZ/V2H USB VBENCTL VBUS_SEL.
All patches in the original series ([0]) have been merged except this one,
so this is just a follow-up patch to add the mux driver.
[0] https://patchwork.kernel.org/project/linux-renesas-soc/cover/cover.1775047175.git.tommaso.merciai.xr@bp.renesas.com/
Thanks & Regards,
Tommaso
v12->v13
- Rebased on top of next-20260807
- Renamed CONFIG_MUX_RZV2H_USB_VBENCTL to CONFIG_MUX_RZV2H_VBENCTL and
propagated the rename to the source file and module name.
- Dropped the unneeded "depends on OF".
- Added the missing "To compile the driver as a module" paragraph to the
Kconfig help text.
- Used the REG_FIELD() macro instead of open-coding struct reg_field, and
made it const to keep checkpatch --strict without warning.
- Used dev->parent instead of adev->dev.parent in dev_get_regmap().
- Collected Reviewed-by tags from Alvin and Prabhakar (the changes above are
cosmetic, please let me know if you want them dropped).
v11->v12
- No changes, just rebased on top of next-20260714
v10->v11:
- Rebased on top of next-20260424
- PATCHES 2,3,4,5 of [0] have been merged except this one,
so this is just a follow-up patch to add the mux driver.
v9->v10:
- Rebased on top of next-20260331
- PATCH 4/5: Use struct reg_sequence and regmap_multi_reg_write()
to handle initialization, assert and deassert sequences and drop
custom struct rzv2h_usb2phy_regval.
v8->v9
- Rebased on top of next-20260326
- PATCH 1/6: Fixed driver comment year (2025 -> 2026)
- Switch from devm_regmap_init_mmio() to dev_get_regmap().
- Drop unnecessasry include bitops.h, of.h, property.h and
drivers/reset/reset-rzv2h-usb2phy.h headers, driver is now based on
regmap.
- Collected PZabel tag.
- PATCH 4/6: Collected PZabel tag.
- PATCH 5/6: New patch.
- PATCH 6/6: Drop linux/reset/reset_rzv2h_usb2phy.h dependecy as the
driver is now based on regmap and does not need the
reset driver's private header, update driver accordingly.
- Collected PZabel tag.
- Update cover letter.
v7->v8:
- Rebased on top of next-20260311
- Updated series cover letter as part of the series was already merged.
v6->v7:
- Rebased on top of next-20260128
- Split series into per subsystem series, no changes.
v5->v6:
- Rebased on top of next-20251219
- Re-arranged series order per subsystem patches.
- Patch: 3/14: Collected tag.
- Patch: 4/14: Fixed commit message.
- Split from dts patches will send separate series.
- Added merge strategy in cover letter.
v4->v5:
- Rebased on top of next-20251127
- Patch 01/22: Added Reviewed-by tag from Conor Dooley.
- Patch 06/22: Changed file name to rzv2h-usb-vbenctl.c and Fixed
Makefile, Kconfig, function names accordingly.
Changed driver .name to "vbenctl" and fix auxiliary_device_id name.
Updated commit msg.
- Patch 07/22: Update mux_name to "vbenctl" to match the driver name.
Updated commit message.
- Patch 11/22: Fixed if statement for mux_state error check.
v3->v4:
- Rebased on top of next-20251121
- Added patch 01/22 to remove nodename pattern from mux-controller schema.
- Switch back to v2 implementation for mux controller in patches
5/22, 15/22, 16/22, 21/22.
- Improved commit bodies for patches 5/22, 15/22, 16/22, 21/22.
- Removed mux_chip->dev.of_node not needed in patch 06/22.
- Collected CDooley tag in patch 09/22.
- Added missing select MULTIPLEXER into Kconfig in patch 11/22.
v2->v3:
- Rebased on top of next-20251110 + [1] + [2]
- Add missing Cc: stable@vger.kernel.org in patch 03/21
- Patch 03/21: Added missing Cc: stable@vger.kernel.org.
Improved commit body describing the removal of rzv2h_usbphy_assert_helper()
from rzv2h_usb2phy_reset_probe().
- Patch 04/21: Manipulate mux-controller as an internal node.
Improved commit body.
- Patch 05/21: The main driver is using now __devm_auxiliary_device_create()
then update the aux driver accordingly.
- Patch 06/21: Use __devm_auxiliary_device_create() to create the aux device.
- Patch 08/21: Improved commit body and mux-states description.
- Patch 14/21: Manipulate the mux controller as an internal node,
and update commit body accordingly.
- Patch 15/21: Manipulate the mux controller as an internal node,
and update commit body accordingly.
- Patch 20/21: Manipulate the mux controller as an internal node.
v1->v2:
- Rebased on top of next-20251103 + [1] + [2]
- Reworked series to use mux-state for controlling VBUS_SEL
as suggested by PZabel added also mux bindings documentation
on phy and rst side.
- Collected Conor Dooley tags
- Dropped unnecessary rzv2h_usbphy_assert_helper() function from
rzv2h_usb2phy_reset_probe()
Tommaso Merciai (1):
mux: Add driver for Renesas RZ/V2H VBENCTL VBUS_SEL mux
drivers/mux/Kconfig | 13 ++++++
drivers/mux/Makefile | 2 +
drivers/mux/rzv2h-vbenctl.c | 81 +++++++++++++++++++++++++++++++++++++
3 files changed, 96 insertions(+)
create mode 100644 drivers/mux/rzv2h-vbenctl.c
--
2.54.0
^ permalink raw reply [flat|nested] 4+ messages in thread
* [PATCH v13 1/1] mux: Add driver for Renesas RZ/V2H VBENCTL VBUS_SEL mux
2026-08-10 7:51 [PATCH v13 0/1] Add USB2.0 VBUS mux driver for RZ/G3E Tommaso Merciai
@ 2026-08-10 7:51 ` Tommaso Merciai
2026-08-13 10:38 ` [PATCH v13 0/1] Add USB2.0 VBUS mux driver for RZ/G3E Peter Rosin
1 sibling, 0 replies; 4+ messages in thread
From: Tommaso Merciai @ 2026-08-10 7:51 UTC (permalink / raw)
To: tomm.merciai, peda, prabhakar.mahadev-lad.rj, peda, p.zabel,
ulf.hansson
Cc: linux-renesas-soc, biju.das.jz, Tommaso Merciai, Ulf Hansson,
Alvin Šipraga, Josua Mayer, linux-kernel
As per the RZ/V2H(P) HW manual, VBUSEN can be controlled by the VBUS_SEL
bit of the VBENCTL Control Register. This register is mapped in the
reset framework. The reset driver expose this register as mux-controller
and instantiates this driver. The consumer will use the mux API to
control the VBUS_SEL bit.
Reviewed-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@bp.renesas.com>
Reviewed-by: Alvin Šipraga <alvin.sipraga@analog.com>
Reviewed-by: Philipp Zabel <p.zabel@pengutronix.de>
Signed-off-by: Tommaso Merciai <tommaso.merciai.xr@bp.renesas.com>
---
v12->v13
- Renamed CONFIG_MUX_RZV2H_USB_VBENCTL to CONFIG_MUX_RZV2H_VBENCTL and
propagated the rename to the source file and module name.
- Dropped the unneeded "depends on OF".
- Added the missing "To compile the driver as a module" paragraph to the
Kconfig help text.
- Used the REG_FIELD() macro instead of open-coding struct reg_field, and
made it const to keep checkpatch --strict without warning.
- Used dev->parent instead of adev->dev.parent in dev_get_regmap().
- Collected Reviewed-by tags from Alvin and Prabhakar (the changes above are
cosmetic, please let me know if you want them dropped).
v11->v12
- No changes, just rebased on top of next-20260714
v10->v11:
- No changes.
v9->v10:
- No changes.
v8->v9:
- Fixed driver comment year (2025 -> 2026)
- Switch from devm_regmap_init_mmio() to dev_get_regmap().
- Drop unnecessasry include bitops.h, of.h, property.h and
drivers/reset/reset-rzv2h-usb2phy.h headers, driver is now based on regmap.
- Collected PZabel tag.
v7->v8:
- No changes.
v6->v7:
- No changes.
v5->v6:
- No changes.
v4->v5:
- Changed file name to rzv2h-usb-vbenctl.c and Fixed
Makefile, Kconfig, function names accordingly.
- Changed driver .name to "vbenctl" and fix auxiliary_device_id name.
- Updated commit msg.
v3->v4:
- Removed mux_chip->dev.of_node not needed.
v2->v3:
- Added mux_chip->dev.of_node = dev->of_node->child as the mux-controller
is an internal node.
- Fixed auxiliary_device_id name.
- Get rdev using from platform_data.
- Drop struct auxiliary_device adev from reset_rzv2h_usb2phy_adev
as it is needed.
- Drop to_reset_rzv2h_usb2phy_adev() as it is not needed.
v1->v2:
- New patch
drivers/mux/Kconfig | 13 ++++++
drivers/mux/Makefile | 2 +
drivers/mux/rzv2h-vbenctl.c | 81 +++++++++++++++++++++++++++++++++++++
3 files changed, 96 insertions(+)
create mode 100644 drivers/mux/rzv2h-vbenctl.c
diff --git a/drivers/mux/Kconfig b/drivers/mux/Kconfig
index 6d17dfa25dad..eb34457beaab 100644
--- a/drivers/mux/Kconfig
+++ b/drivers/mux/Kconfig
@@ -70,6 +70,19 @@ config MUX_MMIO
To compile the driver as a module, choose M here: the module will
be called mux-mmio.
+config MUX_RZV2H_VBENCTL
+ tristate "Renesas RZ/V2H VBENCTL VBUS_SEL mux driver"
+ depends on RESET_RZV2H_USB2PHY || COMPILE_TEST
+ select REGMAP
+ select AUXILIARY_BUS
+ default RESET_RZV2H_USB2PHY
+ help
+ Support for the VBENCTL VBUS_SEL mux implemented on Renesas
+ RZ/V2H SoCs.
+
+ To compile the driver as a module, choose M here: the module will
+ be called mux-rzv2h-vbenctl.
+
endmenu
endif # MULTIPLEXER
diff --git a/drivers/mux/Makefile b/drivers/mux/Makefile
index 6e9fa47daf56..0854c04613b9 100644
--- a/drivers/mux/Makefile
+++ b/drivers/mux/Makefile
@@ -8,9 +8,11 @@ mux-adg792a-objs := adg792a.o
mux-adgs1408-objs := adgs1408.o
mux-gpio-objs := gpio.o
mux-mmio-objs := mmio.o
+mux-rzv2h-vbenctl-objs := rzv2h-vbenctl.o
obj-$(CONFIG_MULTIPLEXER) += mux-core.o
obj-$(CONFIG_MUX_ADG792A) += mux-adg792a.o
obj-$(CONFIG_MUX_ADGS1408) += mux-adgs1408.o
obj-$(CONFIG_MUX_GPIO) += mux-gpio.o
obj-$(CONFIG_MUX_MMIO) += mux-mmio.o
+obj-$(CONFIG_MUX_RZV2H_VBENCTL) += mux-rzv2h-vbenctl.o
diff --git a/drivers/mux/rzv2h-vbenctl.c b/drivers/mux/rzv2h-vbenctl.c
new file mode 100644
index 000000000000..2699458045f3
--- /dev/null
+++ b/drivers/mux/rzv2h-vbenctl.c
@@ -0,0 +1,81 @@
+// SPDX-License-Identifier: GPL-2.0
+/*
+ * Renesas RZ/V2H(P) VBENCTL VBUS_SEL mux driver
+ *
+ * Copyright (C) 2026 Renesas Electronics Corp.
+ */
+
+#include <linux/auxiliary_bus.h>
+#include <linux/err.h>
+#include <linux/module.h>
+#include <linux/mux/driver.h>
+#include <linux/regmap.h>
+
+#define RZV2H_VBENCTL 0xf0c
+
+struct mux_rzv2h_vbenctl_priv {
+ struct regmap_field *field;
+};
+
+static int mux_rzv2h_vbenctl_set(struct mux_control *mux, int state)
+{
+ struct mux_rzv2h_vbenctl_priv *priv = mux_chip_priv(mux->chip);
+
+ return regmap_field_write(priv->field, state);
+}
+
+static const struct mux_control_ops mux_rzv2h_vbenctl_ops = {
+ .set = mux_rzv2h_vbenctl_set,
+};
+
+static int mux_rzv2h_vbenctl_probe(struct auxiliary_device *adev,
+ const struct auxiliary_device_id *id)
+{
+ const struct reg_field reg_field = REG_FIELD(RZV2H_VBENCTL, 0, 0);
+ struct mux_rzv2h_vbenctl_priv *priv;
+ struct device *dev = &adev->dev;
+ struct mux_chip *mux_chip;
+ struct regmap *regmap;
+ int ret;
+
+ regmap = dev_get_regmap(dev->parent, NULL);
+ if (!regmap)
+ return -ENODEV;
+
+ mux_chip = devm_mux_chip_alloc(dev, 1, sizeof(*priv));
+ if (IS_ERR(mux_chip))
+ return PTR_ERR(mux_chip);
+
+ priv = mux_chip_priv(mux_chip);
+
+ priv->field = devm_regmap_field_alloc(dev, regmap, reg_field);
+ if (IS_ERR(priv->field))
+ return PTR_ERR(priv->field);
+
+ mux_chip->ops = &mux_rzv2h_vbenctl_ops;
+ mux_chip->mux[0].states = 2;
+ mux_chip->mux[0].idle_state = MUX_IDLE_AS_IS;
+
+ ret = devm_mux_chip_register(dev, mux_chip);
+ if (ret < 0)
+ return dev_err_probe(dev, ret, "Failed to register mux chip\n");
+
+ return 0;
+}
+
+static const struct auxiliary_device_id mux_rzv2h_vbenctl_ids[] = {
+ { .name = "rzv2h_usb2phy_reset.vbenctl" },
+ { /* sentinel */ }
+};
+MODULE_DEVICE_TABLE(auxiliary, mux_rzv2h_vbenctl_ids);
+
+static struct auxiliary_driver mux_rzv2h_vbenctl_driver = {
+ .name = "vbenctl",
+ .probe = mux_rzv2h_vbenctl_probe,
+ .id_table = mux_rzv2h_vbenctl_ids,
+};
+module_auxiliary_driver(mux_rzv2h_vbenctl_driver);
+
+MODULE_DESCRIPTION("RZ/V2H VBENCTL VBUS_SEL mux driver");
+MODULE_AUTHOR("Tommaso Merciai <tommaso.merciai.xr@bp.renesas.com>");
+MODULE_LICENSE("GPL");
--
2.54.0
^ permalink raw reply related [flat|nested] 4+ messages in thread
* Re: [PATCH v13 0/1] Add USB2.0 VBUS mux driver for RZ/G3E
2026-08-10 7:51 [PATCH v13 0/1] Add USB2.0 VBUS mux driver for RZ/G3E Tommaso Merciai
2026-08-10 7:51 ` [PATCH v13 1/1] mux: Add driver for Renesas RZ/V2H VBENCTL VBUS_SEL mux Tommaso Merciai
@ 2026-08-13 10:38 ` Peter Rosin
2026-08-14 9:00 ` Tommaso Merciai
1 sibling, 1 reply; 4+ messages in thread
From: Peter Rosin @ 2026-08-13 10:38 UTC (permalink / raw)
To: Tommaso Merciai, tomm.merciai, prabhakar.mahadev-lad.rj, p.zabel,
ulf.hansson
Cc: linux-renesas-soc, biju.das.jz, Ulf Hansson, Alvin Šipraga,
Josua Mayer, linux-kernel
On 2026-08-10 09:51, Tommaso Merciai wrote:
> Dear All,
>
> This patch adds a new mux driver for RZ/V2H USB VBENCTL VBUS_SEL.
>
> All patches in the original series ([0]) have been merged except this one,
> so this is just a follow-up patch to add the mux driver.
>
> [0] https://patchwork.kernel.org/project/linux-renesas-soc/cover/cover.1775047175.git.tommaso.merciai.xr@bp.renesas.com/
>
> Thanks & Regards,
> Tommaso
Thanks for your patience, I have added the patch to the mux for-next
branch [1] and it should show up in linux-next when next is regenerated
(usually within a day or two).
However, it is now too late for the patch to actually hit the 7.3
merge window. I will feed it to Greg in time for the 7.4 merge window
instead.
Cheers,
Peter
[1] https://gitlab.com/peda-linux/mux
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH v13 0/1] Add USB2.0 VBUS mux driver for RZ/G3E
2026-08-13 10:38 ` [PATCH v13 0/1] Add USB2.0 VBUS mux driver for RZ/G3E Peter Rosin
@ 2026-08-14 9:00 ` Tommaso Merciai
0 siblings, 0 replies; 4+ messages in thread
From: Tommaso Merciai @ 2026-08-14 9:00 UTC (permalink / raw)
To: Peter Rosin
Cc: tomm.merciai, prabhakar.mahadev-lad.rj, p.zabel, ulf.hansson,
linux-renesas-soc, biju.das.jz, Ulf Hansson, Alvin Šipraga,
Josua Mayer, linux-kernel
Hi Peter,
On Thu, Aug 13, 2026 at 12:38:06PM +0200, Peter Rosin wrote:
> On 2026-08-10 09:51, Tommaso Merciai wrote:
> > Dear All,
> >
> > This patch adds a new mux driver for RZ/V2H USB VBENCTL VBUS_SEL.
> >
> > All patches in the original series ([0]) have been merged except this one,
> > so this is just a follow-up patch to add the mux driver.
> >
> > [0] https://patchwork.kernel.org/project/linux-renesas-soc/cover/cover.1775047175.git.tommaso.merciai.xr@bp.renesas.com/
> >
> > Thanks & Regards,
> > Tommaso
> Thanks for your patience, I have added the patch to the mux for-next
> branch [1] and it should show up in linux-next when next is regenerated
> (usually within a day or two).
>
> However, it is now too late for the patch to actually hit the 7.3
> merge window. I will feed it to Greg in time for the 7.4 merge window
> instead.
Thanks for sharing.
Kind regards,
Tommaso
>
> Cheers,
> Peter
>
> [1] https://gitlab.com/peda-linux/mux
>
^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2026-08-14 9:00 UTC | newest]
Thread overview: 4+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-08-10 7:51 [PATCH v13 0/1] Add USB2.0 VBUS mux driver for RZ/G3E Tommaso Merciai
2026-08-10 7:51 ` [PATCH v13 1/1] mux: Add driver for Renesas RZ/V2H VBENCTL VBUS_SEL mux Tommaso Merciai
2026-08-13 10:38 ` [PATCH v13 0/1] Add USB2.0 VBUS mux driver for RZ/G3E Peter Rosin
2026-08-14 9:00 ` Tommaso Merciai
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.