From: Corey Minyard <corey@minyard.net>
To: pzalewski@thegoodpenguin.co.uk
Cc: Clemens Ladisch <clemens@ladisch.de>,
Arnd Bergmann <arnd@arndb.de>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Mattia Dongili <malattia@linux.it>,
Weili Qian <qianweili@huawei.com>,
Olivia Mackall <olivia@selenic.com>,
Herbert Xu <herbert@gondor.apana.org.au>,
Peter Huewe <peterhuewe@gmx.de>,
Jarkko Sakkinen <jarkko@kernel.org>,
Jason Gunthorpe <jgg@ziepe.ca>,
linux-kernel@vger.kernel.org,
platform-driver-x86@vger.kernel.org,
linux-crypto@vger.kernel.org,
openipmi-developer@lists.sourceforge.net,
linux-integrity@vger.kernel.org
Subject: Re: [PATCH 3/4] char: ipmi: use named initializers for acpi_device_id
Date: Fri, 7 Aug 2026 06:40:20 -0500 [thread overview]
Message-ID: <anXEJOF27FiNOqWx@mail.minyard.net> (raw)
In-Reply-To: <20260807-acpi-char-v1-3-742c450254dd@thegoodpenguin.co.uk>
On Fri, Aug 07, 2026 at 12:26:10PM +0100, Pawel Zalewski via B4 Relay wrote:
> From: "Pawel Zalewski (The Capable Hub)" <pzalewski@thegoodpenguin.co.uk>
>
> Use a named initializer for the acpi_device_id fields which
> makes the code more readable and consistent with how lists
> are initialized in the rest of the kernel code base. Also
> drop explicitly setting fields to 0 where it is redundant.
>
> While we are at it - unify the list terminator to have
> a single space between the brackets and no trailing
> comma.
This is fine, it's in my next tree for next release.
Thank you,
-corey
>
> Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>
> ---
> drivers/char/ipmi/ipmb_dev_int.c | 4 ++--
> drivers/char/ipmi/ipmi_si_platform.c | 4 ++--
> drivers/char/ipmi/ipmi_ssif.c | 4 ++--
> 3 files changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/char/ipmi/ipmb_dev_int.c b/drivers/char/ipmi/ipmb_dev_int.c
> index 680ff15c30ab..d576a77df927 100644
> --- a/drivers/char/ipmi/ipmb_dev_int.c
> +++ b/drivers/char/ipmi/ipmb_dev_int.c
> @@ -360,8 +360,8 @@ MODULE_DEVICE_TABLE(i2c, ipmb_id);
>
> #ifdef CONFIG_ACPI
> static const struct acpi_device_id acpi_ipmb_id[] = {
> - { "IPMB0001", 0 },
> - {},
> + { .id = "IPMB0001" },
> + { }
> };
> MODULE_DEVICE_TABLE(acpi, acpi_ipmb_id);
> #endif
> diff --git a/drivers/char/ipmi/ipmi_si_platform.c b/drivers/char/ipmi/ipmi_si_platform.c
> index bdc481ce1302..fa221cbb4b3b 100644
> --- a/drivers/char/ipmi/ipmi_si_platform.c
> +++ b/drivers/char/ipmi/ipmi_si_platform.c
> @@ -387,8 +387,8 @@ static int acpi_ipmi_probe(struct platform_device *pdev)
> }
>
> static const struct acpi_device_id acpi_ipmi_match[] = {
> - { "IPI0001", 0 },
> - { },
> + { .id = "IPI0001" },
> + { }
> };
> MODULE_DEVICE_TABLE(acpi, acpi_ipmi_match);
> #else
> diff --git a/drivers/char/ipmi/ipmi_ssif.c b/drivers/char/ipmi/ipmi_ssif.c
> index 07f1d2327bb7..2361103c5edc 100644
> --- a/drivers/char/ipmi/ipmi_ssif.c
> +++ b/drivers/char/ipmi/ipmi_ssif.c
> @@ -2057,8 +2057,8 @@ static unsigned short *ssif_address_list(void)
>
> #ifdef CONFIG_ACPI
> static const struct acpi_device_id ssif_acpi_match[] = {
> - { "IPI0001", 0 },
> - { },
> + { .id = "IPI0001" },
> + { }
> };
> MODULE_DEVICE_TABLE(acpi, ssif_acpi_match);
> #endif
>
> --
> 2.55.0
>
>
next prev parent reply other threads:[~2026-08-07 11:40 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-07 11:26 [PATCH 0/4] char: use named initializers for acpi_device_id Pawel Zalewski via B4 Relay
2026-08-07 11:26 ` Pawel Zalewski (The Capable Hub)
2026-08-07 11:26 ` [PATCH 1/4] " Pawel Zalewski via B4 Relay
2026-08-07 11:26 ` Pawel Zalewski (The Capable Hub)
2026-08-07 12:26 ` Arnd Bergmann
2026-08-07 11:26 ` [PATCH 2/4] char: hw_random: " Pawel Zalewski via B4 Relay
2026-08-07 11:26 ` Pawel Zalewski (The Capable Hub)
2026-08-07 11:26 ` [PATCH 3/4] char: ipmi: " Pawel Zalewski via B4 Relay
2026-08-07 11:26 ` Pawel Zalewski (The Capable Hub)
2026-08-07 11:40 ` Corey Minyard [this message]
2026-08-07 11:26 ` [PATCH 4/4] char: tpm: " Pawel Zalewski via B4 Relay
2026-08-07 11:26 ` Pawel Zalewski (The Capable Hub)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=anXEJOF27FiNOqWx@mail.minyard.net \
--to=corey@minyard.net \
--cc=arnd@arndb.de \
--cc=clemens@ladisch.de \
--cc=gregkh@linuxfoundation.org \
--cc=herbert@gondor.apana.org.au \
--cc=jarkko@kernel.org \
--cc=jgg@ziepe.ca \
--cc=linux-crypto@vger.kernel.org \
--cc=linux-integrity@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=malattia@linux.it \
--cc=olivia@selenic.com \
--cc=openipmi-developer@lists.sourceforge.net \
--cc=peterhuewe@gmx.de \
--cc=platform-driver-x86@vger.kernel.org \
--cc=pzalewski@thegoodpenguin.co.uk \
--cc=qianweili@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.