All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/4] char: use named initializers for acpi_device_id
@ 2026-08-07 11:26 ` Pawel Zalewski (The Capable Hub)
  0 siblings, 0 replies; 12+ messages in thread
From: Pawel Zalewski via B4 Relay @ 2026-08-07 11:26 UTC (permalink / raw)
  To: Clemens Ladisch, Arnd Bergmann, Greg Kroah-Hartman,
	Mattia Dongili, Weili Qian, Olivia Mackall, Herbert Xu,
	Corey Minyard, Peter Huewe, Jarkko Sakkinen, Jason Gunthorpe
  Cc: linux-kernel, platform-driver-x86, linux-crypto,
	openipmi-developer, linux-integrity,
	Pawel Zalewski (The Capable Hub)

This series is converting lists that contain the acpi_device_id
struct, which is defined in the include/linux/device-id/acpi.h
to makes use of named initializers (which they do not use currently).
This work is part of the on going effort in the kernel associated
with device-ids [1]

The plan is to convert acpi_device_id::driver_data to have an anonymous
union, similarly to what was introduced for PCI and I2C device ID tables.
The goal is to increase type-safety (as most of the existing casts are gone),
to improve readability and to make use intent a bit more clear:

```
union {
	kernel_ulong_t driver_data;
	const void *driver_data_ptr;
}
```

But for that to work all lists containing the structs need to use named
initializers first. I already have patches that implement this and touching
a lot of kernel subsystmes that use the acpi_device_id struct and that list
keeps on growing. Therefore, I have decided to split the series per every
subsystem into:
- pre-clean-ups that convert the lists to use named initializers (this series)
- actual implementations that make some of the modules use the new driver_data_ptr

That way the task can be fragmented into manageable and independent
chunks of work and makes this effort easier to review.

Tested builds on a64 in Yocto using 7.2-rc6

Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>
---
Pawel Zalewski (The Capable Hub) (4):
      char: use named initializers for acpi_device_id
      char: hw_random: use named initializers for acpi_device_id
      char: ipmi: use named initializers for acpi_device_id
      char: tpm: use named initializers for acpi_device_id

 drivers/char/hpet.c                   | 4 ++--
 drivers/char/hw_random/hisi-trng-v2.c | 2 +-
 drivers/char/hw_random/xgene-rng.c    | 2 +-
 drivers/char/ipmi/ipmb_dev_int.c      | 4 ++--
 drivers/char/ipmi/ipmi_si_platform.c  | 4 ++--
 drivers/char/ipmi/ipmi_ssif.c         | 4 ++--
 drivers/char/sonypi.c                 | 4 ++--
 drivers/char/tpm/st33zp24/i2c.c       | 4 ++--
 drivers/char/tpm/st33zp24/spi.c       | 4 ++--
 drivers/char/tpm/tpm_crb.c            | 4 ++--
 drivers/char/tpm/tpm_tis.c            | 4 ++--
 drivers/char/tpm/tpm_tis_i2c_cr50.c   | 4 ++--
 drivers/char/tpm/tpm_tis_spi_main.c   | 4 ++--
 drivers/char/tpm/tpm_tis_synquacer.c  | 4 ++--
 14 files changed, 26 insertions(+), 26 deletions(-)
---
base-commit: 848acc8ffe1b7cd5f1bf427b93069becfebc2c9d
change-id: 20260804-acpi-char-56316ab2bd03

Best regards,
--  
Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>



^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2026-08-07 12:27 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-08-07 11:26 [PATCH 0/4] char: use named initializers for acpi_device_id Pawel Zalewski via B4 Relay
2026-08-07 11:26 ` Pawel Zalewski (The Capable Hub)
2026-08-07 11:26 ` [PATCH 1/4] " Pawel Zalewski via B4 Relay
2026-08-07 11:26   ` Pawel Zalewski (The Capable Hub)
2026-08-07 12:26   ` Arnd Bergmann
2026-08-07 11:26 ` [PATCH 2/4] char: hw_random: " Pawel Zalewski via B4 Relay
2026-08-07 11:26   ` Pawel Zalewski (The Capable Hub)
2026-08-07 11:26 ` [PATCH 3/4] char: ipmi: " Pawel Zalewski via B4 Relay
2026-08-07 11:26   ` Pawel Zalewski (The Capable Hub)
2026-08-07 11:40   ` Corey Minyard
2026-08-07 11:26 ` [PATCH 4/4] char: tpm: " Pawel Zalewski via B4 Relay
2026-08-07 11:26   ` Pawel Zalewski (The Capable Hub)

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.