From: Muhammad Usama Anjum <usama.anjum@collabora.com>
To: John Hubbard <jhubbard@nvidia.com>,
Andrew Morton <akpm@linux-foundation.org>,
Yury Norov <yury.norov@gmail.com>,
Rasmus Villemoes <linux@rasmusvillemoes.dk>,
Shuah Khan <shuah@kernel.org>,
linux-kernel@vger.kernel.org, linux-kselftest@vger.kernel.org,
kees@kernel.org, David Gow <davidgow@google.com>
Cc: Muhammad Usama Anjum <usama.anjum@collabora.com>, kernel@collabora.com
Subject: Re: [PATCH 2/3] bitmap: Rename module
Date: Mon, 29 Jul 2024 12:57:41 +0500 [thread overview]
Message-ID: <ba6cac02-615b-4db3-a591-fb1cb4e52823@collabora.com> (raw)
In-Reply-To: <f5aeeea3-1b6f-4ace-b346-b6650d6937a4@nvidia.com>
On 7/26/24 11:45 PM, John Hubbard wrote:
> On 7/26/24 4:06 AM, Muhammad Usama Anjum wrote:
>> Rename module to bitmap_kunit and rename the configuration option
>> compliant with kunit framework.
>>
>> Cc: kees@kernel.org
>> Signed-off-by: Muhammad Usama Anjum <usama.anjum@collabora.com>
>> ---
>> MAINTAINERS | 2 +-
>> lib/Kconfig.debug | 15 ++++++++-------
>> lib/Makefile | 2 +-
>> lib/{test_bitmap.c => bitmap_kunit.c} | 0
>> 4 files changed, 10 insertions(+), 9 deletions(-)
>> rename lib/{test_bitmap.c => bitmap_kunit.c} (100%)
>>
>> diff --git a/MAINTAINERS b/MAINTAINERS
>> index 12b870712da4a..289b727344d64 100644
>> --- a/MAINTAINERS
>> +++ b/MAINTAINERS
>> @@ -3814,13 +3814,13 @@ F: include/linux/find.h
>> F: include/linux/nodemask.h
>> F: include/linux/nodemask_types.h
>> F: include/vdso/bits.h
>> +F: lib/bitmap_kunit.c
>> F: lib/bitmap-str.c
>> F: lib/bitmap.c
>> F: lib/cpumask.c
>> F: lib/cpumask_kunit.c
>> F: lib/find_bit.c
>> F: lib/find_bit_benchmark.c
>> -F: lib/test_bitmap.c
>
> This changes the situation from "works for Linus' tab completion
> case", to "causes a tab completion problem"! :)
>
> I think a tests/ subdir is how we eventually decided to do this [1],
> right?
Yes, Thank you for mentioning it. I'd missed the naming scheme. I'll fix it.
>
> So:
>
> lib/tests/bitmap_kunit.c
>
>
> [1] https://lore.kernel.org/20240724201354.make.730-kees@kernel.org
>
> thanks,
--
BR,
Muhammad Usama Anjum
next prev parent reply other threads:[~2024-07-29 7:57 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-07-26 11:06 [PATCH 0/3] bitmap: Convert test_bitmap to kunit test Muhammad Usama Anjum
2024-07-26 11:06 ` [PATCH 1/3] bitmap: convert test_bitmap to KUnit test Muhammad Usama Anjum
2024-07-26 11:06 ` [PATCH 2/3] bitmap: Rename module Muhammad Usama Anjum
2024-07-26 18:45 ` John Hubbard
2024-07-29 7:57 ` Muhammad Usama Anjum [this message]
2024-07-26 19:24 ` Shuah Khan
2024-07-29 8:02 ` Muhammad Usama Anjum
2024-07-27 17:35 ` Yury Norov
2024-07-29 8:07 ` Muhammad Usama Anjum
2024-07-29 14:09 ` Randy Dunlap
2024-07-30 7:51 ` Muhammad Usama Anjum
2024-07-30 13:53 ` Randy Dunlap
2024-07-30 10:10 ` David Gow
2024-07-30 15:55 ` Shuah Khan
2024-07-30 18:17 ` Shuah Khan
2024-07-30 18:44 ` John Hubbard
2024-07-30 17:49 ` Yury Norov
2024-07-26 11:06 ` [PATCH 3/3] selftests: lib: remove test_bitmap Muhammad Usama Anjum
2024-07-26 19:22 ` Shuah Khan
2024-07-26 19:26 ` [PATCH 0/3] bitmap: Convert test_bitmap to kunit test Shuah Khan
2024-07-27 18:10 ` Yury Norov
2024-07-29 8:15 ` Muhammad Usama Anjum
2024-07-30 15:39 ` Shuah Khan
2024-07-31 3:05 ` David Gow
2024-07-29 8:29 ` Muhammad Usama Anjum
2024-07-30 15:49 ` Shuah Khan
2024-07-31 3:06 ` David Gow
2024-07-31 16:26 ` Shuah Khan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ba6cac02-615b-4db3-a591-fb1cb4e52823@collabora.com \
--to=usama.anjum@collabora.com \
--cc=akpm@linux-foundation.org \
--cc=davidgow@google.com \
--cc=jhubbard@nvidia.com \
--cc=kees@kernel.org \
--cc=kernel@collabora.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=linux@rasmusvillemoes.dk \
--cc=shuah@kernel.org \
--cc=yury.norov@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.