From: "Souza, Jose" <jose.souza@intel.com>
To: "intel-xe@lists.freedesktop.org" <intel-xe@lists.freedesktop.org>,
"Harrison, John C" <john.c.harrison@intel.com>
Cc: "De Marchi, Lucas" <lucas.demarchi@intel.com>
Subject: Re: [PATCH 2/3] drm/xe: Make GUC binaries dump consistent with other binaries in devcoredump
Date: Thu, 23 Jan 2025 18:45:04 +0000 [thread overview]
Message-ID: <c9c4edd6ff425db18c189e09d12365f27aefbdc7.camel@intel.com> (raw)
In-Reply-To: <9c1e56c4-4809-4f11-a41d-ecf6754de6ca@intel.com>
On Thu, 2025-01-23 at 10:17 -0800, John Harrison wrote:
> On 1/23/2025 09:59, José Roberto de Souza wrote:
> > All other binaries follow this format:
> > [name].length: 0x1000
> > [name].data: xxxxxxx
> > [name].error: errno
> What is the purpose of including the name in []?
Make easy to identify if the line is a binary dump line or not.
We have that pattern and should follow now.
>
> >
> > The error ones is just in case by some reason was not able to capture
> > binary.
> >
> > So this GuC binaries should follow the same patern.
> >
> > Cc: John Harrison <John.C.Harrison@Intel.com>
> > Cc: Lucas De Marchi <lucas.demarchi@intel.com>
> > Signed-off-by: José Roberto de Souza <jose.souza@intel.com>
> > ---
> > drivers/gpu/drm/xe/xe_guc_ct.c | 6 ++++--
> > drivers/gpu/drm/xe/xe_guc_log.c | 3 ++-
> > 2 files changed, 6 insertions(+), 3 deletions(-)
> >
> > diff --git a/drivers/gpu/drm/xe/xe_guc_ct.c b/drivers/gpu/drm/xe/xe_guc_ct.c
> > index 50c8076b51585..497036675a38c 100644
> > --- a/drivers/gpu/drm/xe/xe_guc_ct.c
> > +++ b/drivers/gpu/drm/xe/xe_guc_ct.c
> > @@ -1723,9 +1723,11 @@ void xe_guc_ct_snapshot_print(struct xe_guc_ct_snapshot *snapshot,
> > drm_printf(p, "\tg2h outstanding: %d\n",
> > snapshot->g2h_outstanding);
> >
> > - if (snapshot->ctb)
> > - xe_print_blob_ascii85(p, "CTB data", '\n',
> > + if (snapshot->ctb) {
> > + drm_printf(p, "[CTB].length: 0x%lx\n", snapshot->ctb_size);
> > + xe_print_blob_ascii85(p, "[CTB].data", '\n',
> > snapshot->ctb, 0, snapshot->ctb_size);
> > + }
> > } else {
> > drm_puts(p, "CT disabled\n");
> > }
> > diff --git a/drivers/gpu/drm/xe/xe_guc_log.c b/drivers/gpu/drm/xe/xe_guc_log.c
> > index 44482ea919924..462ec4bb98bb9 100644
> > --- a/drivers/gpu/drm/xe/xe_guc_log.c
> > +++ b/drivers/gpu/drm/xe/xe_guc_log.c
> > @@ -204,10 +204,11 @@ void xe_guc_log_snapshot_print(struct xe_guc_log_snapshot *snapshot, struct drm_
> > drm_printf(p, "GuC timestamp: 0x%08llX [%llu]\n", snapshot->stamp, snapshot->stamp);
> > drm_printf(p, "Log level: %u\n", snapshot->level);
> >
> > + drm_printf(p, "[GUC].length: 0x%lx\n", snapshot->size);
> > remain = snapshot->size;
> > for (i = 0; i < snapshot->num_chunks; i++) {
> > size_t size = min(GUC_LOG_CHUNK_SIZE, remain);
> > - const char *prefix = i ? NULL : "Log data";
> > + const char *prefix = i ? NULL : "[GUC].data";
> This is not printing the GuC firmware image, it is the GuC log buffer.
> It should be called 'Log' not 'GUC'.
okay, GUC_LOG would be better or just LOG? will change that.
>
> John.
>
> > char suffix = i == snapshot->num_chunks - 1 ? '\n' : 0;
> >
> > xe_print_blob_ascii85(p, prefix, suffix, snapshot->copy[i], 0, size);
>
next prev parent reply other threads:[~2025-01-23 18:45 UTC|newest]
Thread overview: 25+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-01-23 17:59 [PATCH 0/3] Enable GuC log dump and minor fixes in devcoredump José Roberto de Souza
2025-01-23 17:59 ` [PATCH 1/3] drm/xe: Fix and re-enable xe_print_blob_ascii85() José Roberto de Souza
2025-01-23 18:20 ` John Harrison
2025-01-23 19:37 ` Lucas De Marchi
2025-01-23 17:59 ` [PATCH 2/3] drm/xe: Make GUC binaries dump consistent with other binaries in devcoredump José Roberto de Souza
2025-01-23 18:17 ` John Harrison
2025-01-23 18:45 ` Souza, Jose [this message]
2025-01-23 19:26 ` John Harrison
2025-01-23 19:12 ` Lucas De Marchi
2025-01-23 17:59 ` [PATCH 3/3] drm/xe: Drop duplicated information about GT tile " José Roberto de Souza
2025-01-23 18:18 ` John Harrison
2025-01-23 18:24 ` Souza, Jose
2025-01-23 18:30 ` John Harrison
2025-01-23 18:56 ` Souza, Jose
2025-01-23 19:27 ` John Harrison
2025-01-23 19:35 ` Souza, Jose
2025-01-23 20:59 ` John Harrison
2025-01-23 18:08 ` ✓ CI.Patch_applied: success for Enable GuC log dump and minor fixes " Patchwork
2025-01-23 18:08 ` ✗ CI.checkpatch: warning " Patchwork
2025-01-23 18:09 ` ✓ CI.KUnit: success " Patchwork
2025-01-23 18:26 ` ✓ CI.Build: " Patchwork
2025-01-23 18:28 ` ✗ CI.Hooks: failure " Patchwork
2025-01-23 18:29 ` ✓ CI.checksparse: success " Patchwork
2025-01-23 18:55 ` ✓ Xe.CI.BAT: " Patchwork
2025-01-24 5:25 ` ✗ Xe.CI.Full: failure " Patchwork
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=c9c4edd6ff425db18c189e09d12365f27aefbdc7.camel@intel.com \
--to=jose.souza@intel.com \
--cc=intel-xe@lists.freedesktop.org \
--cc=john.c.harrison@intel.com \
--cc=lucas.demarchi@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.