All of lore.kernel.org
 help / color / mirror / Atom feed
From: Kuldeep Singh via OP-TEE <op-tee@lists.trustedfirmware.org>
To: Jarkko Sakkinen <jarkko@kernel.org>
Cc: Amirreza Zarrabi <amirreza.zarrabi@oss.qualcomm.com>,
	Jens Wiklander <jenswi@kernel.org>,
	Sumit Garg <sumit.garg@kernel.org>,
	Peter Huewe <peterhuewe@gmx.de>, Jason Gunthorpe <jgg@ziepe.ca>,
	linux-arm-msm@vger.kernel.org, op-tee@lists.trustedfirmware.org,
	linux-kernel@vger.kernel.org, linux-integrity@vger.kernel.org
Subject: Re: [PATCH 2/2] firmware: tpm: Introduce tpm-qcom driver
Date: Thu, 10 Sep 2026 14:04:48 +0530	[thread overview]
Message-ID: <f39b118b-b100-4063-bc4c-ded1f9ce0233@oss.qualcomm.com> (raw)
In-Reply-To: <aqGDL2qZ0sZNMG0f@kernel.org>

On 09-09-2026 21:32, Jarkko Sakkinen wrote:
> On Wed, Sep 02, 2026 at 02:52:17PM +0530, Kuldeep Singh wrote:
>> On 01-09-2026 19:16, Jarkko Sakkinen wrote:
>>> Short summary has a different driver name that is implemented i.e.,
>>> it should has "tpm_qcom", not "tpm-qcom".
>>
>> True, let me make more generic like "Introduce Qualcomm TPM driver"
>> instead of having driver filename in commit title for any confusion.
>>
>>>>  MAINTAINERS                 |   7 +
>>>>  drivers/char/tpm/Kconfig    |   9 ++
>>>>  drivers/char/tpm/Makefile   |   1 +
>>>>  drivers/char/tpm/tpm_qcom.c | 371 ++++++++++++++++++++++++++++++++++++++++++++
>>>>  drivers/char/tpm/tpm_qcom.h |  82 ++++++++++
>>>
>>> Rename it as tpm_qcom_tee just to be aligned on how Microsoft's fTPM
>>> driver is named.
>>
>> I'd say firstly microsoft ftpm driver should be renamed.
>> For example, MS ftpm is based on optee(session based context) whereas
>> Qcom tpm driver is based on qcomtee(part of same TEE subsystem but uses
>> completely different mink-ipc based sharing mechanism).
>> So, it's completely different driver compared to MS.
>>
>> My suggestions:
>>  - Rename MS driver i.e tpm_ftpm_tee.c -> tpm_microsoft.c
>>  - Rename Qcom driver i.e tpm_qcom.c -> tpm_qcom.c
> 
> This goes for argument using tpm_qcom.c but we don't rename ko's in
> normal circumstances (unfortunately so).

Sure, we can keep tpm_qcom.c then and don't update tpm_ftpm_tee.c
I hope I understand you correctly.

Kindly check v2 posted after addressing comments for latest.
https://lore.kernel.org/lkml/20260907-tpm_qcom_driver-v2-0-71a6b1752da8@oss.qualcomm.com/

-- 
Regards
Kuldeep


WARNING: multiple messages have this Message-ID (diff)
From: Kuldeep Singh <kuldeep.singh@oss.qualcomm.com>
To: Jarkko Sakkinen <jarkko@kernel.org>
Cc: Amirreza Zarrabi <amirreza.zarrabi@oss.qualcomm.com>,
	Jens Wiklander <jenswi@kernel.org>,
	Sumit Garg <sumit.garg@kernel.org>,
	Peter Huewe <peterhuewe@gmx.de>, Jason Gunthorpe <jgg@ziepe.ca>,
	linux-arm-msm@vger.kernel.org, op-tee@lists.trustedfirmware.org,
	linux-kernel@vger.kernel.org, linux-integrity@vger.kernel.org
Subject: Re: [PATCH 2/2] firmware: tpm: Introduce tpm-qcom driver
Date: Thu, 10 Sep 2026 14:04:48 +0530	[thread overview]
Message-ID: <f39b118b-b100-4063-bc4c-ded1f9ce0233@oss.qualcomm.com> (raw)
In-Reply-To: <aqGDL2qZ0sZNMG0f@kernel.org>

On 09-09-2026 21:32, Jarkko Sakkinen wrote:
> On Wed, Sep 02, 2026 at 02:52:17PM +0530, Kuldeep Singh wrote:
>> On 01-09-2026 19:16, Jarkko Sakkinen wrote:
>>> Short summary has a different driver name that is implemented i.e.,
>>> it should has "tpm_qcom", not "tpm-qcom".
>>
>> True, let me make more generic like "Introduce Qualcomm TPM driver"
>> instead of having driver filename in commit title for any confusion.
>>
>>>>  MAINTAINERS                 |   7 +
>>>>  drivers/char/tpm/Kconfig    |   9 ++
>>>>  drivers/char/tpm/Makefile   |   1 +
>>>>  drivers/char/tpm/tpm_qcom.c | 371 ++++++++++++++++++++++++++++++++++++++++++++
>>>>  drivers/char/tpm/tpm_qcom.h |  82 ++++++++++
>>>
>>> Rename it as tpm_qcom_tee just to be aligned on how Microsoft's fTPM
>>> driver is named.
>>
>> I'd say firstly microsoft ftpm driver should be renamed.
>> For example, MS ftpm is based on optee(session based context) whereas
>> Qcom tpm driver is based on qcomtee(part of same TEE subsystem but uses
>> completely different mink-ipc based sharing mechanism).
>> So, it's completely different driver compared to MS.
>>
>> My suggestions:
>>  - Rename MS driver i.e tpm_ftpm_tee.c -> tpm_microsoft.c
>>  - Rename Qcom driver i.e tpm_qcom.c -> tpm_qcom.c
> 
> This goes for argument using tpm_qcom.c but we don't rename ko's in
> normal circumstances (unfortunately so).

Sure, we can keep tpm_qcom.c then and don't update tpm_ftpm_tee.c
I hope I understand you correctly.

Kindly check v2 posted after addressing comments for latest.
https://lore.kernel.org/lkml/20260907-tpm_qcom_driver-v2-0-71a6b1752da8@oss.qualcomm.com/

-- 
Regards
Kuldeep


  reply	other threads:[~2026-09-10  8:35 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-31  9:42 [PATCH 0/2] Add TPM support via Qualcomm TEE TPM TA Kuldeep Singh via OP-TEE
2026-08-31  9:42 ` Kuldeep Singh
2026-08-31  9:43 ` [PATCH 1/2] tee: qcomtee: Register qcom.tz.tpm service for discovery Kuldeep Singh
2026-08-31  9:43   ` Kuldeep Singh via OP-TEE
2026-09-02  9:27   ` Kuldeep Singh
2026-09-02  9:27     ` Kuldeep Singh via OP-TEE
2026-08-31  9:43 ` [PATCH 2/2] firmware: tpm: Introduce tpm-qcom driver Kuldeep Singh
2026-08-31  9:43   ` Kuldeep Singh via OP-TEE
2026-08-31 11:15   ` Konrad Dybcio via OP-TEE
2026-08-31 11:15     ` Konrad Dybcio
2026-08-31 11:26     ` Kuldeep Singh via OP-TEE
2026-08-31 11:26       ` Kuldeep Singh
2026-09-01 13:46   ` Jarkko Sakkinen via OP-TEE
2026-09-01 13:46     ` Jarkko Sakkinen
2026-09-02  9:22     ` Kuldeep Singh via OP-TEE
2026-09-02  9:22       ` Kuldeep Singh
2026-09-09 16:02       ` Jarkko Sakkinen
2026-09-09 16:02         ` Jarkko Sakkinen via OP-TEE
2026-09-10  8:34         ` Kuldeep Singh via OP-TEE [this message]
2026-09-10  8:34           ` Kuldeep Singh
2026-09-07  9:47 ` [PATCH 0/2] Add TPM support via Qualcomm TEE TPM TA Kuldeep Singh
2026-09-07  9:47   ` Kuldeep Singh via OP-TEE

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f39b118b-b100-4063-bc4c-ded1f9ce0233@oss.qualcomm.com \
    --to=op-tee@lists.trustedfirmware.org \
    --cc=amirreza.zarrabi@oss.qualcomm.com \
    --cc=jarkko@kernel.org \
    --cc=jenswi@kernel.org \
    --cc=jgg@ziepe.ca \
    --cc=kuldeep.singh@oss.qualcomm.com \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-integrity@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=peterhuewe@gmx.de \
    --cc=sumit.garg@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.