All of lore.kernel.org
 help / color / mirror / Atom feed
From: Sui Jingfeng <sui.jingfeng@linux.dev>
To: Liu Ying <victor.liu@nxp.com>, Shawn Guo <shawnguo@kernel.org>,
	Sascha Hauer <s.hauer@pengutronix.de>,
	Fabio Estevam <festevam@gmail.com>
Cc: Pengutronix Kernel Team <kernel@pengutronix.de>,
	Maxime Ripard <mripard@kernel.org>,
	Andrzej Hajda <andrzej.hajda@intel.com>,
	Neil Armstrong <neil.armstrong@linaro.org>,
	Robert Foss <rfoss@kernel.org>,
	Laurent Pinchart <Laurent.pinchart@ideasonboard.com>,
	Jonas Karlman <jonas@kwiboo.se>,
	Jernej Skrabec <jernej.skrabec@gmail.com>,
	Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
	Thomas Zimmermann <tzimmermann@suse.de>,
	dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] drm/bridge: imx: Remove redundant checks on existence of bridge->encoder
Date: Mon, 13 May 2024 14:43:01 +0800	[thread overview]
Message-ID: <faf43075-a738-41b6-975c-f8c007929050@linux.dev> (raw)
In-Reply-To: <c1a69a18-4db2-4625-80c2-a7536347e15f@nxp.com>

Hi,


On 5/13/24 13:56, Liu Ying wrote:
> On 5/11/24 23:08, Sui Jingfeng wrote:
>> The check on the existence of bridge->encoder on the implementation layer
>> of drm bridge driver is not necessary, as it has already been done in the
>> drm_bridge_attach() function. It is guaranteed that the .encoder member
>> of the drm_bridge instance is not NULL when various imx_xxx_bridge_attach()
>> function gets called.
> 
> Nit:
> ldb_bridge_attach_helper() doesn't follow the fashion of
> imx_xxx_bridge_attach(), not even the other bridge attach
> functions touched by this patch do. 


Right, my bad.

But personally, I think rename it as ldb_bridge_attach() should
enough to express the meaning. :-)


  Maybe, reword as
> "when various i.MX specific bridge attach functions are
> called."
> 

OK, fine.

I will correct the commit message at the next version,
so happy being reviewed. Thanks.


> Regards,
> Liu Ying
>

      reply	other threads:[~2024-05-13  6:43 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-05-11 15:08 [PATCH] drm/bridge: imx: Remove redundant checks on existence of bridge->encoder Sui Jingfeng
2024-05-12 21:17 ` Laurent Pinchart
2024-05-13  5:56 ` Liu Ying
2024-05-13  6:43   ` Sui Jingfeng [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=faf43075-a738-41b6-975c-f8c007929050@linux.dev \
    --to=sui.jingfeng@linux.dev \
    --cc=Laurent.pinchart@ideasonboard.com \
    --cc=andrzej.hajda@intel.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=festevam@gmail.com \
    --cc=jernej.skrabec@gmail.com \
    --cc=jonas@kwiboo.se \
    --cc=kernel@pengutronix.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=maarten.lankhorst@linux.intel.com \
    --cc=mripard@kernel.org \
    --cc=neil.armstrong@linaro.org \
    --cc=rfoss@kernel.org \
    --cc=s.hauer@pengutronix.de \
    --cc=shawnguo@kernel.org \
    --cc=tzimmermann@suse.de \
    --cc=victor.liu@nxp.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.