All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/2] s390/ipl: Improve readability
@ 2026-07-21 18:47 Mete Durlu
  2026-07-21 18:47 ` [PATCH 1/2] s390/ipl: Use ARRAY_SIZE macro Mete Durlu
                   ` (3 more replies)
  0 siblings, 4 replies; 7+ messages in thread
From: Mete Durlu @ 2026-07-21 18:47 UTC (permalink / raw)
  To: Heiko Carstens, Vasily Gorbik, Alexander Gordeev,
	Christian Borntraeger, Sven Schnelle
  Cc: linux-s390, Mete Durlu

Improve readability of s390 ipl code by openly writing static struct
definitions, reformatting list definitions and using ARRAY_SIZE() macro
in suitable places.

No functional changes, only coding style changes.

Signed-off-by: Mete Durlu <meted@linux.ibm.com>
---
Mete Durlu (2):
      s390/ipl: Use ARRAY_SIZE macro
      s390/ipl: Improve readability

 arch/s390/kernel/ipl.c | 58 +++++++++++++++++++++++++++++++++-----------------
 1 file changed, 38 insertions(+), 20 deletions(-)
---
base-commit: 248951ddc14de84de3910f9b13f51491a8cd91df
change-id: 20260721-ipl_refactor-ef6aa1bafa8a

Best regards,
-- 
Mete Durlu <meted@linux.ibm.com>


^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2026-07-23 12:53 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-21 18:47 [PATCH 0/2] s390/ipl: Improve readability Mete Durlu
2026-07-21 18:47 ` [PATCH 1/2] s390/ipl: Use ARRAY_SIZE macro Mete Durlu
2026-07-21 19:00   ` sashiko-bot
2026-07-21 18:47 ` [PATCH 2/2] s390/ipl: Improve readability Mete Durlu
2026-07-21 19:04   ` sashiko-bot
2026-07-22  8:28 ` [PATCH 0/2] " Heiko Carstens
2026-07-23 12:53 ` Vasily Gorbik

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.