From: Junio C Hamano <gitster@pobox.com>
To: Patrick Steinhardt <ps@pks.im>
Cc: git@vger.kernel.org, Justin Tobler <jltobler@gmail.com>
Subject: Re: [PATCH v2 0/6] odb: refactor source-specific information in object info
Date: Sat, 04 Jul 2026 18:28:01 -0700 [thread overview]
Message-ID: <xmqqy0fqdy3i.fsf@gitster.g> (raw)
In-Reply-To: <20260702-b4-pks-odb-drop-whence-v2-0-b0af7468ad95@pks.im> (Patrick Steinhardt's message of "Thu, 02 Jul 2026 14:01:58 +0200")
Patrick Steinhardt <ps@pks.im> writes:
> Changes in v2:
> - Rename `struct object_info_source` to `odb_source_info` and the
> `sourcep` pointer to `source_infop`. This follows a suggestion made
> by Justin, as the current naming is too easy to confuse with the
> actual source.
> - Link to v1: https://patch.msgid.link/20260624-b4-pks-odb-drop-whence-v1-0-8d1877b790ac@pks.im
Thanks. Queued.
prev parent reply other threads:[~2026-07-05 1:28 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-24 12:19 [PATCH 0/6] odb: refactor source-specific information in object info Patrick Steinhardt
2026-06-24 12:19 ` [PATCH 1/6] packfile: thread odb_source_packed through packed_object_info() Patrick Steinhardt
2026-06-29 17:01 ` Justin Tobler
2026-06-30 11:28 ` Patrick Steinhardt
2026-06-24 12:19 ` [PATCH 2/6] odb: make backend-specific fields optional Patrick Steinhardt
2026-06-29 17:25 ` Justin Tobler
2026-06-30 11:28 ` Patrick Steinhardt
2026-06-24 12:19 ` [PATCH 3/6] odb: add `source` field to struct object_info_source Patrick Steinhardt
2026-06-29 17:49 ` Justin Tobler
2026-06-29 20:47 ` Junio C Hamano
2026-06-30 11:28 ` Patrick Steinhardt
2026-06-30 16:54 ` Junio C Hamano
2026-06-24 12:19 ` [PATCH 4/6] treewide: convert users of `whence` to the new source field Patrick Steinhardt
2026-06-29 17:55 ` Justin Tobler
2026-06-24 12:19 ` [PATCH 5/6] odb: drop `whence` field from object info Patrick Steinhardt
2026-06-29 17:57 ` Justin Tobler
2026-06-24 12:19 ` [PATCH 6/6] odb: document object info fields Patrick Steinhardt
2026-06-24 17:13 ` [PATCH 0/6] odb: refactor source-specific information in object info Junio C Hamano
2026-07-02 12:01 ` [PATCH v2 " Patrick Steinhardt
2026-07-02 12:01 ` [PATCH v2 1/6] packfile: thread odb_source_packed through packed_object_info() Patrick Steinhardt
2026-07-02 12:02 ` [PATCH v2 2/6] odb: make backend-specific fields optional Patrick Steinhardt
2026-07-02 12:02 ` [PATCH v2 3/6] odb: add `source` field to struct object_info_source Patrick Steinhardt
2026-07-02 12:02 ` [PATCH v2 4/6] treewide: convert users of `whence` to the new source field Patrick Steinhardt
2026-07-02 12:02 ` [PATCH v2 5/6] odb: drop `whence` field from object info Patrick Steinhardt
2026-07-02 12:02 ` [PATCH v2 6/6] odb: document object info fields Patrick Steinhardt
2026-07-05 1:28 ` Junio C Hamano [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=xmqqy0fqdy3i.fsf@gitster.g \
--to=gitster@pobox.com \
--cc=git@vger.kernel.org \
--cc=jltobler@gmail.com \
--cc=ps@pks.im \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.