Alsa-Devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>,
	Vinod Koul <vinod.koul@intel.com>
Cc: jeremy@jcline.org, tiwai@suse.de, alsa-devel@alsa-project.org,
	broonie@kernel.org, liam.r.girdwood@linux.intel.com
Subject: Re: [PATCH v2 4/4] ASoC: acpi: remove hard-coded i2c-device name length
Date: Tue, 09 Jan 2018 12:39:50 +0200	[thread overview]
Message-ID: <1515494390.7000.816.camel@linux.intel.com> (raw)
In-Reply-To: <12631c8f-699c-cb2f-643f-5f4c7ab982c0@linux.intel.com>

On Mon, 2018-01-08 at 14:28 -0600, Pierre-Louis Bossart wrote:
> On 1/7/18 10:41 PM, Vinod Koul wrote:
> > On Fri, Jan 05, 2018 at 02:55:36PM -0600, Pierre-Louis Bossart
> > wrote:
> > > Remove hard-coded [16] array size, replace with clearer
> > > description and
> > > dependency on ACPI_ID_LEN
> > > 


> > >   
> > > +/* codec name is used in DAIs is i2c-<HID>:00 with HID being 8
> > > chars */
> > > +#define SND_SOC_ACPI_I2C_DEVICE_NAME_LEN (4 + ACPI_ID_LEN + 3 +
> > > 1)
> > 
> > nitpicking, thats a very long name :(
> > 
> > how about SND_ACPI_I2C_ID_LEN, we can drop SOC. And replace
> > DEVICE_NAME with ID
> 
> Fine with me. Andy do you concur or have a more precise suggestion?

Looks sane to me.
Thank you, Vinod, for a suggestion.

-- 
Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Intel Finland Oy

      reply	other threads:[~2018-01-09 10:40 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-01-05 20:55 [PATCH v2 0/4] ASoC: Intel: ACPI-related fixes Pierre-Louis Bossart
2018-01-05 20:55 ` [PATCH v2 1/4] ASoC: acpi: fix machine driver selection based on quirk Pierre-Louis Bossart
2018-01-08 12:35   ` Applied "ASoC: acpi: fix machine driver selection based on quirk" to the asoc tree Mark Brown
2018-01-05 20:55 ` [PATCH v2 2/4] ASoC: Replace snd_soc_acpi_check_hid with acpi_dev_present Pierre-Louis Bossart
2018-01-08 16:23   ` Applied "ASoC: Replace snd_soc_acpi_check_hid with acpi_dev_present" to the asoc tree Mark Brown
2018-01-05 20:55 ` [PATCH v2 3/4] ASoC: Intel: bytcht_es8316: fix HID handling Pierre-Louis Bossart
2018-01-08  4:43   ` Vinod Koul
2018-01-08 20:23     ` Pierre-Louis Bossart
2018-01-09  4:48       ` Vinod Koul
2018-01-09 10:40         ` Andy Shevchenko
2018-01-05 20:55 ` [PATCH v2 4/4] ASoC: acpi: remove hard-coded i2c-device name length Pierre-Louis Bossart
2018-01-08  4:41   ` Vinod Koul
2018-01-08 20:28     ` Pierre-Louis Bossart
2018-01-09 10:39       ` Andy Shevchenko [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1515494390.7000.816.camel@linux.intel.com \
    --to=andriy.shevchenko@linux.intel.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=broonie@kernel.org \
    --cc=jeremy@jcline.org \
    --cc=liam.r.girdwood@linux.intel.com \
    --cc=pierre-louis.bossart@linux.intel.com \
    --cc=tiwai@suse.de \
    --cc=vinod.koul@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox