Alsa-Devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Vinod Koul <vinod.koul@intel.com>
To: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>
Cc: jeremy@jcline.org, alsa-devel@alsa-project.org, tiwai@suse.de,
	liam.r.girdwood@linux.intel.com, broonie@kernel.org,
	andriy.shevchenko@linux.intel.com
Subject: Re: [PATCH v2 4/4] ASoC: acpi: remove hard-coded i2c-device name length
Date: Mon, 8 Jan 2018 10:11:33 +0530	[thread overview]
Message-ID: <20180108044133.GW18649@localhost> (raw)
In-Reply-To: <20180105205536.10366-5-pierre-louis.bossart@linux.intel.com>

On Fri, Jan 05, 2018 at 02:55:36PM -0600, Pierre-Louis Bossart wrote:
> Remove hard-coded [16] array size, replace with clearer description and
> dependency on ACPI_ID_LEN
> No functionality change
> 
> Suggested-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> Signed-off-by: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>
> ---
>  include/sound/soc-acpi.h                | 3 +++
>  sound/soc/intel/boards/bytcht_da7213.c  | 2 +-
>  sound/soc/intel/boards/bytcht_es8316.c  | 2 +-
>  sound/soc/intel/boards/bytcr_rt5640.c   | 2 +-
>  sound/soc/intel/boards/bytcr_rt5651.c   | 2 +-
>  sound/soc/intel/boards/cht_bsw_rt5645.c | 4 ++--
>  sound/soc/intel/boards/cht_bsw_rt5672.c | 2 +-
>  7 files changed, 10 insertions(+), 7 deletions(-)
> 
> diff --git a/include/sound/soc-acpi.h b/include/sound/soc-acpi.h
> index d1aaf876cd26..703c78483113 100644
> --- a/include/sound/soc-acpi.h
> +++ b/include/sound/soc-acpi.h
> @@ -27,6 +27,9 @@ struct snd_soc_acpi_package_context {
>  	bool data_valid;
>  };
>  
> +/* codec name is used in DAIs is i2c-<HID>:00 with HID being 8 chars */
> +#define SND_SOC_ACPI_I2C_DEVICE_NAME_LEN (4 + ACPI_ID_LEN + 3 + 1)

nitpicking, thats a very long name :(

how about SND_ACPI_I2C_ID_LEN, we can drop SOC. And replace DEVICE_NAME with ID

-- 
~Vinod

  reply	other threads:[~2018-01-08  4:37 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-01-05 20:55 [PATCH v2 0/4] ASoC: Intel: ACPI-related fixes Pierre-Louis Bossart
2018-01-05 20:55 ` [PATCH v2 1/4] ASoC: acpi: fix machine driver selection based on quirk Pierre-Louis Bossart
2018-01-08 12:35   ` Applied "ASoC: acpi: fix machine driver selection based on quirk" to the asoc tree Mark Brown
2018-01-05 20:55 ` [PATCH v2 2/4] ASoC: Replace snd_soc_acpi_check_hid with acpi_dev_present Pierre-Louis Bossart
2018-01-08 16:23   ` Applied "ASoC: Replace snd_soc_acpi_check_hid with acpi_dev_present" to the asoc tree Mark Brown
2018-01-05 20:55 ` [PATCH v2 3/4] ASoC: Intel: bytcht_es8316: fix HID handling Pierre-Louis Bossart
2018-01-08  4:43   ` Vinod Koul
2018-01-08 20:23     ` Pierre-Louis Bossart
2018-01-09  4:48       ` Vinod Koul
2018-01-09 10:40         ` Andy Shevchenko
2018-01-05 20:55 ` [PATCH v2 4/4] ASoC: acpi: remove hard-coded i2c-device name length Pierre-Louis Bossart
2018-01-08  4:41   ` Vinod Koul [this message]
2018-01-08 20:28     ` Pierre-Louis Bossart
2018-01-09 10:39       ` Andy Shevchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180108044133.GW18649@localhost \
    --to=vinod.koul@intel.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=broonie@kernel.org \
    --cc=jeremy@jcline.org \
    --cc=liam.r.girdwood@linux.intel.com \
    --cc=pierre-louis.bossart@linux.intel.com \
    --cc=tiwai@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox