From: Cezary Rojewski <cezary.rojewski@intel.com>
To: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>
Cc: alsa-devel@alsa-project.org, tiwai@suse.com, hdegoede@redhat.com,
broonie@kernel.org, amadeuszx.slawinski@linux.intel.com
Subject: Re: [PATCH] ALSA: hda: Do not unset preset when cleaning up codec
Date: Wed, 18 Jan 2023 12:47:18 +0100 [thread overview]
Message-ID: <2bf7c18d-7435-5049-620b-2c30065f7fbd@intel.com> (raw)
In-Reply-To: <533b79eb-443b-1181-5ef0-8e1c6bc62e02@intel.com>
On 2023-01-18 12:38 PM, Cezary Rojewski wrote:
> On 2023-01-17 4:48 PM, Pierre-Louis Bossart wrote:
>> On 1/17/23 09:47, Cezary Rojewski wrote:
>>> Several functions that take part in codec's initialization and removal
>>> are re-used by ASoC codec drivers implementations. Drivers mimic the
>>> behavior of hda_codec_driver_probe/remove() found in
>>> sound/pci/hda/hda_bind.c with their component->probe/remove() instead.
>>>
>>> One of the reasons for that is the expectation of
>>> snd_hda_codec_device_new() to receive a valid struct snd_card pointer
>>> what cannot be fulfilled on ASoC side until a card is attempted to be
>>
>> very hard to follow.
>> Is there a spurious 'what' to be removed?
>> Or is there missing text?
>> Please consider rewording with simpler sentences.
>
> Thanks for the comments. 'what' is here on purpose as to my ear this
> sentence sounds reasonable, but I'm not a native English speaker so I
> might be wrong here.
>
> The following is being explained by the commit message:
>
> - functions such as snd_hda_codec_device_new() expect a valid pointer to
> struct snd_card instance
> - for ASoC hda codec drivers, when hdev_attach/detach() are called,
> there is no possibility to provide one to HDAudio API as card components
> are not yet enumerated
> - once component->probe() is invoked and succeeds, component->card will
> point to a valid sound card
> - hda codec driver is now ready to call snd_hda_codec_device_new()
Let me rephrase the last 2 points: hda codec driver is ready to call
functions such as snd_hda_codec_device_new() only when its
component->probe() op gets invoked. Until that happens, field
component->card is invalid.
next prev parent reply other threads:[~2023-01-18 11:48 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-01-17 15:47 [PATCH] ALSA: hda: Do not unset preset when cleaning up codec Cezary Rojewski
2023-01-17 15:48 ` Pierre-Louis Bossart
2023-01-18 11:38 ` Cezary Rojewski
2023-01-18 11:47 ` Cezary Rojewski [this message]
2023-01-17 16:01 ` Takashi Iwai
2023-01-18 12:04 ` Cezary Rojewski
2023-01-18 12:32 ` Takashi Iwai
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2bf7c18d-7435-5049-620b-2c30065f7fbd@intel.com \
--to=cezary.rojewski@intel.com \
--cc=alsa-devel@alsa-project.org \
--cc=amadeuszx.slawinski@linux.intel.com \
--cc=broonie@kernel.org \
--cc=hdegoede@redhat.com \
--cc=pierre-louis.bossart@linux.intel.com \
--cc=tiwai@suse.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox