From: Takashi Sakamoto <o-takashi@sakamocchi.jp>
To: Takashi Iwai <tiwai@suse.de>
Cc: clemens@ladisch.de, alsa-devel@alsa-project.org,
ffado-devel@lists.sourceforge.net
Subject: Re: [PATCH 21/30] ALSA: oxfw: Change the way to name card
Date: Mon, 01 Dec 2014 23:58:43 +0900 [thread overview]
Message-ID: <547C8223.4070402@sakamocchi.jp> (raw)
In-Reply-To: <s5hzjb792z3.wl-tiwai@suse.de>
On Dec 1 2014 17:41, Takashi Iwai wrote:
> At Mon, 01 Dec 2014 08:19:14 +0900,
> Takashi Sakamoto wrote:
>>
>> On Nov 30 2013 17:31, Takashi Iwai wrote:
>>>>> So, this ends up with the identical strings for both driver and
>>>>> shortname? This doesn't sound like an improvement.
>>>>
>>>> Basically, hard-coded strings can be replaced by strings read from
>>>> config-rom on the devices. My original intension of this commit is
>>>> following to this.
>>>>
>>>> But FWSpeakers/FireWave has long strings for vendor/model strings on
>>>> config-rom, therefore his commit can obsolete long name only.
>>>>
>>>> Actually this patch is a help for later patch:
>>>> [PATCH 26/30] ALSA: oxfw: Add support for Behringer/Mackie devices
>>>> http://mailman.alsa-project.org/pipermail/alsa-devel/2014-November/084818.html
>>>
>>> But still it's not applied to LaCie and other that have device_info,
>>> no? So they'll end up with the even shorter names than now.
>>>
>>> I'd be better to create a short_name from "Vendor Model" where
>>> driver_name can be a fallback of model name.
>>
>> Any reasons?
>
> Read again: it'll be "shorter name than now".
I think this is a description, and
> Basically it's strange to have a very same string for both driver and
> shrotname. The shortname is a more detailed description usually
> including both vendor and model names while the driver is the unique
> identifier string.
this is a reason, your intension. This is what I required because I
didn't understand why you insist.
There is just a comment, '/* short name of this soundcard */' in
include/sound/core.h or '/* Short name of soundcard */' in
include/uapi/sound/asound.h. There is no hint for how I should define
the shortname.
Well, I don't mind to use 'Vendor Model' style for shortname. This is
also good for identical names such as 'hw:FireWave' because the last
word of shortname is used for the identical name. Therefore I don't like
to use reverse combination, 'Model Vendor' style, such as 'HDA Intel'.
Regards
Takashi Sakamoto
o-takashi@sakamocchi.jp
next prev parent reply other threads:[~2014-12-01 14:58 UTC|newest]
Thread overview: 48+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-11-28 15:59 [PATCH 00/30 v3] ALSA: Enhancement for existed FireWire drivers Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 01/30] ALSA: dice: suppress checkpatch.pl warnings Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 02/30] ALSA: dice: Rename structure and its members Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 03/30] ALSA: dice: Move file to its own directory Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 04/30] ALSA: dice: Split transaction functionality into a file Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 05/30] ALSA: dice: Split stream " Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 06/30] ALSA: dice: Split PCM " Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 07/30] ALSA: dice: Split hwdep " Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 08/30] ALSA: dice: Split proc interface " Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 09/30] ALSA: dice: Add new functions for constraints of PCM parameters Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 10/30] ALSA: dice: Change the way to start stream Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 11/30] ALSA: dice: Add support for duplex streams with synchronization Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 12/30] ALSA: dice: Support for non SYT-Match sampling clock source mode Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 13/30] ALSA: dice: Add support for capturing PCM samples Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 14/30] ALSA: dice: Add support for MIDI capture/playback Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 15/30] ALSA: dice: remove experimental state Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 16/30] ALSA: speakers: Rename to oxfw and rename some members Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 17/30] ALSA: oxfw: Move to its own directory Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 18/30] ALSA: oxfw: Split stream functionality to a new file and add a header file Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 19/30] ALSA: oxfw: Split PCM functionality to a new file Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 20/30] ALSA: oxfw: Split control " Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 21/30] ALSA: oxfw: Change the way to name card Takashi Sakamoto
2014-11-29 19:37 ` Takashi Iwai
2014-11-30 4:33 ` Takashi Sakamoto
2014-11-30 8:31 ` Takashi Iwai
2014-11-30 23:19 ` Takashi Sakamoto
2014-12-01 8:41 ` Takashi Iwai
2014-12-01 11:21 ` Clemens Ladisch
2014-12-01 15:05 ` Takashi Sakamoto
2014-12-01 15:21 ` Takashi Iwai
2014-12-02 6:17 ` Takashi Sakamoto
2014-12-02 6:41 ` Takashi Iwai
2014-12-03 14:19 ` Takashi Sakamoto
2014-12-01 14:58 ` Takashi Sakamoto [this message]
2014-12-01 15:22 ` Takashi Iwai
2014-11-28 15:59 ` [PATCH 22/30] ALSA: oxfw: Add support for AV/C stream format command to get/set supported stream formation Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 23/30] ALSA: oxfw: Change the way to make PCM rules/constraints Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 24/30] ALSA: oxfw: Add proc interface for debugging purpose Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 25/30] ALSA: oxfw: Change the way to start stream Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 26/30] ALSA: oxfw: Add support for Behringer/Mackie devices Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 27/30] ALSA: oxfw: Add support AMDTP in-stream Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 28/30] ALSA: oxfw: add support for capturing PCM samples Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 29/30] ALSA: oxfw: Add support for capture/playback MIDI messages Takashi Sakamoto
2014-11-28 15:59 ` [PATCH 30/30] ALSA: oxfw: Add hwdep interface Takashi Sakamoto
2014-11-28 16:03 ` [PATCH alsa-lib] hwdep: add OXFW driver support Takashi Sakamoto
2014-11-29 19:35 ` [PATCH 00/30 v3] ALSA: Enhancement for existed FireWire drivers Takashi Iwai
2014-11-30 3:21 ` Takashi Sakamoto
2014-11-30 8:35 ` Takashi Iwai
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=547C8223.4070402@sakamocchi.jp \
--to=o-takashi@sakamocchi.jp \
--cc=alsa-devel@alsa-project.org \
--cc=clemens@ladisch.de \
--cc=ffado-devel@lists.sourceforge.net \
--cc=tiwai@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox