Alsa-Devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
* Re: [PATCH] ASoC: hdmi-codec: Use different name for playback streams
       [not found] <1502440173-23429-1-git-send-email-jeffy.chen@rock-chips.com>
@ 2017-08-11 16:59 ` Brian Norris
  2017-08-12  0:52   ` jeffy
  0 siblings, 1 reply; 2+ messages in thread
From: Brian Norris @ 2017-08-11 16:59 UTC (permalink / raw)
  To: Jeffy Chen; +Cc: alsa-devel, linux-kernel, dianders

Hi Jeffy,

You need to be more careful about the addressee's of your patches. No
one on To/CC is a maintainer or a sufficiently-targeted mailing list. I
doubt any of the maintainers will read your patch. (I've added
alsa-devel for you, but given my understanding of at least Mark's
patchwork workflow -- and of general patch etiquette -- it's important
the patch is actually sent there in the first place.)

Probably worth resending.

Brian

On Fri, Aug 11, 2017 at 04:29:33PM +0800, Jeffy Chen wrote:
> Currently the hdmi i2s playback stream and hdmi spdif playback stream
> are using the same name. So when they are enabled at the same time,
> kernel will print this warning:
> 
> [    2.201835] hdmi-audio-codec hdmi-audio-codec.1.auto: ASoC: Failed to
> create Playback debugfs file
> 
> Assign different names to them to avoid that.
> 
> Signed-off-by: Jeffy Chen <jeffy.chen@rock-chips.com>
> ---
> 
>  sound/soc/codecs/hdmi-codec.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/sound/soc/codecs/hdmi-codec.c b/sound/soc/codecs/hdmi-codec.c
> index 509ab51..a2af440 100644
> --- a/sound/soc/codecs/hdmi-codec.c
> +++ b/sound/soc/codecs/hdmi-codec.c
> @@ -696,7 +696,7 @@ static struct snd_soc_dai_driver hdmi_i2s_dai = {
>  	.name = "i2s-hifi",
>  	.id = DAI_ID_I2S,
>  	.playback = {
> -		.stream_name = "Playback",
> +		.stream_name = "I2S Playback",
>  		.channels_min = 2,
>  		.channels_max = 8,
>  		.rates = HDMI_RATES,
> @@ -711,7 +711,7 @@ static const struct snd_soc_dai_driver hdmi_spdif_dai = {
>  	.name = "spdif-hifi",
>  	.id = DAI_ID_SPDIF,
>  	.playback = {
> -		.stream_name = "Playback",
> +		.stream_name = "SPDIF Playback",
>  		.channels_min = 2,
>  		.channels_max = 2,
>  		.rates = HDMI_RATES,
> -- 
> 2.1.4
> 
> 

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH] ASoC: hdmi-codec: Use different name for playback streams
  2017-08-11 16:59 ` [PATCH] ASoC: hdmi-codec: Use different name for playback streams Brian Norris
@ 2017-08-12  0:52   ` jeffy
  0 siblings, 0 replies; 2+ messages in thread
From: jeffy @ 2017-08-12  0:52 UTC (permalink / raw)
  To: Brian Norris; +Cc: linux-kernel, dianders, alsa-devel

Hi Brian,

Thanks for noting.

On 08/12/2017 12:59 AM, Brian Norris wrote:
> Hi Jeffy,
>
> You need to be more careful about the addressee's of your patches. No
> one on To/CC is a maintainer or a sufficiently-targeted mailing list. I
> doubt any of the maintainers will read your patch. (I've added
> alsa-devel for you, but given my understanding of at least Mark's
> patchwork workflow -- and of general patch etiquette -- it's important
> the patch is actually sent there in the first place.)
>
> Probably worth resending.
Ok, will do that.

I was using patman to send it, not sure why it didn't work correctly 
that time...

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2017-08-12  0:52 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
     [not found] <1502440173-23429-1-git-send-email-jeffy.chen@rock-chips.com>
2017-08-11 16:59 ` [PATCH] ASoC: hdmi-codec: Use different name for playback streams Brian Norris
2017-08-12  0:52   ` jeffy

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox