Alsa-Devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Ranjani Sridharan <ranjani.sridharan@linux.intel.com>
To: "Amadeusz Sławiński" <amadeuszx.slawinski@linux.intel.com>,
	"Liam Girdwood" <lgirdwood@gmail.com>,
	"Mark Brown" <broonie@kernel.org>
Cc: Cezary Rojewski <cezary.rojewski@intel.com>,
	Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>,
	alsa-devel@alsa-project.org, Takashi Iwai <tiwai@suse.com>
Subject: Re: [PATCH 0/6] ASoC: topology: Cleanup patches
Date: Fri, 01 Apr 2022 13:22:57 -0700	[thread overview]
Message-ID: <66dc2dbe3fe0bc25164018927fa010d0d4b69791.camel@linux.intel.com> (raw)
In-Reply-To: <20220401120200.4047867-1-amadeuszx.slawinski@linux.intel.com>

On Fri, 2022-04-01 at 14:01 +0200, Amadeusz Sławiński wrote:
> Following patches contain minor changes, cleaning up code to be
> easier
> to read.
> Clean up few loops, to be simpler or altogether remove them.
> Rename some things to make code easier to understand.
> 
> Amadeusz Sławiński (6):
>   ASoC: topology: Use for loop instead of while
>   ASoC: topology: Remove unnecessary looping
>   ASoC: topology: Return bool instead of int
>   ASoC: topology: Rename SOC_TPLG_PASS_MIXER to _CONTROL
>   ASoC: topology: Correct error message
>   ASoC: topology: Rename soc_tplg_init_kcontrol() function
> 
>  sound/soc/soc-topology.c | 455 ++++++++++++++++++-------------------
> --
>  1 file changed, 208 insertions(+), 247 deletions(-)

Looks good to me. Thanks!

Reviewed-by: Ranjani Sridharan <ranjani.sridharan@linux.intel.com>


  parent reply	other threads:[~2022-04-01 20:24 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-04-01 12:01 [PATCH 0/6] ASoC: topology: Cleanup patches Amadeusz Sławiński
2022-04-01 12:01 ` [PATCH 1/6] ASoC: topology: Use for loop instead of while Amadeusz Sławiński
2022-04-01 12:01 ` [PATCH 2/6] ASoC: topology: Remove unnecessary looping Amadeusz Sławiński
2022-04-01 12:01 ` [PATCH 3/6] ASoC: topology: Return bool instead of int Amadeusz Sławiński
2022-04-01 12:01 ` [PATCH 4/6] ASoC: topology: Rename SOC_TPLG_PASS_MIXER to _CONTROL Amadeusz Sławiński
2022-04-01 12:01 ` [PATCH 5/6] ASoC: topology: Correct error message Amadeusz Sławiński
2022-04-01 12:02 ` [PATCH 6/6] ASoC: topology: Rename soc_tplg_init_kcontrol() function Amadeusz Sławiński
2022-04-01 12:51 ` [PATCH 0/6] ASoC: topology: Cleanup patches Cezary Rojewski
2022-04-01 20:22 ` Ranjani Sridharan [this message]
2022-04-05  9:31 ` Mark Brown

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=66dc2dbe3fe0bc25164018927fa010d0d4b69791.camel@linux.intel.com \
    --to=ranjani.sridharan@linux.intel.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=amadeuszx.slawinski@linux.intel.com \
    --cc=broonie@kernel.org \
    --cc=cezary.rojewski@intel.com \
    --cc=lgirdwood@gmail.com \
    --cc=pierre-louis.bossart@linux.intel.com \
    --cc=tiwai@suse.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox