Alsa-Devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Cezary Rojewski <cezary.rojewski@intel.com>
To: "Amadeusz Sławiński" <amadeuszx.slawinski@linux.intel.com>
Cc: Pierre-Louis Bossart <pierre-louis.bossart@linux.intel.com>,
	alsa-devel@alsa-project.org, Takashi Iwai <tiwai@suse.com>,
	Liam Girdwood <lgirdwood@gmail.com>,
	Mark Brown <broonie@kernel.org>
Subject: Re: [PATCH 0/6] ASoC: topology: Cleanup patches
Date: Fri, 1 Apr 2022 14:51:36 +0200	[thread overview]
Message-ID: <f8e1cad7-c411-e8db-b182-654054456924@intel.com> (raw)
In-Reply-To: <20220401120200.4047867-1-amadeuszx.slawinski@linux.intel.com>

On 2022-04-01 2:01 PM, Amadeusz Sławiński wrote:
> Following patches contain minor changes, cleaning up code to be easier
> to read.
> Clean up few loops, to be simpler or altogether remove them.
> Rename some things to make code easier to understand.

While avs-driver is not fully upstreamed yet, I believe it is still 
vital to state that patches have been tested on following cAVS 1.5 
platforms i.e.: Skylake, Kabylake, Amberlake, Appololake and their 
variants with the avs-drivers.

As code looks good to me:

Reviewed-by: Cezary Rojewski <cezary.rojewski@intel.com>

> Amadeusz Sławiński (6):
>    ASoC: topology: Use for loop instead of while
>    ASoC: topology: Remove unnecessary looping
>    ASoC: topology: Return bool instead of int
>    ASoC: topology: Rename SOC_TPLG_PASS_MIXER to _CONTROL
>    ASoC: topology: Correct error message
>    ASoC: topology: Rename soc_tplg_init_kcontrol() function
> 
>   sound/soc/soc-topology.c | 455 ++++++++++++++++++---------------------
>   1 file changed, 208 insertions(+), 247 deletions(-)
> 

  parent reply	other threads:[~2022-04-01 12:53 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-04-01 12:01 [PATCH 0/6] ASoC: topology: Cleanup patches Amadeusz Sławiński
2022-04-01 12:01 ` [PATCH 1/6] ASoC: topology: Use for loop instead of while Amadeusz Sławiński
2022-04-01 12:01 ` [PATCH 2/6] ASoC: topology: Remove unnecessary looping Amadeusz Sławiński
2022-04-01 12:01 ` [PATCH 3/6] ASoC: topology: Return bool instead of int Amadeusz Sławiński
2022-04-01 12:01 ` [PATCH 4/6] ASoC: topology: Rename SOC_TPLG_PASS_MIXER to _CONTROL Amadeusz Sławiński
2022-04-01 12:01 ` [PATCH 5/6] ASoC: topology: Correct error message Amadeusz Sławiński
2022-04-01 12:02 ` [PATCH 6/6] ASoC: topology: Rename soc_tplg_init_kcontrol() function Amadeusz Sławiński
2022-04-01 12:51 ` Cezary Rojewski [this message]
2022-04-01 20:22 ` [PATCH 0/6] ASoC: topology: Cleanup patches Ranjani Sridharan
2022-04-05  9:31 ` Mark Brown

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f8e1cad7-c411-e8db-b182-654054456924@intel.com \
    --to=cezary.rojewski@intel.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=amadeuszx.slawinski@linux.intel.com \
    --cc=broonie@kernel.org \
    --cc=lgirdwood@gmail.com \
    --cc=pierre-louis.bossart@linux.intel.com \
    --cc=tiwai@suse.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox