Alsa-Devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] ASoC: cs4271: Remove unnecessary additional variable definition
@ 2017-05-23 15:03 Charles Keepax
  2017-05-23 17:22 ` [PATCH] ASoC: cs4271: Remove unnecessary additional variable definitio Paul Handrigan
  2017-05-24 17:42 ` Applied "ASoC: cs4271: Remove unnecessary additional variable definition" to the asoc tree Mark Brown
  0 siblings, 2 replies; 3+ messages in thread
From: Charles Keepax @ 2017-05-23 15:03 UTC (permalink / raw)
  To: broonie, brian.austin; +Cc: alsa-devel, patches, lgirdwood, Paul.Handrigan

The function already defines a ret variable at the top and makes
no particular use of the shadowed definition, as such remove the
redundant definition.

Signed-off-by: Charles Keepax <ckeepax@opensource.wolfsonmicro.com>
---
 sound/soc/codecs/cs4271.c | 2 --
 1 file changed, 2 deletions(-)

diff --git a/sound/soc/codecs/cs4271.c b/sound/soc/codecs/cs4271.c
index e78b5f0..d882477 100644
--- a/sound/soc/codecs/cs4271.c
+++ b/sound/soc/codecs/cs4271.c
@@ -674,8 +674,6 @@ static int cs4271_common_probe(struct device *dev,
 		cs4271->gpio_nreset = cs4271plat->gpio_nreset;
 
 	if (gpio_is_valid(cs4271->gpio_nreset)) {
-		int ret;
-
 		ret = devm_gpio_request(dev, cs4271->gpio_nreset,
 					"CS4271 Reset");
 		if (ret < 0)
-- 
2.1.4

^ permalink raw reply related	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2017-05-24 17:42 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2017-05-23 15:03 [PATCH] ASoC: cs4271: Remove unnecessary additional variable definition Charles Keepax
2017-05-23 17:22 ` [PATCH] ASoC: cs4271: Remove unnecessary additional variable definitio Paul Handrigan
2017-05-24 17:42 ` Applied "ASoC: cs4271: Remove unnecessary additional variable definition" to the asoc tree Mark Brown

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox