* [PATCH 1/2] OMAP4: PMIC: Rename twl6030_codec as twl6040_codec
@ 2010-03-13 1:52 Olaya, Margarita
2010-03-13 11:17 ` Felipe Balbi
0 siblings, 1 reply; 3+ messages in thread
From: Olaya, Margarita @ 2010-03-13 1:52 UTC (permalink / raw)
To: alsa-devel@alsa-project.org, linux-omap@vger.kernel.org
Cc: broonie@opensource.wolfsonmicro.com, lrg@slimlogic.co.uk,
Samuel Ortiz
Signed-off-by: Margarita Olaya Cabrera <magi.olaya@ti.com>
---
drivers/mfd/twl-core.c | 4 ++--
include/linux/i2c/twl.h | 6 +++---
2 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/mfd/twl-core.c b/drivers/mfd/twl-core.c
index 562cd49..720e099 100644
--- a/drivers/mfd/twl-core.c
+++ b/drivers/mfd/twl-core.c
@@ -109,7 +109,7 @@
#endif
#if defined(CONFIG_TWL4030_CODEC) || defined(CONFIG_TWL4030_CODEC_MODULE) ||\
- defined(CONFIG_SND_SOC_TWL6030) || defined(CONFIG_SND_SOC_TWL6030_MODULE)
+ defined(CONFIG_SND_SOC_TWL6040) || defined(CONFIG_SND_SOC_TWL6040_MODULE)
#define twl_has_codec() true
#else
#define twl_has_codec() false
@@ -708,7 +708,7 @@ add_children(struct twl4030_platform_data *pdata, unsigned long features)
/* Phoenix*/
if (twl_has_codec() && pdata->codec && twl_class_is_6030()) {
sub_chip_id = twl_map[TWL_MODULE_AUDIO_VOICE].sid;
- child = add_child(sub_chip_id, "twl6030_codec",
+ child = add_child(sub_chip_id, "twl6040_codec",
pdata->codec, sizeof(*pdata->codec),
false, 0, 0);
if (IS_ERR(child))
diff --git a/include/linux/i2c/twl.h b/include/linux/i2c/twl.h
index fb6784e..ebd90ce 100644
--- a/include/linux/i2c/twl.h
+++ b/include/linux/i2c/twl.h
@@ -569,9 +569,9 @@ struct twl4030_codec_data {
struct twl4030_codec_audio_data *audio;
struct twl4030_codec_vibra_data *vibra;
- /* twl6030 */
- int audpwron_gpio; /* audio power-on gpio */
- int naudint_irq; /* audio interrupt */
+ /* twl6040 */
+ int audpwron_gpio; /* audio power-on gpio */
+ int naudint_irq; /* audio interrupt */
};
struct twl4030_platform_data {
--
1.6.1.3
^ permalink raw reply related [flat|nested] 3+ messages in thread
* Re: [PATCH 1/2] OMAP4: PMIC: Rename twl6030_codec as twl6040_codec
2010-03-13 1:52 [PATCH 1/2] OMAP4: PMIC: Rename twl6030_codec as twl6040_codec Olaya, Margarita
@ 2010-03-13 11:17 ` Felipe Balbi
2010-03-16 17:35 ` Olaya, Margarita
0 siblings, 1 reply; 3+ messages in thread
From: Felipe Balbi @ 2010-03-13 11:17 UTC (permalink / raw)
To: Olaya, Margarita; +Cc: alsa-devel, linux-omap, broonie, lrg, Samuel Ortiz
Hi,
On Fri, 12 Mar 2010 19:52:15 -0600, "Olaya, Margarita" <magi.olaya@ti.com>
wrote:
please add a description here. Why do you need to rename it ?
> Signed-off-by: Margarita Olaya Cabrera <magi.olaya@ti.com>
[snip]
> @@ -708,7 +708,7 @@ add_children(struct twl4030_platform_data *pdata,
> unsigned long features)
> /* Phoenix*/
> if (twl_has_codec() && pdata->codec && twl_class_is_6030()) {
> sub_chip_id = twl_map[TWL_MODULE_AUDIO_VOICE].sid;
> - child = add_child(sub_chip_id, "twl6030_codec",
> + child = add_child(sub_chip_id, "twl6040_codec",
you rename the platform_device but no the platform_driver ??
how do you expect the driver to probe() ??
--
balbi
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH 1/2] OMAP4: PMIC: Rename twl6030_codec as twl6040_codec
2010-03-13 11:17 ` Felipe Balbi
@ 2010-03-16 17:35 ` Olaya, Margarita
0 siblings, 0 replies; 3+ messages in thread
From: Olaya, Margarita @ 2010-03-16 17:35 UTC (permalink / raw)
To: Felipe Balbi
Cc: alsa-devel@alsa-project.org, linux-omap@vger.kernel.org,
lrg@slimlogic.co.uk, Samuel Ortiz,
broonie@opensource.wolfsonmicro.com
On Saturday, March 13, 2010 5:18 AM Felipe Balbi wrote:
> Hi,
>
> On Fri, 12 Mar 2010 19:52:15 -0600, "Olaya, Margarita"
> <magi.olaya@ti.com> wrote:
>
> please add a description here. Why do you need to rename it ?
Ok, I'll add a description. We were using twl6030 for Phoenix
Audio and Phoenix Power chips but Phoenix Audio is actually twl6040.
>
>> Signed-off-by: Margarita Olaya Cabrera <magi.olaya@ti.com>
>
> [snip]
>
>> if (twl_has_codec() && pdata->codec && twl_class_is_6030()) {
>> sub_chip_id = twl_map[TWL_MODULE_AUDIO_VOICE].sid;
>> - child = add_child(sub_chip_id, "twl6030_codec",
>> + child = add_child(sub_chip_id, "twl6040_codec",
>
> you rename the platform_device but no the platform_driver ??
> how do you expect the driver to probe() ??
Platform_driver register is called in twl6040.c file, I haven't found an issue
at probe.
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2010-03-16 17:35 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2010-03-13 1:52 [PATCH 1/2] OMAP4: PMIC: Rename twl6030_codec as twl6040_codec Olaya, Margarita
2010-03-13 11:17 ` Felipe Balbi
2010-03-16 17:35 ` Olaya, Margarita
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox