ATH10K Archive on lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/9] ath10k: cleanups 2015-03-20
@ 2015-03-20 13:54 Michal Kazior
  2015-03-20 13:54 ` [PATCH 1/9] ath10k: move rate definitions to file start Michal Kazior
                   ` (9 more replies)
  0 siblings, 10 replies; 11+ messages in thread
From: Michal Kazior @ 2015-03-20 13:54 UTC (permalink / raw)
  To: ath10k; +Cc: linux-wireless, Michal Kazior

Hi,

Here's a bunch of cleanups and fixes associated
with tx/rx rate code.

Feel free to squash some of the patches if you
think it makes sense or let me know which ones you
want me to squash.

There are a few checkpatch warnings for going over
80 chars. I decided to leave them be to avoid code
wrapping which would make the code less readable
than it is now in my opinion.

I have 2 more patches for .set_bitrate_mask()
callback which depend on this patchset. Once you
apply this patchset to your `pending` branch let
me know, please, so I can push the rest with git
indexes your git repo will recognize.


Michal Kazior (9):
  ath10k: move rate definitions to file start
  ath10k: derive rate from bitrate
  ath10k: drop RATETAB_ENT macro
  ath10k: add hw rate definitions
  ath10k: use hw rate definitions for fixed rate
  ath10k: simplify fixed rate selection
  ath10k: rework legacy rx rate decoding
  ath10k: deduplicate bitrate to rate idx conversion
  ath10k: document ofdm/5ghz rate offset with a macro

 drivers/net/wireless/ath/ath10k/htt.h     |   1 +
 drivers/net/wireless/ath/ath10k/htt_rx.c  |  64 ++----------
 drivers/net/wireless/ath/ath10k/hw.h      |  21 ++++
 drivers/net/wireless/ath/ath10k/mac.c     | 161 ++++++++++++++++++------------
 drivers/net/wireless/ath/ath10k/mac.h     |   5 +
 drivers/net/wireless/ath/ath10k/rx_desc.h |  22 ++++
 drivers/net/wireless/ath/ath10k/wmi.c     |  62 +-----------
 7 files changed, 163 insertions(+), 173 deletions(-)

-- 
2.1.4


_______________________________________________
ath10k mailing list
ath10k@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/ath10k

^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2015-03-30 12:19 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2015-03-20 13:54 [PATCH 0/9] ath10k: cleanups 2015-03-20 Michal Kazior
2015-03-20 13:54 ` [PATCH 1/9] ath10k: move rate definitions to file start Michal Kazior
2015-03-20 13:54 ` [PATCH 2/9] ath10k: derive rate from bitrate Michal Kazior
2015-03-20 13:54 ` [PATCH 3/9] ath10k: drop RATETAB_ENT macro Michal Kazior
2015-03-20 13:54 ` [PATCH 4/9] ath10k: add hw rate definitions Michal Kazior
2015-03-20 13:54 ` [PATCH 5/9] ath10k: use hw rate definitions for fixed rate Michal Kazior
2015-03-20 13:54 ` [PATCH 6/9] ath10k: simplify fixed rate selection Michal Kazior
2015-03-20 13:54 ` [PATCH 7/9] ath10k: rework legacy rx rate decoding Michal Kazior
2015-03-20 13:54 ` [PATCH 8/9] ath10k: deduplicate bitrate to rate idx conversion Michal Kazior
2015-03-20 13:54 ` [PATCH 9/9] ath10k: document ofdm/5ghz rate offset with a macro Michal Kazior
2015-03-30 12:19 ` [PATCH 0/9] ath10k: cleanups 2015-03-20 Kalle Valo

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox