BPF List
 help / color / mirror / Atom feed
From: Alan Maguire <alan.maguire@oracle.com>
To: Quentin Monnet <qmo@kernel.org>,
	ast@kernel.org, andrii@kernel.org, eddyz87@gmail.com,
	jolsa@kernel.org
Cc: daniel@iogearbox.net, ihor.solodrai@linux.dev,
	yonghong.song@linux.dev, song@kernel.org, martin.lau@linux.dev,
	memxor@gmail.com, emil@etsalapatis.com, bpf@vger.kernel.org,
	nsc@kernel.org, puranjay@kernel.org, yatsenko@meta.com
Subject: Re: [PATCH v3 bpf-next 09/11] bpftool: Add ability to dump LOC_PARAM, LOC_PROTO and LOCSEC
Date: Thu, 17 Sep 2026 18:32:57 +0100	[thread overview]
Message-ID: <2f661066-caae-4ce2-8a6c-e07bbd4bc146@oracle.com> (raw)
In-Reply-To: <89767d7c-c622-42dc-a820-ead87ed3e2cf@kernel.org>

On 17/09/2026 17:06, Quentin Monnet wrote:
> 2026-09-16 08:41 UTC+0100 ~ Alan Maguire <alan.maguire@oracle.com>
>> In raw mode ensure we can dump new BTF kinds in normal/json format.
>> BTF_KIND_LOC_PARAMs are rendered as strings, for example a
>> const value of 0x2a and a dereference of r10 + 0x20:
>>
>>   [12] LOC_PARAM '(anon)' size=4 flags=0x2 vlen=1 values='0x2a'
>>   [13] LOC_PARAM '(anon)' size=8 flags=0x38 vlen=2 values='*(r10 + 0x20)'
>>
>> LOC_PROTOs render the associated values of each of their
>> LOC_PARAMs for easier readability:
>>
>>   [14] LOC_PROTO '(anon)' vlen=2
>>   	type_id=12 value='r1'
>>   	type_id=13 value='*(r2 + 0x10)'
>>
>> and LOCSEC shows function name associated with site:
>>
>>   [15] LOCSEC 'inline.text' vlen=1
>>   	name=foo func_type_id=5 loc_proto_type_id=14 offset=64
>>
>> Signed-off-by: Alan Maguire <alan.maguire@oracle.com>
>> ---
>>  tools/bpf/bpftool/btf.c | 169 ++++++++++++++++++++++++++++++++++++++++
>>  1 file changed, 169 insertions(+)
>>
>> diff --git a/tools/bpf/bpftool/btf.c b/tools/bpf/bpftool/btf.c
>> index bbe8f9ea144f..5e0cb5862811 100644
>> --- a/tools/bpf/bpftool/btf.c
>> +++ b/tools/bpf/bpftool/btf.c
>> @@ -51,6 +51,9 @@ static const char * const btf_kind_str[NR_BTF_KINDS] = {
>>  	[BTF_KIND_DECL_TAG]	= "DECL_TAG",
>>  	[BTF_KIND_TYPE_TAG]	= "TYPE_TAG",
>>  	[BTF_KIND_ENUM64]	= "ENUM64",
>> +	[BTF_KIND_LOC_PARAM]	= "LOC_PARAM",
>> +	[BTF_KIND_LOC_PROTO]	= "LOC_PROTO",
>> +	[BTF_KIND_LOCSEC]	= "LOCSEC",
>>  };
>>  
>>  struct sort_datum {
>> @@ -117,6 +120,83 @@ static int btf_kind_safe(int kind)
>>  	return kind <= BTF_KIND_MAX ? kind : BTF_KIND_UNKN;
>>  }
>>  
>> +static void btf_loc_param_str(const struct btf_type *t, char *str, size_t sz)
>> +{
>> +	const struct btf_loc_param *p;
>> +	__u32 i = 0, vlen;
>> +	__u64 value;
>> +	bool negative = false;
>> +	char regs[32] = {};
>> +	char num[32] = {};
>> +	const char *op = "";
>> +
>> +	if (!t || !btf_is_loc_param(t)) {
>> +		snprintf(str, sz, "<invalid>");
>> +		return;
>> +	}
>> +
>> +	p = btf_loc_param(t);
>> +	vlen = btf_vlen(t);
>> +
>> +	if (p->flags & BTF_LOC_PARAM_REG) {
>> +		__u32 nregs = (p->flags == BTF_LOC_PARAM_REG) ? vlen : 1;
>> +
>> +		if (nregs > vlen) {
>> +			snprintf(str, sz, "?");
>> +			return;
>> +		}
>> +
>> +		switch (nregs) {
>> +		case 2:
>> +			snprintf(regs, sizeof(regs), "r%u, r%u",
>> +				 p->values[0], p->values[1]);
>> +			break;
>> +		case 1:
>> +			snprintf(regs, sizeof(regs), "r%u", p->values[0]);
>> +			break;
>> +		default:
>> +			snprintf(regs, sizeof(regs), "?");
>> +			break;
>> +		}
>> +		i += nregs;
>> +	}
>> +	if (p->flags & (BTF_LOC_PARAM_CONST|BTF_LOC_PARAM_OFFSET)) {
>> +		switch (vlen - i) {
>> +		case 1:
>> +			value = p->values[i];
>> +			break;
>> +		case 2:
>> +			value = ((__u64)p->values[i + 1] << 32) | p->values[i];
>> +			break;
>> +		default:
>> +			snprintf(num, sizeof(num), "?");
>> +			goto done;
>> +		}
>> +		if ((p->flags & BTF_LOC_PARAM_SIGNED) && t->size &&
>> +		    t->size <= sizeof(value)) {
>> +			__u32 bits = t->size * 8;
> 
> 
> Hi Alan, thanks!
> 
> In the case of BTF_LOC_PARAM_OFFSET, what do we need "negative" for
> exactly, is this supposed to be the sign for the parameter or for the
> associated offset? My understanding is that "t->size" refers to the
> parameter itself, not the offset, so we would pick the wrong bit if
> trying to find the sign for the offset? But I'm not sure I read it
> correctly.
> 

hi Quentin, great catch! This was a leftover from a previous iteration
where the sign of the size was used to connote whether the constant 
value is signed or not; we use the flags to identify that now so that
the size can be a valid (>= 0) size, so the negative size needs to go
away; will fix for v4.

> 
>> +
>> +			if (t->size < sizeof(value))
>> +				value &= (1ULL << bits) - 1;
>> +			negative = value & (1ULL << (bits - 1));
>> +			if (negative)
>> +				value = t->size == sizeof(value) ? -value :
>> +					(1ULL << bits) - value;
>> +		}
>> +		snprintf(num, sizeof(num), "0x%llx", (unsigned long long)value);
> 
> 
> Looking at the different existing flags and their docs, I see:
> 
> "a BTF_LOC_PARAM_ADDR|BTF_LOC_PARAM_CONST is an address that should be
> normalized with respect to kernel/module base address."
> 
> But I don't see the output accounting for BTF_LOC_PARAM_ADDR, is this
> expected or is that an omission?
>

In general an address will have both _CONST and _ADDR specified so it will
be captured by const display, but I should make that more explicit in the
code.
 
> [...]
> 
> Please also look at Sashiko and bpf-ci's reviews for patch 7.
>

Will do; thanks again!

Alan

 
> Thanks,
> Quentin


  reply	other threads:[~2026-09-17 17:33 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-16  7:41 [PATCH v3 bpf-next 00/11] Support inline functions in BTF Alan Maguire
2026-09-16  7:41 ` [PATCH v3 bpf-next 01/11] btf: Extend UAPI to support BTF location (inline site) info Alan Maguire
2026-09-16  9:03   ` bot+bpf-ci
2026-09-16  7:41 ` [PATCH v3 bpf-next 02/11] libbpf: Add support for BTF kinds LOC[_PARAM|_PROTO|SEC] Alan Maguire
2026-09-16  7:55   ` sashiko-bot
2026-09-16  9:03   ` bot+bpf-ci
2026-09-16  7:41 ` [PATCH v3 bpf-next 03/11] selftests/bpf: Test helper support for BTF_KIND_LOC[_PARAM|_PROTO|SEC] Alan Maguire
2026-09-16  8:44   ` bot+bpf-ci
2026-09-18 18:34   ` Eduard Zingerman
2026-09-16  7:41 ` [PATCH v3 bpf-next 04/11] selftests/bpf: Add LOC_PARAM, LOC_PROTO, LOCSEC to field iter tests Alan Maguire
2026-09-18 18:43   ` Eduard Zingerman
2026-09-16  7:41 ` [PATCH v3 bpf-next 05/11] selftests/bpf: Add LOC_PARAM, LOC_PROTO, LOCSEC to dedup split tests Alan Maguire
2026-09-18 18:46   ` Eduard Zingerman
2026-09-16  7:41 ` [PATCH v3 bpf-next 06/11] selftests/bpf: BTF distill tests to ensure LOC[_PARAM|_PROTO] add to split BTF Alan Maguire
2026-09-18 19:59   ` Eduard Zingerman
2026-09-21 18:36     ` Alan Maguire
2026-09-16  7:41 ` [PATCH v3 bpf-next 07/11] bpftool: Handle multi-split BTF by supporting multiple base BTFs Alan Maguire
2026-09-16  7:54   ` sashiko-bot
2026-09-16  9:03   ` bot+bpf-ci
2026-09-16  7:41 ` [PATCH v3 bpf-next 08/11] bpftool: Document support for multi-split BTF Alan Maguire
2026-09-16  7:41 ` [PATCH v3 bpf-next 09/11] bpftool: Add ability to dump LOC_PARAM, LOC_PROTO and LOCSEC Alan Maguire
2026-09-16  7:55   ` sashiko-bot
2026-09-16  9:03   ` bot+bpf-ci
2026-09-16 22:07   ` Jiri Olsa
2026-09-17  8:27     ` Alan Maguire
2026-09-17 22:00       ` Jiri Olsa
2026-09-18  9:19         ` Alan Maguire
2026-09-18 13:01           ` Jiri Olsa
2026-09-17 16:06   ` Quentin Monnet
2026-09-17 17:32     ` Alan Maguire [this message]
2026-09-18  7:29     ` Alan Maguire
2026-09-18 20:51   ` Eduard Zingerman
2026-09-21 18:47     ` Alan Maguire
2026-09-21 21:46       ` Eduard Zingerman
2026-09-22 11:59         ` Quentin Monnet
2026-09-23  8:47           ` Alan Maguire
2026-09-16  7:41 ` [PATCH v3 bpf-next 10/11] selftests/bpf: Test bpftool dump of BTF location info Alan Maguire
2026-09-16  7:56   ` sashiko-bot
2026-09-16  9:03   ` bot+bpf-ci
2026-09-16  7:41 ` [PATCH v3 bpf-next 11/11] Documentation/bpf: Describe new location-related BTF kinds Alan Maguire
2026-09-16  8:01   ` sashiko-bot
2026-09-16  9:03   ` bot+bpf-ci

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2f661066-caae-4ce2-8a6c-e07bbd4bc146@oracle.com \
    --to=alan.maguire@oracle.com \
    --cc=andrii@kernel.org \
    --cc=ast@kernel.org \
    --cc=bpf@vger.kernel.org \
    --cc=daniel@iogearbox.net \
    --cc=eddyz87@gmail.com \
    --cc=emil@etsalapatis.com \
    --cc=ihor.solodrai@linux.dev \
    --cc=jolsa@kernel.org \
    --cc=martin.lau@linux.dev \
    --cc=memxor@gmail.com \
    --cc=nsc@kernel.org \
    --cc=puranjay@kernel.org \
    --cc=qmo@kernel.org \
    --cc=song@kernel.org \
    --cc=yatsenko@meta.com \
    --cc=yonghong.song@linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox