* [PATCH 00/12] net: Use min()/max() to improve code
@ 2025-07-08 13:55 Qianfeng Rong
2025-07-08 14:12 ` Jakub Kicinski
2025-07-08 14:15 ` Qianfeng Rong
0 siblings, 2 replies; 7+ messages in thread
From: Qianfeng Rong @ 2025-07-08 13:55 UTC (permalink / raw)
To: Andrew Lunn, David S. Miller, Eric Dumazet, Jakub Kicinski,
Paolo Abeni, Potnuri Bharat Teja, Veerasenareddy Burru,
Sathesh Edara, Louis Peens, Shahed Shaikh, Manish Chopra,
GR-Linux-NIC-Dev, Jiri Slaby, Nick Kossifidis, Luis Chamberlain,
Toke Høiland-Jørgensen, Arend van Spriel, Brian Norris,
Francesco Dolcini, Ajay Singh, Claudiu Beznea, Ping-Ke Shih,
Qianfeng Rong, Kees Cook, Gustavo A. R. Silva,
Benjamin Große, Hayes Wang, Lucas Sanchez Sagrado,
Philipp Hahn, Aleksander Jan Bajkowski, Eric Biggers,
Wentao Liang, Johannes Berg, Sebastian Reichel, Ondrej Jirman,
Jacobe Zang, Dmitry Antipov, Kalle Valo, Sascha Hauer,
Aditya Kumar Singh, David Lin, Roopni Devanathan,
Rameshkumar Sundaram, Marek Vasut, Alexis Lothoré,
Arnd Bergmann, netdev, linux-kernel, oss-drivers, linux-usb,
linux-wireless, brcm80211, brcm80211-dev-list.pdl
Cc: opensource.kernel
Use min() to reduce the code and improve its readability.
No functional changes.
Qianfeng Rong (12):
ethernet: liquidio: Use min() to improve code
ethernet: cxgb4: Use min() to improve code
ethernet: octeon_ep: Use min() to improve code
ethernet: nfp: Use min()/max() to improve code
ethernet: qlcnic: Use min() to improve code
net: usb: Use min() to improve code
wifi: ath5k: Use max() to improve code
wifi: ath9k: Use max() to improve code
wifi: brcm80211: Use min() to improve code
wifi: mwifiex: Use max() to improve code
wifi: wilc1000: Use min() to improve code
wifi: rtlwifi: Use min()/max() to improve code
.../ethernet/cavium/liquidio/octeon_console.c | 5 +----
drivers/net/ethernet/chelsio/cxgb4/t4_hw.c | 5 +----
.../marvell/octeon_ep/octep_pfvf_mbox.c | 5 +----
.../ethernet/netronome/nfp/nfp_netvf_main.c | 13 ++++---------
.../ethernet/qlogic/qlcnic/qlcnic_83xx_hw.c | 5 +----
drivers/net/usb/r8152.c | 5 +----
drivers/net/wireless/ath/ath5k/phy.c | 12 +++---------
drivers/net/wireless/ath/ath9k/dfs.c | 5 +----
.../broadcom/brcm80211/brcmfmac/usb.c | 5 +----
.../broadcom/brcm80211/brcmsmac/phy/phy_n.c | 6 ++----
.../net/wireless/marvell/mwifiex/cfg80211.c | 6 ++----
.../net/wireless/microchip/wilc1000/wlan.c | 5 +----
.../wireless/realtek/rtlwifi/rtl8192ce/hw.c | 19 +++----------------
.../wireless/realtek/rtlwifi/rtl8192cu/hw.c | 17 +++--------------
.../wireless/realtek/rtlwifi/rtl8192ee/dm.c | 5 +----
.../wireless/realtek/rtlwifi/rtl8723ae/hw.c | 15 +++------------
.../wireless/realtek/rtlwifi/rtl8723be/dm.c | 5 +----
.../wireless/realtek/rtlwifi/rtl8821ae/dm.c | 5 +----
18 files changed, 31 insertions(+), 112 deletions(-)
--
2.34.1
^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: [PATCH 00/12] net: Use min()/max() to improve code
2025-07-08 13:55 Qianfeng Rong
@ 2025-07-08 14:12 ` Jakub Kicinski
2025-07-08 14:15 ` Qianfeng Rong
1 sibling, 0 replies; 7+ messages in thread
From: Jakub Kicinski @ 2025-07-08 14:12 UTC (permalink / raw)
To: Qianfeng Rong
Cc: Andrew Lunn, David S. Miller, Eric Dumazet, Paolo Abeni,
Potnuri Bharat Teja, Veerasenareddy Burru, Sathesh Edara,
Louis Peens, Shahed Shaikh, Manish Chopra, GR-Linux-NIC-Dev,
Jiri Slaby, Nick Kossifidis, Luis Chamberlain,
Toke Høiland-Jørgensen, Arend van Spriel, Brian Norris,
Francesco Dolcini, Ajay Singh, Claudiu Beznea, Ping-Ke Shih,
Kees Cook, Gustavo A. R. Silva, Benjamin Große, Hayes Wang,
Lucas Sanchez Sagrado, Philipp Hahn, Aleksander Jan Bajkowski,
Eric Biggers, Wentao Liang, Johannes Berg, Sebastian Reichel,
Ondrej Jirman, Jacobe Zang, Dmitry Antipov, Kalle Valo,
Sascha Hauer, Aditya Kumar Singh, David Lin, Roopni Devanathan,
Rameshkumar Sundaram, Marek Vasut, Alexis Lothoré,
Arnd Bergmann, netdev, linux-kernel, oss-drivers, linux-usb,
linux-wireless, brcm80211, brcm80211-dev-list.pdl,
opensource.kernel
On Tue, 8 Jul 2025 21:55:50 +0800 Qianfeng Rong wrote:
> Use min() to reduce the code and improve its readability.
>
> No functional changes.
I don't see any patches on the list, 15 min after receiving this cover
letter. But either way, this sort of changes are not worth the churn.
^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: [PATCH 00/12] net: Use min()/max() to improve code
2025-07-08 13:55 Qianfeng Rong
2025-07-08 14:12 ` Jakub Kicinski
@ 2025-07-08 14:15 ` Qianfeng Rong
1 sibling, 0 replies; 7+ messages in thread
From: Qianfeng Rong @ 2025-07-08 14:15 UTC (permalink / raw)
To: Andrew Lunn, David S. Miller, Eric Dumazet, Jakub Kicinski,
Paolo Abeni, Potnuri Bharat Teja, Veerasenareddy Burru,
Sathesh Edara, Louis Peens, Shahed Shaikh, Manish Chopra,
GR-Linux-NIC-Dev, Jiri Slaby, Nick Kossifidis, Luis Chamberlain,
Toke Høiland-Jørgensen, Arend van Spriel, Brian Norris,
Francesco Dolcini, Ajay Singh, Claudiu Beznea, Ping-Ke Shih,
Kees Cook, Gustavo A. R. Silva, Benjamin Große, Hayes Wang,
Lucas Sanchez Sagrado, Philipp Hahn, Aleksander Jan Bajkowski,
Eric Biggers, Wentao Liang, Johannes Berg, Sebastian Reichel,
Ondrej Jirman, Jacobe Zang, Dmitry Antipov, Kalle Valo,
Sascha Hauer, Aditya Kumar Singh, David Lin, Roopni Devanathan,
Rameshkumar Sundaram, Marek Vasut, Alexis Lothoré,
Arnd Bergmann, netdev, linux-kernel, oss-drivers, linux-usb,
linux-wireless, brcm80211, brcm80211-dev-list.pdl
Cc: opensource.kernel
Hi all,
Sorry, please ignore this incomplete email.
Thanks
在 2025/7/8 21:55, Qianfeng Rong 写道:
> Use min() to reduce the code and improve its readability.
>
> No functional changes.
>
> Qianfeng Rong (12):
> ethernet: liquidio: Use min() to improve code
> ethernet: cxgb4: Use min() to improve code
> ethernet: octeon_ep: Use min() to improve code
> ethernet: nfp: Use min()/max() to improve code
> ethernet: qlcnic: Use min() to improve code
> net: usb: Use min() to improve code
> wifi: ath5k: Use max() to improve code
> wifi: ath9k: Use max() to improve code
> wifi: brcm80211: Use min() to improve code
> wifi: mwifiex: Use max() to improve code
> wifi: wilc1000: Use min() to improve code
> wifi: rtlwifi: Use min()/max() to improve code
>
> .../ethernet/cavium/liquidio/octeon_console.c | 5 +----
> drivers/net/ethernet/chelsio/cxgb4/t4_hw.c | 5 +----
> .../marvell/octeon_ep/octep_pfvf_mbox.c | 5 +----
> .../ethernet/netronome/nfp/nfp_netvf_main.c | 13 ++++---------
> .../ethernet/qlogic/qlcnic/qlcnic_83xx_hw.c | 5 +----
> drivers/net/usb/r8152.c | 5 +----
> drivers/net/wireless/ath/ath5k/phy.c | 12 +++---------
> drivers/net/wireless/ath/ath9k/dfs.c | 5 +----
> .../broadcom/brcm80211/brcmfmac/usb.c | 5 +----
> .../broadcom/brcm80211/brcmsmac/phy/phy_n.c | 6 ++----
> .../net/wireless/marvell/mwifiex/cfg80211.c | 6 ++----
> .../net/wireless/microchip/wilc1000/wlan.c | 5 +----
> .../wireless/realtek/rtlwifi/rtl8192ce/hw.c | 19 +++----------------
> .../wireless/realtek/rtlwifi/rtl8192cu/hw.c | 17 +++--------------
> .../wireless/realtek/rtlwifi/rtl8192ee/dm.c | 5 +----
> .../wireless/realtek/rtlwifi/rtl8723ae/hw.c | 15 +++------------
> .../wireless/realtek/rtlwifi/rtl8723be/dm.c | 5 +----
> .../wireless/realtek/rtlwifi/rtl8821ae/dm.c | 5 +----
> 18 files changed, 31 insertions(+), 112 deletions(-)
>
^ permalink raw reply [flat|nested] 7+ messages in thread
* [PATCH 00/12] net: Use min()/max() to improve code
@ 2025-07-09 2:21 Qianfeng Rong
2025-07-09 2:21 ` [PATCH 09/12] wifi: brcm80211: Use min() " Qianfeng Rong
2025-07-11 0:59 ` [PATCH 00/12] net: Use min()/max() " Jakub Kicinski
0 siblings, 2 replies; 7+ messages in thread
From: Qianfeng Rong @ 2025-07-09 2:21 UTC (permalink / raw)
To: Andrew Lunn, David S. Miller, Eric Dumazet, Jakub Kicinski,
Paolo Abeni, Potnuri Bharat Teja, Veerasenareddy Burru,
Sathesh Edara, Louis Peens, Shahed Shaikh, Manish Chopra,
maintainer:QLOGIC QLCNIC (1/10)Gb ETHERNET DRIVER, Jiri Slaby,
Nick Kossifidis, Luis Chamberlain,
Toke Høiland-Jørgensen, Arend van Spriel, Brian Norris,
Francesco Dolcini, Ajay Singh, Claudiu Beznea, Ping-Ke Shih,
Qianfeng Rong, Kees Cook, Gustavo A. R. Silva, Kory Maincent,
Aleksander Jan Bajkowski, Lucas Sanchez Sagrado, Philipp Hahn,
Eric Biggers, Hayes Wang, Wentao Liang, Johannes Berg,
Sai Krishna, Jacobe Zang, Dmitry Antipov, Kalle Valo,
Sascha Hauer, David Lin, Aditya Kumar Singh, Roopni Devanathan,
Dan Carpenter, Marek Vasut, Alexis Lothoré, Arnd Bergmann,
open list:CAVIUM LIQUIDIO NETWORK DRIVER, open list,
open list:NETRONOME ETHERNET DRIVERS,
open list:USB NETWORKING DRIVERS,
open list:ATHEROS ATH5K WIRELESS DRIVER,
open list:BROADCOM BRCM80211 IEEE802.11 WIRELESS DRIVERS,
open list:BROADCOM BRCM80211 IEEE802.11 WIRELESS DRIVERS
Use min() to reduce the code and improve its readability.
No functional changes.
Qianfeng Rong (12):
ethernet: liquidio: Use min() to improve code
ethernet: cxgb4: Use min() to improve code
ethernet: octeon_ep: Use min() to improve code
ethernet: nfp: Use min()/max() to improve code
ethernet: qlcnic: Use min() to improve code
net: usb: Use min() to improve code
wifi: ath5k: Use max() to improve code
wifi: ath9k: Use max() to improve code
wifi: brcm80211: Use min() to improve code
wifi: mwifiex: Use max() to improve code
wifi: wilc1000: Use min() to improve code
wifi: rtlwifi: Use min()/max() to improve code
.../ethernet/cavium/liquidio/octeon_console.c | 5 +----
drivers/net/ethernet/chelsio/cxgb4/t4_hw.c | 5 +----
.../marvell/octeon_ep/octep_pfvf_mbox.c | 5 +----
.../ethernet/netronome/nfp/nfp_netvf_main.c | 13 ++++---------
.../ethernet/qlogic/qlcnic/qlcnic_83xx_hw.c | 5 +----
drivers/net/usb/r8152.c | 5 +----
drivers/net/wireless/ath/ath5k/phy.c | 12 +++---------
drivers/net/wireless/ath/ath9k/dfs.c | 5 +----
.../broadcom/brcm80211/brcmfmac/usb.c | 5 +----
.../broadcom/brcm80211/brcmsmac/phy/phy_n.c | 6 ++----
.../net/wireless/marvell/mwifiex/cfg80211.c | 6 ++----
.../net/wireless/microchip/wilc1000/wlan.c | 5 +----
.../wireless/realtek/rtlwifi/rtl8192ce/hw.c | 19 +++----------------
.../wireless/realtek/rtlwifi/rtl8192cu/hw.c | 17 +++--------------
.../wireless/realtek/rtlwifi/rtl8192ee/dm.c | 5 +----
.../wireless/realtek/rtlwifi/rtl8723ae/hw.c | 15 +++------------
.../wireless/realtek/rtlwifi/rtl8723be/dm.c | 5 +----
.../wireless/realtek/rtlwifi/rtl8821ae/dm.c | 5 +----
18 files changed, 31 insertions(+), 112 deletions(-)
--
2.34.1
^ permalink raw reply [flat|nested] 7+ messages in thread
* [PATCH 09/12] wifi: brcm80211: Use min() to improve code
2025-07-09 2:21 [PATCH 00/12] net: Use min()/max() to improve code Qianfeng Rong
@ 2025-07-09 2:21 ` Qianfeng Rong
2025-07-11 0:59 ` [PATCH 00/12] net: Use min()/max() " Jakub Kicinski
1 sibling, 0 replies; 7+ messages in thread
From: Qianfeng Rong @ 2025-07-09 2:21 UTC (permalink / raw)
To: Arend van Spriel, Wentao Liang, Johannes Berg, Kalle Valo,
Sai Krishna, Qianfeng Rong, Jacobe Zang, Dmitry Antipov,
open list:BROADCOM BRCM80211 IEEE802.11 WIRELESS DRIVERS,
open list:BROADCOM BRCM80211 IEEE802.11 WIRELESS DRIVERS,
open list:BROADCOM BRCM80211 IEEE802.11 WIRELESS DRIVERS,
open list
Use min() to reduce the code and improve its readability.
Signed-off-by: Qianfeng Rong <rongqianfeng@vivo.com>
---
drivers/net/wireless/broadcom/brcm80211/brcmfmac/usb.c | 5 +----
.../net/wireless/broadcom/brcm80211/brcmsmac/phy/phy_n.c | 6 ++----
2 files changed, 3 insertions(+), 8 deletions(-)
diff --git a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/usb.c b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/usb.c
index b056336d5da6..f0129d10d2b9 100644
--- a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/usb.c
+++ b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/usb.c
@@ -927,10 +927,7 @@ brcmf_usb_dl_writeimage(struct brcmf_usbdev_info *devinfo, u8 *fw, int fwlen)
/* Wait until the usb device reports it received all
* the bytes we sent */
if ((rdlbytes == sent) && (rdlbytes != dllen)) {
- if ((dllen-sent) < TRX_RDL_CHUNK)
- sendlen = dllen-sent;
- else
- sendlen = TRX_RDL_CHUNK;
+ sendlen = min(dllen - sent, TRX_RDL_CHUNK);
/* simply avoid having to send a ZLP by ensuring we
* never have an even
diff --git a/drivers/net/wireless/broadcom/brcm80211/brcmsmac/phy/phy_n.c b/drivers/net/wireless/broadcom/brcm80211/brcmsmac/phy/phy_n.c
index d362c4337616..cc406699e389 100644
--- a/drivers/net/wireless/broadcom/brcm80211/brcmsmac/phy/phy_n.c
+++ b/drivers/net/wireless/broadcom/brcm80211/brcmsmac/phy/phy_n.c
@@ -25825,10 +25825,8 @@ wlc_phy_cal_txiqlo_nphy(struct brcms_phy *pi, struct nphy_txgains target_gain,
if (mphase) {
cal_cnt = pi->mphase_txcal_cmdidx;
- if ((cal_cnt + pi->mphase_txcal_numcmds) < max_cal_cmds)
- num_cals = cal_cnt + pi->mphase_txcal_numcmds;
- else
- num_cals = max_cal_cmds;
+ num_cals = min(cal_cnt + pi->mphase_txcal_numcmds,
+ max_cal_cmds);
} else {
cal_cnt = 0;
num_cals = max_cal_cmds;
--
2.34.1
^ permalink raw reply related [flat|nested] 7+ messages in thread
* Re: [PATCH 00/12] net: Use min()/max() to improve code
2025-07-09 2:21 [PATCH 00/12] net: Use min()/max() to improve code Qianfeng Rong
2025-07-09 2:21 ` [PATCH 09/12] wifi: brcm80211: Use min() " Qianfeng Rong
@ 2025-07-11 0:59 ` Jakub Kicinski
2025-07-14 2:08 ` Qianfeng Rong
1 sibling, 1 reply; 7+ messages in thread
From: Jakub Kicinski @ 2025-07-11 0:59 UTC (permalink / raw)
To: Qianfeng Rong
Cc: Andrew Lunn, David S. Miller, Eric Dumazet, Paolo Abeni,
Potnuri Bharat Teja, Veerasenareddy Burru, Sathesh Edara,
Louis Peens, Shahed Shaikh, Manish Chopra,
maintainer:QLOGIC QLCNIC (1/10)Gb ETHERNET DRIVER, Jiri Slaby,
Nick Kossifidis, Luis Chamberlain,
Toke Høiland-Jørgensen, Arend van Spriel, Brian Norris,
Francesco Dolcini, Ajay Singh, Claudiu Beznea, Ping-Ke Shih,
Kees Cook, Gustavo A. R. Silva, Kory Maincent,
Aleksander Jan Bajkowski, Lucas Sanchez Sagrado, Philipp Hahn,
Eric Biggers, Hayes Wang, Wentao Liang, Johannes Berg,
Sai Krishna, Jacobe Zang, Dmitry Antipov, Kalle Valo,
Sascha Hauer, David Lin, Aditya Kumar Singh, Roopni Devanathan,
Dan Carpenter, Marek Vasut, Alexis Lothoré, Arnd Bergmann,
open list:CAVIUM LIQUIDIO NETWORK DRIVER, open list,
open list:NETRONOME ETHERNET DRIVERS,
open list:USB NETWORKING DRIVERS,
open list:ATHEROS ATH5K WIRELESS DRIVER,
open list:BROADCOM BRCM80211 IEEE802.11 WIRELESS DRIVERS,
open list:BROADCOM BRCM80211 IEEE802.11 WIRELESS DRIVERS
On Wed, 9 Jul 2025 10:21:28 +0800 Qianfeng Rong wrote:
> Use min() to reduce the code and improve its readability.
>
> No functional changes.
For net/ethernet/ this is not worth the churn, sorry.
^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: [PATCH 00/12] net: Use min()/max() to improve code
2025-07-11 0:59 ` [PATCH 00/12] net: Use min()/max() " Jakub Kicinski
@ 2025-07-14 2:08 ` Qianfeng Rong
0 siblings, 0 replies; 7+ messages in thread
From: Qianfeng Rong @ 2025-07-14 2:08 UTC (permalink / raw)
To: Jakub Kicinski
Cc: Andrew Lunn, David S. Miller, Eric Dumazet, Paolo Abeni,
Potnuri Bharat Teja, Veerasenareddy Burru, Sathesh Edara,
Louis Peens, Shahed Shaikh, Manish Chopra,
maintainer:QLOGIC QLCNIC (1/10)Gb ETHERNET DRIVER, Jiri Slaby,
Nick Kossifidis, Luis Chamberlain,
Toke Høiland-Jørgensen, Arend van Spriel, Brian Norris,
Francesco Dolcini, Ajay Singh, Claudiu Beznea, Ping-Ke Shih,
Kees Cook, Gustavo A. R. Silva, Kory Maincent,
Aleksander Jan Bajkowski, Lucas Sanchez Sagrado, Philipp Hahn,
Eric Biggers, Hayes Wang, Wentao Liang, Johannes Berg,
Sai Krishna, Jacobe Zang, Dmitry Antipov, Kalle Valo,
Sascha Hauer, David Lin, Aditya Kumar Singh, Roopni Devanathan,
Dan Carpenter, Marek Vasut, Alexis Lothoré, Arnd Bergmann,
open list:CAVIUM LIQUIDIO NETWORK DRIVER, open list,
open list:NETRONOME ETHERNET DRIVERS,
open list:USB NETWORKING DRIVERS,
open list:ATHEROS ATH5K WIRELESS DRIVER,
open list:BROADCOM BRCM80211 IEEE802.11 WIRELESS DRIVERS,
open list:BROADCOM BRCM80211 IEEE802.11 WIRELESS DRIVERS
在 2025/7/11 8:59, Jakub Kicinski 写道:
> On Wed, 9 Jul 2025 10:21:28 +0800 Qianfeng Rong wrote:
>> Use min() to reduce the code and improve its readability.
>>
>> No functional changes.
> For net/ethernet/ this is not worth the churn, sorry.
Never mind, thanks for your reply.
Best regards,
Qianfeng
^ permalink raw reply [flat|nested] 7+ messages in thread
end of thread, other threads:[~2025-07-14 2:08 UTC | newest]
Thread overview: 7+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-07-09 2:21 [PATCH 00/12] net: Use min()/max() to improve code Qianfeng Rong
2025-07-09 2:21 ` [PATCH 09/12] wifi: brcm80211: Use min() " Qianfeng Rong
2025-07-11 0:59 ` [PATCH 00/12] net: Use min()/max() " Jakub Kicinski
2025-07-14 2:08 ` Qianfeng Rong
-- strict thread matches above, loose matches on Subject: below --
2025-07-08 13:55 Qianfeng Rong
2025-07-08 14:12 ` Jakub Kicinski
2025-07-08 14:15 ` Qianfeng Rong
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox