From: Alex Elder <elder@inktank.com>
To: ceph-devel@vger.kernel.org
Subject: [PATCH 00/16] rbd: updates and enhancements
Date: Wed, 11 Jul 2012 08:49:48 -0500 [thread overview]
Message-ID: <4FFD847C.7070205@inktank.com> (raw)
The following series of patches constitute a few minor
fixes and cleanups, as well as some new utility routines
in the rbd code. Some of these comprise a foundation
that's being used to add support for the "new" rbd image
format.
We've agreed to refer to the "old" and "new" formats as
format 1 and 2, respectively.
-Alex
[PATCH 01/16] libceph: fix off-by-one bug in ceph_encode_filepath()
This is a minor bug fix.
[PATCH 02/16] rbd: drop a useless local variable
This is a minor cleanup.
[PATCH 03/16] libceph: define ceph_decode_string()
[PATCH 04/16] libceph: define ceph_extract_encoded_string()
[PATCH 05/16] rbd: define dup_token()
Each of these defines a new utility routine. They are
all going to be used in some upcoming rbd patches, but
they're ready for review now.
[PATCH 06/16] rbd: rename rbd_dev->block_name
[PATCH 07/16] rbd: dynamically allocate object prefix
These update the "block_name" field of a rbd_dev structure
to be named "object_prefix", which is consistent with the
way the new rbd format describes it. It also removes the
unnecessary fixed limit on the length of that string.
[PATCH 08/16] rbd: don't store pool name in struct rbd_dev
Since a pool name can change, this patch makes sure the
rbd client code doesn't save a copy of it--relying instead
on the invariant pool id. The "pool" entry has been
replaced by "pool_id" in /sys/bus/rbd/<N>.
[PATCH 09/16] rbd: dynamically allocate image header name
[PATCH 10/16] rbd: dynamically allocate image name
[PATCH 11/16] rbd: dynamically allocate snapshot name
These three change some more fields for in-core data
structures so they aren't arbitrarily limited to a fixed
size.
[PATCH 12/16] rbd: use rbd_dev consistently
This makes all variables representing a struct rbd_device
be named "rbd_dev".
[PATCH 13/16] rbd: rename some fields in struct rbd_dev
[PATCH 14/16] rbd: more symbol renames
[PATCH 15/16] rbd: option symbol renames
These change the names of some fields and symbols so
they are (hopefully) a bit more descriptive.
[PATCH 16/16] rbd: kill num_reply parameters
This eliminates an unused parameter that was defined in
a number of functions.
next reply other threads:[~2012-07-11 13:49 UTC|newest]
Thread overview: 69+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-07-11 13:49 Alex Elder [this message]
2012-07-11 14:00 ` [PATCH 01/16] libceph: fix off-by-one bug in ceph_encode_filepath() Alex Elder
2012-07-11 16:59 ` Yehuda Sadeh
2012-07-11 18:35 ` Josh Durgin
2012-07-11 14:00 ` [PATCH 02/16] rbd: drop a useless local variable Alex Elder
2012-07-11 16:58 ` Yehuda Sadeh Weinraub
2012-07-11 18:36 ` Josh Durgin
2012-07-11 14:00 ` [PATCH 03/16] libceph: define ceph_decode_string() Alex Elder
2012-07-11 17:13 ` Yehuda Sadeh
2012-07-11 18:43 ` Josh Durgin
2012-07-11 22:09 ` [PATCH v2 " Alex Elder
2012-07-12 17:13 ` Alex Elder
2012-07-11 14:01 ` [PATCH 04/16] libceph: define ceph_extract_encoded_string() Alex Elder
2012-07-11 17:20 ` Yehuda Sadeh
2012-07-11 17:45 ` Sage Weil
2012-07-11 19:14 ` Alex Elder
2012-07-11 19:26 ` Yehuda Sadeh
2012-07-11 22:10 ` [PATCH v2 " Alex Elder
2012-07-12 17:13 ` [PATCH v3 " Alex Elder
2012-07-12 18:20 ` Sage Weil
2012-07-12 19:48 ` Alex Elder
2012-07-12 22:47 ` Alex Elder
2012-07-12 22:47 ` [PATCH v4 " Alex Elder
2012-07-11 14:01 ` [PATCH 05/16] rbd: define dup_token() Alex Elder
2012-07-11 17:48 ` Yehuda Sadeh
2012-07-11 21:50 ` Alex Elder
2012-07-11 18:50 ` Josh Durgin
2012-07-11 14:01 ` [PATCH 06/16] rbd: rename rbd_dev->block_name Alex Elder
2012-07-11 17:55 ` Yehuda Sadeh
2012-07-11 19:02 ` Josh Durgin
2012-07-11 22:13 ` Alex Elder
2012-07-11 14:01 ` [PATCH 07/16] rbd: dynamically allocate object prefix Alex Elder
2012-07-11 19:12 ` Josh Durgin
2012-07-11 19:17 ` Alex Elder
2012-07-12 17:24 ` [PATCH v2 " Alex Elder
2012-07-12 17:42 ` Josh Durgin
2012-07-11 14:02 ` [PATCH 08/16] rbd: don't store pool name in struct rbd_dev Alex Elder
2012-07-11 19:36 ` Josh Durgin
2012-07-11 20:19 ` Sage Weil
2012-07-11 22:25 ` Alex Elder
2012-07-11 23:32 ` Josh Durgin
2012-07-12 2:59 ` Alex Elder
2012-07-12 4:19 ` Josh Durgin
2012-07-12 17:05 ` Alex Elder
2012-07-12 17:05 ` [PATCH] rbd: create pool_id device attribute Alex Elder
2012-07-12 17:16 ` Josh Durgin
2012-07-12 17:35 ` Alex Elder
2012-07-12 17:05 ` [PATCH] rbd: dynamically allocate pool name Alex Elder
2012-07-12 17:21 ` Josh Durgin
2012-07-11 14:02 ` [PATCH 09/16] rbd: dynamically allocate image header name Alex Elder
2012-07-11 20:41 ` Josh Durgin
2012-07-11 14:02 ` [PATCH 10/16] rbd: dynamically allocate image name Alex Elder
2012-07-11 20:49 ` Josh Durgin
2012-07-11 20:52 ` Josh Durgin
2012-07-12 11:12 ` Alex Elder
2012-07-11 14:02 ` [PATCH 11/16] rbd: dynamically allocate snapshot name Alex Elder
2012-07-11 20:53 ` Josh Durgin
2012-07-11 14:02 ` [PATCH 12/16] rbd: use rbd_dev consistently Alex Elder
2012-07-11 20:56 ` Josh Durgin
2012-07-11 14:02 ` [PATCH 13/16] rbd: rename some fields in struct rbd_dev Alex Elder
2012-07-11 21:01 ` Josh Durgin
2012-07-12 11:14 ` Alex Elder
2012-07-11 14:02 ` [PATCH 14/16] rbd: more symbol renames Alex Elder
2012-07-11 21:03 ` Josh Durgin
2012-07-12 11:15 ` Alex Elder
2012-07-11 14:03 ` [PATCH 15/16] rbd: option " Alex Elder
2012-07-11 21:07 ` Josh Durgin
2012-07-11 14:03 ` [PATCH 16/16] rbd: kill num_reply parameters Alex Elder
2012-07-11 21:07 ` Josh Durgin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4FFD847C.7070205@inktank.com \
--to=elder@inktank.com \
--cc=ceph-devel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox