DAMON development mailing list
 help / color / mirror / Atom feed
From: SJ Park <sj@kernel.org>
To: sashiko-bot@kernel.org
Cc: SJ Park <sj@kernel.org>, damon@lists.linux.dev
Subject: Re: [RFC PATCH v1.1 04/16] mm/damon/core: ask apply_probe() to return max probe hits weighted sum
Date: Mon,  6 Jul 2026 16:42:10 -0700	[thread overview]
Message-ID: <20260706234211.96517-1-sj@kernel.org> (raw)
In-Reply-To: <20260706143938.310BA1F000E9@smtp.kernel.org>

On Mon, 06 Jul 2026 14:39:37 +0000 sashiko-bot@kernel.org wrote:

> Thank you for your contribution! Sashiko AI review found 2 potential issue(s) to consider:
> 
> Pre-existing issues:
> - [High] Advancing physical addresses using `addr += folio_size(folio)` in large folio iteration paths skips memory when `addr` is not aligned to the start of the folio.
> - [High] Static local variables used for caching are shared across concurrent kernel threads without synchronization.
> --
> 
> commit 1ecdc723ec9bfdc97493a942107d11622114a694
> Author: SJ Park <sj@kernel.org>
> 
> mm/damon/core: ask apply_probe() to return max probe hits weighted sum
> 
> check_accesses() DAMON ops callback returns the maximum nr_accesses of
> regions.  DAMON core uses it to calculate a reasonable region merge
> threshold.  The core will need to adjust regions for not nr_accesses but
> probe hits weighted sum in future.  For that, the core needs to know the
> maximum weighted sum of the regions.  Update the protocol for the task.
> 
> > diff --git a/mm/damon/paddr.c b/mm/damon/paddr.c
> > index ff4fcca949660..3eba3564a31fc 100644
> > --- a/mm/damon/paddr.c
> > +++ b/mm/damon/paddr.c
> > @@ -166,7 +166,8 @@ static bool damon_pa_filter_pass(phys_addr_t pa, struct folio *folio,
> >  	return pass;
> >  }
> >  
> > -static void damon_pa_apply_probes(struct damon_ctx *ctx, bool set_samples)
> > +static unsigned int damon_pa_apply_probes(struct damon_ctx *ctx,
> > +		bool set_samples, bool return_max_wsum)
> >  {
> >  	struct damon_target *t;
> >  	struct damon_region *r;
> > @@ -194,6 +195,7 @@ static void damon_pa_apply_probes(struct damon_ctx *ctx, bool set_samples)
> >  				folio_put(folio);
> >  		}
> >  	}
> > +	return 0;
> >  }
> 
> [Severity: High]
> This isn't a bug introduced by this patch, but while reviewing the changes in
> mm/damon/paddr.c, I noticed that __damon_pa_check_access() declares static
> local variables for caching:
> 
> mm/damon/paddr.c:__damon_pa_check_access() {
> 	static phys_addr_t last_addr;
> 	static unsigned long last_folio_sz = PAGE_SIZE;
> 	static bool last_accessed;
> 	...
> }
> 
> Because DAMON allows multiple contexts to be created and run concurrently,
> each in its own kdamond thread, could these static variables be modified
> concurrently without locking? Does this data race risk corrupting the cache
> state and misapplying access results between different monitoring contexts?

Correct.  I'm separately working [1] on this.

> 
> [Severity: High]
> This is a pre-existing issue, but I also noticed a potential overshooting bug
> in multiple physical address iteration paths in mm/damon/paddr.c, such as in
> damon_pa_pageout():
> 
> mm/damon/paddr.c:damon_pa_pageout() {
> 	...
> 	addr += folio_size(folio);
> 	...
> }
> 
> If a region start address is not aligned to the size of the folio (for
> instance, starting in the middle of a 2MB THP), advancing the unaligned addr
> by the full folio size will overshoot the folio boundary. Could this silently
> skip valid physical memory that falls in the gap?
> 
> The same pattern appears to be used in damon_pa_de_activate(),
> damon_pa_migrate(), and damon_pa_stat().

correct.  I'm separately working [2] on this.

> 
> -- 
> Sashiko AI review · https://sashiko.dev/#/patchset/20260706141912.88445-1-sj@kernel.org?part=4

[1] https://lore.kernel.org/20260621204050.10993-1-sj@kernel.org
[2] https://lore.kernel.org/20260517234112.89245-1-sj@kernel.org

Thanks,
SJ

  reply	other threads:[~2026-07-06 23:42 UTC|newest]

Thread overview: 40+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-06 14:18 [RFC PATCH v1.1 00/16] mm/damon: introduce data attributes only monitoring SJ Park
2026-07-06 14:18 ` [RFC PATCH v1.1 01/16] mm/damon/core: introduce damon_probe->weight SJ Park
2026-07-06 14:18 ` [RFC PATCH v1.1 02/16] mm/damon/core: ask apply_probes() ops callback to set sampling address SJ Park
2026-07-06 14:18 ` [RFC PATCH v1.1 03/16] mm/damon/paddr: set samples in apply_probes() if requested SJ Park
2026-07-06 14:18 ` [RFC PATCH v1.1 04/16] mm/damon/core: ask apply_probe() to return max probe hits weighted sum SJ Park
2026-07-06 14:39   ` sashiko-bot
2026-07-06 23:42     ` SJ Park [this message]
2026-07-06 14:18 ` [RFC PATCH v1.1 05/16] mm/damon/core: implement damon_probe_hits_wsum() SJ Park
2026-07-06 14:41   ` sashiko-bot
2026-07-06 23:46     ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 06/16] mm/damon/paddr: respect return_max_wsum SJ Park
2026-07-06 14:44   ` sashiko-bot
2026-07-06 23:47     ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 07/16] mm/damon/core: extend merge function to work with probe hits SJ Park
2026-07-06 14:55   ` sashiko-bot
2026-07-06 23:52     ` SJ Park
2026-07-07  3:30       ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 08/16] mm/damon/core: disable access monitoring when probe weights are set SJ Park
2026-07-06 15:03   ` sashiko-bot
2026-07-06 23:54     ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 09/16] mm/damon/core: set samples in apply_probes() if " SJ Park
2026-07-06 15:02   ` sashiko-bot
2026-07-06 23:56     ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 10/16] mm/damon/core: s/max_nr_accesses/max_merge_score/ in kdamond_fn() SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 11/16] mm/damon/core: get merge threshold from probe hits when weights are set SJ Park
2026-07-06 15:18   ` sashiko-bot
2026-07-07  0:03     ` SJ Park
2026-07-07  3:34       ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 12/16] mm/damon/core: implement damon_has_probe_weight() SJ Park
2026-07-06 15:16   ` sashiko-bot
2026-07-07  0:05     ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 13/16] mm/damon/sysfs: implement probe/weight file SJ Park
2026-07-06 15:19   ` sashiko-bot
2026-07-07  0:08     ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 14/16] Docs/mm/damon/design: document attrs-only monitoring SJ Park
2026-07-06 15:34   ` sashiko-bot
2026-07-07  0:11     ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 15/16] Docs/admin-guide/mm/damon/usage: document weight sysfs file SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 16/16] Docs/ABI/damon: document probe weight file SJ Park
2026-07-07  0:13 ` [RFC PATCH v1.1 00/16] mm/damon: introduce data attributes only monitoring SJ Park

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260706234211.96517-1-sj@kernel.org \
    --to=sj@kernel.org \
    --cc=damon@lists.linux.dev \
    --cc=sashiko-bot@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox