From: SJ Park <sj@kernel.org>
To: sashiko-bot@kernel.org
Cc: SJ Park <sj@kernel.org>, damon@lists.linux.dev
Subject: Re: [RFC PATCH v1.1 05/16] mm/damon/core: implement damon_probe_hits_wsum()
Date: Mon, 6 Jul 2026 16:46:43 -0700 [thread overview]
Message-ID: <20260706234645.96802-1-sj@kernel.org> (raw)
In-Reply-To: <20260706144135.1573D1F000E9@smtp.kernel.org>
On Mon, 06 Jul 2026 14:41:34 +0000 sashiko-bot@kernel.org wrote:
> Thank you for your contribution! Sashiko AI review found 3 potential issue(s) to consider:
>
> New issues:
> - [High] The calculation of the weighted sum in `damon_probe_hits_wsum()` is vulnerable to integer overflow, resulting in a silent wrap-around.
> - [Low] Misspelled words in the kernel-doc comment for `damon_probe_hits_wsum`.
>
> Pre-existing issues:
> - [High] `r->probe_hits[i]` is an 8-bit `unsigned char` but serves as a sample counter across an aggregation interval, making it highly susceptible to wrap-around.
> --
>
> commit 627b12cd883dbd832e93cc6b4f4e3373c791b6d0
> Author: SJ Park <sj@kernel.org>
>
> mm/damon/core: implement damon_probe_hits_wsum()
>
> This commit implements damon_probe_hits_wsum() to calculate the weighted
> sum of probe hits for a DAMON region. This weighted sum is intended to be
> used by users as well as DAMON internal logic like region merging.
>
> [ ... ]
>
> > diff --git a/mm/damon/core.c b/mm/damon/core.c
> > index dbd1f86a0832f..42f27849af722 100644
> > --- a/mm/damon/core.c
> > +++ b/mm/damon/core.c
> > @@ -390,6 +390,30 @@ static bool damon_is_last_region(struct damon_region *r,
> > return list_is_last(&r->list, &t->regions_list);
> > }
> >
> > +/**
> > + * damon_probe_hits_wsum() - Returns probe hits weighted sum of a region.
> > + * @r: region to get the weigted sum of.
> > + * @last: if the request is for last-window agggregated probe hits.
>
> [Severity: Low]
> This isn't a bug, but there are spelling errors in this kernel-doc block.
>
> "weigted" should be "weighted" and "agggregated" should be "aggregated".
Good finding, I will fix these in the next spin.
>
> > + * @ctx: context of &r.
> > + *
> > + * Return: the weighted sum of probe hits of the region.
> > + */
> > +unsigned int damon_probe_hits_wsum(struct damon_region *r, bool last,
> > + struct damon_ctx *ctx)
> > +{
> > + struct damon_probe *probe;
> > + unsigned int sum = 0;
> > + int i = 0;
> > +
> > + damon_for_each_probe(probe, ctx) {
> > + if (last)
> > + sum += r->last_probe_hits[i++] * probe->weight;
> > + else
> > + sum += r->probe_hits[i++] * probe->weight;
>
> [Severity: High]
> Can the accumulation into sum silently overflow?
>
> If a large probe weight is configured via sysfs (e.g., > 16,843,009), the
> multiplication of this 32-bit unsigned int weight by r->probe_hits[i] could
> wrap around when accumulated into sum.
>
> This might corrupt the DAMON region merge and split logic that relies on this
> score.
Yes, it can. But it causes only poor monitoring results for wrong user setup.
Maybe we can improve it, but not necessarily right now. No blocker.
>
> [Severity: High]
> This is a pre-existing issue, but can r->probe_hits[i] wrap around during long
> aggregation intervals?
>
> The probe_hits array is defined as an 8-bit unsigned char. If the user
> configures aggr_interval and sample_interval such that their ratio exceeds 255
> (for example, 1s aggregation and 1ms sample), the counter will silently wrap
> around to 0 without any bounds checking.
>
> This could severely degrade the accuracy of DAMON's monitoring, and is
> exacerbated here by relying on the potentially corrupted counter for the new
> weighted sum logic.
Known low priority issue. No blocker.
>
> > + }
> > + return sum;
> > +}
>
> --
> Sashiko AI review · https://sashiko.dev/#/patchset/20260706141912.88445-1-sj@kernel.org?part=5
Thanks,
SJ
next prev parent reply other threads:[~2026-07-06 23:46 UTC|newest]
Thread overview: 40+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-06 14:18 [RFC PATCH v1.1 00/16] mm/damon: introduce data attributes only monitoring SJ Park
2026-07-06 14:18 ` [RFC PATCH v1.1 01/16] mm/damon/core: introduce damon_probe->weight SJ Park
2026-07-06 14:18 ` [RFC PATCH v1.1 02/16] mm/damon/core: ask apply_probes() ops callback to set sampling address SJ Park
2026-07-06 14:18 ` [RFC PATCH v1.1 03/16] mm/damon/paddr: set samples in apply_probes() if requested SJ Park
2026-07-06 14:18 ` [RFC PATCH v1.1 04/16] mm/damon/core: ask apply_probe() to return max probe hits weighted sum SJ Park
2026-07-06 14:39 ` sashiko-bot
2026-07-06 23:42 ` SJ Park
2026-07-06 14:18 ` [RFC PATCH v1.1 05/16] mm/damon/core: implement damon_probe_hits_wsum() SJ Park
2026-07-06 14:41 ` sashiko-bot
2026-07-06 23:46 ` SJ Park [this message]
2026-07-06 14:19 ` [RFC PATCH v1.1 06/16] mm/damon/paddr: respect return_max_wsum SJ Park
2026-07-06 14:44 ` sashiko-bot
2026-07-06 23:47 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 07/16] mm/damon/core: extend merge function to work with probe hits SJ Park
2026-07-06 14:55 ` sashiko-bot
2026-07-06 23:52 ` SJ Park
2026-07-07 3:30 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 08/16] mm/damon/core: disable access monitoring when probe weights are set SJ Park
2026-07-06 15:03 ` sashiko-bot
2026-07-06 23:54 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 09/16] mm/damon/core: set samples in apply_probes() if " SJ Park
2026-07-06 15:02 ` sashiko-bot
2026-07-06 23:56 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 10/16] mm/damon/core: s/max_nr_accesses/max_merge_score/ in kdamond_fn() SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 11/16] mm/damon/core: get merge threshold from probe hits when weights are set SJ Park
2026-07-06 15:18 ` sashiko-bot
2026-07-07 0:03 ` SJ Park
2026-07-07 3:34 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 12/16] mm/damon/core: implement damon_has_probe_weight() SJ Park
2026-07-06 15:16 ` sashiko-bot
2026-07-07 0:05 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 13/16] mm/damon/sysfs: implement probe/weight file SJ Park
2026-07-06 15:19 ` sashiko-bot
2026-07-07 0:08 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 14/16] Docs/mm/damon/design: document attrs-only monitoring SJ Park
2026-07-06 15:34 ` sashiko-bot
2026-07-07 0:11 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 15/16] Docs/admin-guide/mm/damon/usage: document weight sysfs file SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 16/16] Docs/ABI/damon: document probe weight file SJ Park
2026-07-07 0:13 ` [RFC PATCH v1.1 00/16] mm/damon: introduce data attributes only monitoring SJ Park
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260706234645.96802-1-sj@kernel.org \
--to=sj@kernel.org \
--cc=damon@lists.linux.dev \
--cc=sashiko-bot@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox