DAMON development mailing list
 help / color / mirror / Atom feed
From: SJ Park <sj@kernel.org>
To: sashiko-bot@kernel.org
Cc: SJ Park <sj@kernel.org>, damon@lists.linux.dev
Subject: Re: [PATCH 1/7] mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM
Date: Thu, 10 Sep 2026 07:32:52 -0700	[thread overview]
Message-ID: <20260910143254.173561-1-sj@kernel.org> (raw)
In-Reply-To: <20260910142717.916D11F00893@smtp.kernel.org>

On Thu, 10 Sep 2026 14:27:17 +0000 sashiko-bot@kernel.org wrote:

> Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
> - [Low] The kerneldoc comment for `enum damos_filter_type` leaves the handling behavior of `DAMOS_FILTER_TYPE_PROBE_HITS_WSUM` unexplained and contradictory.
> --
> 
> commit 78a988db300660b08e965cf2117e7ad015861252
> Author: SJ Park <sj@kernel.org>
> Subject: mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM
> 
> This commit introduces the DAMOS_FILTER_TYPE_PROBE_HITS_WSUM filter type
> to allow API callers to target regions based on their probe_hits weighted
> sum. It also updates the damos_filter structure and associated
> documentation to accommodate this new filter.
> 
> > diff --git a/include/linux/damon.h b/include/linux/damon.h
> > index 871d26adf6ae5..ef99ff778ae10 100644
> > --- a/include/linux/damon.h
> > +++ b/include/linux/damon.h
> > @@ -399,14 +399,15 @@ struct damos_stat {
> >   * @DAMOS_FILTER_TYPE_UNMAPPED:	Unmapped pages.
> >   * @DAMOS_FILTER_TYPE_ADDR:	Address range.
> >   * @DAMOS_FILTER_TYPE_TARGET:	Data Access Monitoring target.
> > + * @DAMOS_FILTER_TYPE_PROBE_HITS_WSUM:	probe_hits weighted sum range.
> >   * @NR_DAMOS_FILTER_TYPES:	Number of filter types.
> >   *
> > - * All types except &DAMOS_FILTER_TYPE_ADDR and &DAMOS_FILTER_TYPE_TARGET
> > - * are handled by the underlying &struct damon_operations as a part of scheme
> > - * action trying, and therefore accounted as 'tried'.  In contrast,
> > - * &DAMOS_FILTER_TYPE_ADDR and &DAMOS_FILTER_TYPE_TARGET filters are handled
> > - * by the core layer before trying of the action, and therefore not accounted
> > - * as 'tried'.
> > + * All types except &DAMOS_FILTER_TYPE_ADDR, &DAMOS_FILTER_TYPE_TARGET and
> > + * &DAMOS_FILTER_TYPE_PROBE_HITS_WSUM are handled by the underlying &struct
> > + * damon_operations as a part of scheme action trying, and therefore accounted
> > + * as 'tried'.  In contrast, &DAMOS_FILTER_TYPE_ADDR and
> > + * &DAMOS_FILTER_TYPE_TARGET filters are handled by the core layer before
> > + * trying of the action, and therefore not accounted as 'tried'.
> 
> [Severity: Low]
> Does this leave the handling behavior of the new filter unexplained?
> 
> The newly updated kerneldoc for enum damos_filter_type explicitly excludes
> DAMOS_FILTER_TYPE_PROBE_HITS_WSUM from the list of filters handled by
> operations, but it appears to be missing from the subsequent sentence
> detailing which filters are handled by the core layer. 
> 
> This creates a contradiction where its handling behavior is undefined. Should
> it be added to the second sentence alongside DAMOS_FILTER_TYPE_ADDR and
> DAMOS_FILTER_TYPE_TARGET?

That's described in the design document.  Maybe we could add more documentation
including reference to the design document.  That could be done as a followup
rather than blocking this patch.

> 
> -- 
> Sashiko AI review · https://sashiko.dev/#/patchset/20260910141849.170896-1-sj@kernel.org?part=1


Thanks,
SJ

  reply	other threads:[~2026-09-10 14:33 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-10 14:18 [PATCH 0/7] mm/damon: introduce probe_hits_wsum DAMOS core filter SJ Park
2026-09-10 14:18 ` [PATCH 1/7] mm/damon/api: introduce DAMOS_FILTER_TYPE_PROBE_HITS_WSUM SJ Park
2026-09-10 14:27   ` sashiko-bot
2026-09-10 14:32     ` SJ Park [this message]
2026-09-10 14:18 ` [PATCH 2/7] mm/damon/core: extend probe_hits_wsum() for moving sum based calculation SJ Park
2026-09-10 14:24   ` sashiko-bot
2026-09-10 14:18 ` [PATCH 3/7] mm/damon/core: support probe_hits_wsum damos core filter SJ Park
2026-09-10 14:26   ` sashiko-bot
2026-09-10 14:34     ` SJ Park
2026-09-10 14:18 ` [PATCH 4/7] mm/damon/sysfs-schemes: rename sysfs_filter->sz_range to range_{min,max} SJ Park
2026-09-10 14:27   ` sashiko-bot
2026-09-10 14:18 ` [PATCH 5/7] mm/damon/sysfs-schemes: support probe_hits_wsum damos core filter SJ Park
2026-09-10 14:30   ` sashiko-bot
2026-09-10 14:38     ` SJ Park
2026-09-10 14:18 ` [PATCH 6/7] Docs/mm/damon/design: update for probe_hits_wsum DAMOS " SJ Park
2026-09-10 14:24   ` sashiko-bot
2026-09-10 14:18 ` [PATCH 7/7] Docs/admin-guide/mm/damon/usage: update for probe_hits_wsum DAMOS filter SJ Park
2026-09-10 14:28   ` sashiko-bot
2026-09-10 14:40 ` [PATCH 0/7] mm/damon: introduce probe_hits_wsum DAMOS core filter SJ Park

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260910143254.173561-1-sj@kernel.org \
    --to=sj@kernel.org \
    --cc=damon@lists.linux.dev \
    --cc=sashiko-bot@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox