dm-devel.redhat.com archive mirror
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@infradead.org>
To: Mike Snitzer <snitzer@redhat.com>
Cc: linux-block@vger.kernel.org, dm-devel@redhat.com
Subject: Re: [dm-devel] [PATCH 07/14] dm: remove code only needed before submit_bio recursion
Date: Thu, 10 Feb 2022 22:56:01 -0800	[thread overview]
Message-ID: <YgYIgZCMfJ5mgA9t@infradead.org> (raw)
In-Reply-To: <20220210223832.99412-8-snitzer@redhat.com>

>  static void alloc_multiple_bios(struct bio_list *blist, struct clone_info *ci,
>  				struct dm_target *ti, unsigned num_bios,
>  				unsigned *len)
> @@ -1224,14 +1218,14 @@ static void __send_duplicate_bios(struct clone_info *ci, struct dm_target *ti,
>  	case 1:
>  		clone = alloc_tio(ci, ti, 0, len, GFP_NOIO);
>  		if (len)
> -			bio_setup_sector(clone, ci->sector, *len);
> +			clone->bi_iter.bi_size = to_bytes(*len);
>  		__map_bio(clone);
>  		break;
>  	default:
>  		alloc_multiple_bios(&blist, ci, ti, num_bios, len);
>  		while ((clone = bio_list_pop(&blist))) {
>  			if (len)
> -				bio_setup_sector(clone, ci->sector, *len);
> +				clone->bi_iter.bi_size = to_bytes(*len);
>  			__map_bio(clone);
>  		}
>  		break;
> @@ -1350,7 +1344,6 @@ static int __split_and_process_bio(struct clone_info *ci)
>  	len = min_t(sector_t, max_io_len(ti, ci->sector), ci->sector_count);
>  
>  	clone = alloc_tio(ci, ti, 0, &len, GFP_NOIO);
> -	bio_advance(clone, to_bytes(ci->sector - clone->bi_iter.bi_sector));
>  	clone->bi_iter.bi_size = to_bytes(len);

Maybe move the clone->bi_iter.bi_size assignment into alloc_tio as well?

Otherwise looks good:

Reviewed-by: Christoph Hellwig <hch@lst.de>

--
dm-devel mailing list
dm-devel@redhat.com
https://listman.redhat.com/mailman/listinfo/dm-devel


  reply	other threads:[~2022-02-11  6:57 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-02-10 22:38 [dm-devel] [PATCH 00/14] dm: improve bio-based IO accounting Mike Snitzer
2022-02-10 22:38 ` [dm-devel] [PATCH 01/14] dm: rename split functions Mike Snitzer
2022-02-11  6:48   ` Christoph Hellwig
2022-02-10 22:38 ` [dm-devel] [PATCH 02/14] dm: fold __clone_and_map_data_bio into __split_and_process_bio Mike Snitzer
2022-02-11  6:48   ` Christoph Hellwig
2022-02-10 22:38 ` [dm-devel] [PATCH 03/14] dm: refactor dm_split_and_process_bio a bit Mike Snitzer
2022-02-11  6:52   ` Christoph Hellwig
2022-02-10 22:38 ` [dm-devel] [PATCH 04/14] dm: reduce code duplication in __map_bio Mike Snitzer
2022-02-11  6:52   ` Christoph Hellwig
2022-02-10 22:38 ` [dm-devel] [PATCH 05/14] dm: remove impossible BUG_ON in __send_empty_flush Mike Snitzer
2022-02-11  6:53   ` Christoph Hellwig
2022-02-10 22:38 ` [dm-devel] [PATCH 06/14] dm: remove unused mapped_device argument from free_tio Mike Snitzer
2022-02-11  6:53   ` Christoph Hellwig
2022-02-10 22:38 ` [dm-devel] [PATCH 07/14] dm: remove code only needed before submit_bio recursion Mike Snitzer
2022-02-11  6:56   ` Christoph Hellwig [this message]
2022-02-10 22:38 ` [dm-devel] [PATCH 08/14] dm: record old_sector in dm_target_io before calling map function Mike Snitzer
2022-02-11  6:56   ` Christoph Hellwig
2022-02-10 22:38 ` [dm-devel] [PATCH 09/14] dm: prep for following changes Mike Snitzer
2022-02-11  6:57   ` Christoph Hellwig
2022-02-10 22:38 ` [dm-devel] [PATCH 10/14] dm: add dm_submit_bio_remap interface Mike Snitzer
2022-02-10 22:38 ` [dm-devel] [PATCH 11/14] dm crypt: use dm_submit_bio_remap Mike Snitzer
2022-02-10 22:38 ` [dm-devel] [PATCH 12/14] dm delay: dm_submit_bio_remap Mike Snitzer
2022-02-10 22:38 ` [dm-devel] [PATCH 13/14] dm: improve correctness and efficiency of bio-based IO accounting Mike Snitzer
2022-02-10 22:38 ` [dm-devel] [PATCH 14/14] block: add bio_start_io_acct_remapped for the benefit of DM Mike Snitzer
2022-02-11  7:07   ` Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YgYIgZCMfJ5mgA9t@infradead.org \
    --to=hch@infradead.org \
    --cc=dm-devel@redhat.com \
    --cc=linux-block@vger.kernel.org \
    --cc=snitzer@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).