From: Thomas Monjalon <thomas@monjalon.net>
To: Lukasz Wojciechowski <l.wojciechow@partner.samsung.com>,
Akhil Goyal <akhil.goyal@nxp.com>
Cc: "declan.doherty@intel.com" <declan.doherty@intel.com>, dev@dpdk.org
Subject: Re: [dpdk-dev] [PATCH 05/13] app/test: introduce librte_security tests
Date: Wed, 01 Apr 2020 19:51:10 +0200 [thread overview]
Message-ID: <1703484.4MS8fQxZnU@xps> (raw)
In-Reply-To: <DB8PR04MB6635E11FBFFDADD7537D8802E6C90@DB8PR04MB6635.eurprd04.prod.outlook.com>
01/04/2020 19:09, Akhil Goyal:
> Hi Lukasz,
>
> > This patch introduces set of unit tests of librte_security API functions.
> > Tests are added to dpdk-test application and can be run with
> > "security_autotest" runtime command.
> >
> > This is the first patch in the series of patches as adding all test cases
> > for all API functions in a single patch would make it unreadable.
> >
> > This patch defines structure of the file and necessary test framework
> > initialization. It also contains first subset of unit tests for
> > rte_security_session_create API function.
> >
> > Structure of the tests file is following:
> > - macros for making tests more readable;
> > - mockup structures and functions for rte_security_ops;
> > - test suite and test cases setup and teardown functions;
> > - tests functions;
> > - declaration of testcases.
> >
> > Signed-off-by: Lukasz Wojciechowski <l.wojciechow@partner.samsung.com>
> > Change-Id: I3a4585f56ef1a75b2984fcea3a3e4a30e4c2d8a6
> > ---
>
> This patchset has a lot of repeated(for each API) tests just to check the input parameters to
> Rte_security APIs. I am not sure what value addition is done to separate out each API as a separate
> Negative Test. Instead a single case can be added to test all APIs with inappropriate arguments.
> We should add more positive cases with proper session parameters.
>
> Thomas,
> Do we allow these type of test cases in other modules?
I did not review these patches, but I think we can try to compare
with tests done on eventdev library.
It would be interesting to have an opinion from Declan.
These rte_security tests look quite big.
However I don't know what is too big for test code?
Lukasz, please could you explain the initial motivation when writing
these tests? Are you especially interested in rte_security?
Or do you plan to reproduce this effort on other libraries?
next prev parent reply other threads:[~2020-04-01 17:51 UTC|newest]
Thread overview: 80+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <CGME20200312151708eucas1p2a80bb2ac0556c7d7efb3aedd83923e52@eucas1p2.samsung.com>
2020-03-12 15:16 ` [dpdk-dev] [PATCH 00/13] Fixes and unit tests for librte_security Lukasz Wojciechowski
2020-03-12 15:16 ` [dpdk-dev] [PATCH 01/13] librte_security: fix verification of parameters Lukasz Wojciechowski
2020-03-17 12:59 ` Anoob Joseph
2020-04-03 18:36 ` Lukasz Wojciechowski
2020-04-05 12:54 ` [dpdk-dev] [EXT] " Anoob Joseph
2020-04-06 18:49 ` Lukasz Wojciechowski
2020-04-07 6:20 ` Anoob Joseph
2020-04-08 3:25 ` Lukasz Wojciechowski
2020-03-12 15:16 ` [dpdk-dev] [PATCH 02/13] librte_security: fix return types in documentation Lukasz Wojciechowski
2020-03-17 16:34 ` Anoob Joseph
2020-03-12 15:16 ` [dpdk-dev] [PATCH 03/13] librte_security: fix session counter Lukasz Wojciechowski
2020-03-17 17:08 ` Anoob Joseph
2020-03-12 15:16 ` [dpdk-dev] [PATCH 04/13] app/test: fix macro definition Lukasz Wojciechowski
2020-03-12 15:16 ` [dpdk-dev] [PATCH 05/13] app/test: introduce librte_security tests Lukasz Wojciechowski
2020-04-01 17:09 ` Akhil Goyal
2020-04-01 17:51 ` Thomas Monjalon [this message]
2020-04-02 19:49 ` Lukasz Wojciechowski
2020-04-02 20:51 ` Thomas Monjalon
2020-04-03 19:24 ` Lukasz Wojciechowski
2020-03-12 15:16 ` [dpdk-dev] [PATCH 06/13] app/test: add rte_security_session_update tests Lukasz Wojciechowski
2020-03-12 15:16 ` [dpdk-dev] [PATCH 07/13] app/test: add rte_security_session_get_size tests Lukasz Wojciechowski
2020-03-12 15:16 ` [dpdk-dev] [PATCH 08/13] app/test: add rte_security_session_stats_get tests Lukasz Wojciechowski
2020-03-12 15:16 ` [dpdk-dev] [PATCH 09/13] app/test: add rte_security_session_destroy tests Lukasz Wojciechowski
2020-03-12 15:16 ` [dpdk-dev] [PATCH 10/13] app/test: add rte_security_set_pkt_metadata tests Lukasz Wojciechowski
2020-03-12 15:16 ` [dpdk-dev] [PATCH 11/13] app/test: add rte_security_get_userdata tests Lukasz Wojciechowski
2020-03-12 15:16 ` [dpdk-dev] [PATCH 12/13] app/test: add rte_security_capabilities_get tests Lukasz Wojciechowski
2020-03-12 15:16 ` [dpdk-dev] [PATCH 13/13] app/test: add rte_security_capability_get tests Lukasz Wojciechowski
2020-04-08 3:13 ` [dpdk-dev] [PATCH v2 00/13] Fixes and unit tests for librte_security Lukasz Wojciechowski
2020-04-08 3:13 ` [dpdk-dev] [PATCH v2 01/13] security: fix verification of parameters Lukasz Wojciechowski
2020-04-08 12:54 ` Thomas Monjalon
2020-04-08 13:02 ` Anoob Joseph
2020-04-08 13:26 ` Thomas Monjalon
2020-04-08 14:44 ` [dpdk-dev] [EXT] " Anoob Joseph
2020-04-08 15:49 ` Lukasz Wojciechowski
2020-04-08 17:51 ` Thomas Monjalon
2020-04-09 10:14 ` Bruce Richardson
2020-04-09 10:54 ` Thomas Monjalon
2020-04-09 11:13 ` Bruce Richardson
2020-04-09 14:07 ` Lukasz Wojciechowski
2020-04-09 14:21 ` Lukasz Wojciechowski
2020-04-09 15:22 ` Thomas Monjalon
2020-04-09 16:10 ` Lukasz Wojciechowski
2020-04-10 8:45 ` Bruce Richardson
2020-04-08 3:13 ` [dpdk-dev] [PATCH v2 02/13] security: fix return types in documentation Lukasz Wojciechowski
2020-04-08 3:13 ` [dpdk-dev] [PATCH v2 03/13] security: fix session counter Lukasz Wojciechowski
2020-04-08 3:13 ` [dpdk-dev] [PATCH v2 04/13] app/test: fix macro definition Lukasz Wojciechowski
2020-04-08 12:53 ` Thomas Monjalon
2020-04-08 16:15 ` Lukasz Wojciechowski
2020-04-08 17:47 ` Thomas Monjalon
2020-04-09 14:10 ` Lukasz Wojciechowski
2020-04-08 3:13 ` [dpdk-dev] [PATCH v2 05/13] app/test: introduce librte security tests Lukasz Wojciechowski
2020-04-08 3:13 ` [dpdk-dev] [PATCH v2 06/13] app/test: add rte security session update tests Lukasz Wojciechowski
2020-04-08 3:13 ` [dpdk-dev] [PATCH v2 07/13] app/test: add rte security session get size tests Lukasz Wojciechowski
2020-04-08 3:13 ` [dpdk-dev] [PATCH v2 08/13] app/test: add rte security session stats get tests Lukasz Wojciechowski
2020-04-08 3:13 ` [dpdk-dev] [PATCH v2 09/13] app/test: add rte security session destroy tests Lukasz Wojciechowski
2020-04-08 3:13 ` [dpdk-dev] [PATCH v2 10/13] app/test: add rte security set pkt metadata tests Lukasz Wojciechowski
2020-04-08 3:13 ` [dpdk-dev] [PATCH v2 11/13] app/test: add rte security get userdata tests Lukasz Wojciechowski
2020-04-08 3:13 ` [dpdk-dev] [PATCH v2 12/13] app/test: add rte security capabilities get tests Lukasz Wojciechowski
2020-04-08 3:13 ` [dpdk-dev] [PATCH v2 13/13] app/test: add rte security capability " Lukasz Wojciechowski
2020-04-09 17:24 ` [dpdk-dev] [PATCH v3 00/13] Fixes and unit tests for librte_security Lukasz Wojciechowski
2020-04-09 17:24 ` [dpdk-dev] [PATCH v3 01/13] security: fix verification of parameters Lukasz Wojciechowski
2020-04-13 15:42 ` Anoob Joseph
2020-04-09 17:24 ` [dpdk-dev] [PATCH v3 02/13] security: fix return types in documentation Lukasz Wojciechowski
2020-04-13 15:43 ` Anoob Joseph
2020-04-09 17:24 ` [dpdk-dev] [PATCH v3 03/13] security: fix session counter Lukasz Wojciechowski
2020-04-13 15:48 ` Anoob Joseph
2020-04-09 17:24 ` [dpdk-dev] [PATCH v3 04/13] app/test: remove macro definition Lukasz Wojciechowski
2020-04-09 17:24 ` [dpdk-dev] [PATCH v3 05/13] app/test: introduce librte security tests Lukasz Wojciechowski
2020-04-09 17:24 ` [dpdk-dev] [PATCH v3 06/13] app/test: add rte security session update tests Lukasz Wojciechowski
2020-04-09 17:24 ` [dpdk-dev] [PATCH v3 07/13] app/test: add rte security session get size tests Lukasz Wojciechowski
2020-04-09 17:24 ` [dpdk-dev] [PATCH v3 08/13] app/test: add rte security session stats get tests Lukasz Wojciechowski
2020-04-09 17:24 ` [dpdk-dev] [PATCH v3 09/13] app/test: add rte security session destroy tests Lukasz Wojciechowski
2020-04-09 17:24 ` [dpdk-dev] [PATCH v3 10/13] app/test: add rte security set pkt metadata tests Lukasz Wojciechowski
2020-04-09 17:25 ` [dpdk-dev] [PATCH v3 11/13] app/test: add rte security get userdata tests Lukasz Wojciechowski
2020-04-09 17:25 ` [dpdk-dev] [PATCH v3 12/13] app/test: add rte security capabilities get tests Lukasz Wojciechowski
2020-04-09 17:25 ` [dpdk-dev] [PATCH v3 13/13] app/test: add rte security capability " Lukasz Wojciechowski
2020-04-17 19:46 ` [dpdk-dev] [PATCH v3 00/13] Fixes and unit tests for librte_security Akhil Goyal
2020-04-17 20:14 ` Lukasz Wojciechowski
2020-04-17 20:21 ` Akhil Goyal
2020-04-17 20:39 ` Lukasz Wojciechowski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1703484.4MS8fQxZnU@xps \
--to=thomas@monjalon.net \
--cc=akhil.goyal@nxp.com \
--cc=declan.doherty@intel.com \
--cc=dev@dpdk.org \
--cc=l.wojciechow@partner.samsung.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox