From: j.glisse@gmail.com
To: dri-devel@lists.freedesktop.org
Cc: thellstrom@vmware.com
Subject: [RFC] ttm merge ttm_backend & ttm_t V2
Date: Wed, 2 Nov 2011 19:37:47 -0400 [thread overview]
Message-ID: <1320277075-19980-1-git-send-email-j.glisse@gmail.com> (raw)
Hi,
So attached is last batch of patch, i split the ttm put page
fix and i fixed a bug in the pages alloc when clear flags
wasn't set. I tested them on a bunch of radeon and everythings
seems fine (several gl app, firefox, compositor ...). I will
do more testing on agp and nouveau tomorrow.
The last patch add callback for populating and unpopulating
(better name if any welcome) a ttm_tt. Allowing the driver
to choose btw different choice, idea is that Konrad dma
allocator would provide helper function the driver can
call.
I choosed to allocate all page at once because ttm_tt object
are meant to be bind and thus to be fully populated in their
lifetime (vmwgfx might be different in this regard). It
simplify code in several place. I didn't see any performances
impact in the few gl benchmark i ran.
Konrad so i am planning on rebasing the last 4 patch of your
patchset on top of that. They will likely shrink in size a
bit.
Cheers,
Jerome Glisse
next reply other threads:[~2011-11-02 23:33 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-11-02 23:37 j.glisse [this message]
2011-11-02 23:37 ` [PATCH 1/8] drm/ttm: remove userspace backed ttm object support j.glisse
2011-11-02 23:37 ` [PATCH 2/8] drm/ttm: remove split btw highmen and lowmem page j.glisse
2011-11-02 23:37 ` [PATCH 3/8] drm/ttm: remove unused backend flags field j.glisse
2011-11-02 23:37 ` [PATCH 4/8] drm/ttm: use ttm put pages function to properly restore cache attribute j.glisse
2011-11-03 18:35 ` Konrad Rzeszutek Wilk
2011-11-02 23:37 ` [PATCH 5/8] drm/ttm: convert page allocation to use page ptr array instead of list V2 j.glisse
2011-11-03 18:45 ` Konrad Rzeszutek Wilk
2011-11-02 23:37 ` [PATCH 6/8] drm/ttm: test for dma_address array allocation failure j.glisse
2011-11-03 18:45 ` Konrad Rzeszutek Wilk
2011-11-02 23:37 ` [PATCH 7/8] drm/ttm: merge ttm_backend and ttm_tt j.glisse
2011-11-02 23:37 ` [PATCH 8/8] drm/ttm: introduce callback for ttm_tt populate & unpopulate j.glisse
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1320277075-19980-1-git-send-email-j.glisse@gmail.com \
--to=j.glisse@gmail.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=thellstrom@vmware.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox