From: "Christian König" <deathsimple@vodafone.de>
To: dri-devel@lists.freedesktop.org
Cc: "Christian König" <deathsimple@vodafone.de>
Subject: [PATCH 11/26] drm/radeon: return -ENOENT in fence_wait_next v2
Date: Wed, 25 Apr 2012 14:46:28 +0200 [thread overview]
Message-ID: <1335358003-2987-12-git-send-email-deathsimple@vodafone.de> (raw)
In-Reply-To: <1335358003-2987-1-git-send-email-deathsimple@vodafone.de>
We should signal the caller that we haven't waited at all.
v2: only change fence_wait_next not fence_wait_last.
Signed-off-by: Christian König <deathsimple@vodafone.de>
---
drivers/gpu/drm/radeon/radeon_fence.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/gpu/drm/radeon/radeon_fence.c b/drivers/gpu/drm/radeon/radeon_fence.c
index 1a9765a..2fbbc34 100644
--- a/drivers/gpu/drm/radeon/radeon_fence.c
+++ b/drivers/gpu/drm/radeon/radeon_fence.c
@@ -286,7 +286,7 @@ int radeon_fence_wait_next(struct radeon_device *rdev, int ring)
}
if (list_empty(&rdev->fence_drv[ring].emitted)) {
write_unlock_irqrestore(&rdev->fence_lock, irq_flags);
- return 0;
+ return -ENOENT;
}
fence = list_entry(rdev->fence_drv[ring].emitted.next,
struct radeon_fence, list);
--
1.7.5.4
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel
next prev parent reply other threads:[~2012-04-25 12:46 UTC|newest]
Thread overview: 37+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-04-25 12:46 Reworking of GPU reset logic Christian König
2012-04-25 12:46 ` [PATCH 01/26] drm/radeon: make radeon_gpu_is_lockup a per ring function Christian König
2012-04-25 12:46 ` [PATCH 02/26] drm/radeon: replace gpu_lockup with ring->ready flag Christian König
2012-04-25 12:46 ` [PATCH 03/26] drm/radeon: register ring debugfs handlers on init Christian König
2012-04-25 12:46 ` [PATCH 04/26] drm/radeon: use central function for IB testing Christian König
2012-04-25 12:46 ` [PATCH 05/26] drm/radeon: rework gpu lockup detection and processing Christian König
2012-04-25 12:46 ` [PATCH 06/26] drm/radeon: fix a critical bug in the SA code Christian König
2012-04-25 13:19 ` Michel Dänzer
2012-04-25 13:36 ` Christian König
2012-04-25 13:40 ` Alex Deucher
2012-04-25 14:34 ` Jerome Glisse
2012-04-25 15:38 ` Christian König
2012-04-25 12:46 ` [PATCH 07/26] drm/radeon: add proper locking to the SA v2 Christian König
2012-04-25 12:46 ` [PATCH 08/26] drm/radeon: add sub allocator debugfs file Christian König
2012-04-25 12:46 ` [PATCH 09/26] drm/radeon: add biggest hole tracking and wakequeue to the sa v3 Christian König
2012-04-25 12:46 ` [PATCH 10/26] drm/radeon: simplify semaphore handling Christian König
2012-04-25 12:46 ` Christian König [this message]
2012-04-25 12:56 ` [PATCH 11/26] drm/radeon: return -ENOENT in fence_wait_next v2 Michel Dänzer
2012-04-25 12:46 ` [PATCH 12/26] drm/radeon: rename fence_wait_last to fence_wait_empty Christian König
2012-04-25 12:57 ` Michel Dänzer
2012-04-25 12:46 ` [PATCH 13/26] drm/radeon: rip out the ib pool Christian König
2012-04-25 12:46 ` [PATCH 14/26] drm/radeon: fix a bug with the ring syncing code Christian König
2012-04-25 12:46 ` [PATCH 15/26] drm/radeon: rework recursive gpu reset handling Christian König
2012-04-25 12:46 ` [PATCH 16/26] drm/radeon: remove recursive mutex implementation Christian König
2012-04-25 12:46 ` [PATCH 17/26] drm/radeon: move lockup detection code into radeon_ring.c Christian König
2012-04-25 12:46 ` [PATCH 18/26] drm/radeon: make lockup timeout a module param Christian König
2012-04-25 12:46 ` [PATCH 19/26] drm/radeon: unlock the ring mutex while waiting for the next fence Christian König
2012-04-25 12:46 ` [PATCH 20/26] drm/radeon: make forcing ring activity a common function Christian König
2012-04-25 12:46 ` [PATCH 21/26] drm/radeon: remove r300_gpu_is_lockup Christian König
2012-04-25 12:46 ` [PATCH 22/26] drm/radeon: remove cayman_gpu_is_lockup Christian König
2012-04-25 12:46 ` [PATCH 23/26] drm/radeon: add missing locking to fence debugfs function Christian König
2012-04-25 12:46 ` [PATCH 24/26] drm/radeon: extend ring debugfs files with fence info Christian König
2012-04-25 12:46 ` [PATCH 25/26] drm/radeon: keep the cs relocs inside the ib Christian König
2012-04-25 12:46 ` [PATCH 26/26] drm/radeon: add the ib content and relocs to the ring debugfs file Christian König
2012-04-25 14:36 ` Jerome Glisse
2012-04-25 15:47 ` Christian König
2012-04-25 16:15 ` Jerome Glisse
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1335358003-2987-12-git-send-email-deathsimple@vodafone.de \
--to=deathsimple@vodafone.de \
--cc=dri-devel@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox